[HowTo][INFO] Wifi Drop Caused by "Sign-in to WiFi Network" Notification [KitKat BUG]

Search This thread

M_J_Nazari

Inactive Recognized Developer
Jul 14, 2010
1,545
2,577
35
Bushehr
pda-planet.com
[HowTo][INFO] Wifi Drop Caused by "Sign-in to WiFi Network" Notification [KitKat BUG]

Hi guys

when i updated my phone from 4.2.2 to 4.4.2 samsung roms, i faced with this bug and it drives me to crazy and certainly the madness. :crying:

i searched a lot but not found any solution, tried 2 days and finally got the solution.

whats the problem ?
When i connected my phone to my router [TP-Link] , the connection will stay for less than 2 minutes and show me this message!

attachment.php



Your device has been disconnected from this network. Your session has timed out.

after this, my wifi dropped and need to sign-in again, show me this message "Sign into Wi-Fi network"


and i found it caused by checking the wifi activity with Google servers, i don't know why Google should check our connectivity with their clients?!

and we should block the google client servers to pass this check process.

block this url:
Code:
clients3.google.com

----------------------------------------------

Solution A :
1- Goto your modem router configuration, type in your browser
Code:
192.168.1.1

input your username and password of your modem, defaults are :
username : admin
password : admin

if not works, read your modem's manual book. or check the behind info's label of your modem.


2- goto "Access Management" , and select the "Filter" tab.

do this settings:
Filter Type Selection = URL Filter
Active = Yes
URL Index = 1
URL = http://clients3.google.com/

3- select "Save" button and done.

your network will be fine! :good:

it should be like this
attachment.php


-----------------------------------------------------------------------------------------
Solution B , for who cant access to Modem settings, like free wifi services.

All actions will be done from your device.

1- goto Settings > WiFi settings
2- long-press on Connection
3- Select "Modify network config"
4- check the "Show advanced options" tick.
5- select proxy settings to Manual
6- proxy host name , input the value from 192.168.1.1 to 192.168.1.225
7- Proxy port = input one of them "8080" , "3128" , "80"
8- press the "Save".
9- turn wifi off and the On, you will not see the message ""Sign into Wi-Fi network"
10-now repeat the steps from 1 ~ 4
11- and revert back the proxy settings to "None", its Done.
12- you will be fine with this network.

------------------------------------------------------------------------------
I'll hope someone build the xposed module to bypass the "Sign into Wi-Fi network" process.


Don't forget to hit the Thanks! :D


In Persian Language , read here ,, برای فارسی زبان ها ، به اینجا مراجعه کنید
 
Last edited:

methuselah

Senior Member
Aug 25, 2011
3,856
2,133
this is great..

i still remember my friend has the same issue with his tp link router. he always had a prob with this 4.4 rom. today i just put these settings into his wifi. lets see how well this gonna work.cheers:good:
 
Thanks for this temp fix
but i don't think that this is a kitkat's problem nor a google's one
i started to face this problem when i upgraded my samsung s3 to android 4.3
but the problem is not available on my nexus 5 4.4.1 -> 4.4.4
note: both phones work on the same connection
so i think it might be a samsung touchwiz problem
 
Last edited:

khanmein

Senior Member
Nov 28, 2011
1,235
194
Batu Pahat
solution B same like doin on the adblock.. whether i set proxy under wifi, there will be no connection to play store or browser..

proxy host name: localhost or 192.168.1.xxx
port 2020 or 8080
 

dhiru1602

Inactive Recognized Developer
Aug 23, 2010
1,865
13,668
Proper way to fix this would be to make an exposed module to prevent the framework from performing connectivity checks. By blocking clients3.google.com, you might stand a chance of blocking core Google services.
 
  • Like
Reactions: Simba501

Publiuss

Senior Member
Jun 29, 2012
948
170
Proper way to fix this would be to make an exposed module to prevent the framework from performing connectivity checks. By blocking clients3.google.com, you might stand a chance of blocking core Google services.

Good point!
Is it related to "google checkin"? If so, there's a build.prop string to disable it.
 

jpwhre

Senior Member
Aug 3, 2008
556
77
Tucson
I searched this a few months ago and found that the update in android was doing this a lot, my htc one m7, note 2, and galaxy tab 7 were all having constant drops even while surfing the web it would suddenly dip while going to a site. It started with checking my netgear wndr900 and found many having problems with various versions of netgear routers and android devices with the kit Kat update, so I bought a linksys wrt1900, and the constant drops have become not quit as constant. I was still using a netgear device at work with constant drops. It has something to do with the google api is something I read somewhere else (can't recall where) as my laptop and both my ipads went affected.

Am currently running an unofficial release of a Sprint update to 4.4.3 and it still has dropping issues.
 

munjeni

Senior Member
Jun 2, 2011
9,204
21,873
I searched this a few months ago and found that the update in android was doing this a lot, my htc one m7, note 2, and galaxy tab 7 were all having constant drops even while surfing the web it would suddenly dip while going to a site. It started with checking my netgear wndr900 and found many having problems with various versions of netgear routers and android devices with the kit Kat update, so I bought a linksys wrt1900, and the constant drops have become not quit as constant. I was still using a netgear device at work with constant drops. It has something to do with the google api is something I read somewhere else (can't recall where) as my laptop and both my ipads went affected.

Am currently running an unofficial release of a Sprint update to 4.4.3 and it still has dropping issues.
Yes, all low cost routers have these drops since something android side break things while using wpa, wpa2... encription! If you set simple VEP encription on your router wifi your problem is solved!
 

albysprx

Senior Member
Nov 10, 2012
441
143
Yes, all low cost routers have these drops since something android side break things while using wpa, wpa2... encription! If you set simple VEP encription on your router wifi your problem is solved!

WEP encryption can be cracked in less than 1 hour, i would not recommend it

---------- Post added at 10:31 PM ---------- Previous post was at 10:24 PM ----------

ok here is the netgear router steps...
go to 192.168.0.1 , type: (if you not changed it)
admin
password
THtnq0l.png

next go to block sites, paste clients3.google.com on Type keyword or domain name here:
WFBSZrx.png

next click add keyword:
nuS56Z3.png

Enjoy!:
lD6brin.png
 

Mardon

Inactive Recognized Contributor
Mar 5, 2008
3,995
5,970
Hamburg
markusmenzel.de

venky716

Senior Member
Sep 9, 2011
989
722
This is one of the biggest problem I had, I always blamed my phone for dropping wifi.

Now I've switched to D-link router from Tp-link and wifi drop issue doesn't exist anymore but I do have a different issue, battery drain.
It is definitely related to the router since it doesn't happen on other routers.

The problem is that router seems to keep the phone awake by pinging it constantly, which results in kernel wakelocks named 'EventX-xxxx'.

I was hoping since you solved my other biggest problem with the router you could figure this one out as well. :fingers-crossed:

INFO:
D-link 2750u
Phone - Oneplus one, Nexus 5, Xperia Z, Moto G. (All have the issue but only when connected to Dlink router and running CM based ROMs, doesn't happen with Moto G on stock)
Already reported on JIRA .

Googled a lot and found just oneinstance of it being reported, tried the solution of disabling Multicast but couldn't find it in router setting, also tried every other solution found related to wifi wakelocks like static IP, disabling DHCP, disconnecting other devices, disabling microsoft services iphelper etc nothing worked.

Grateful if you could help
 
  • Like
Reactions: Persechini

Persechini

Senior Member
Mar 12, 2012
439
151
Rio de Janeiro
I just enabled blocking clients3.google.com on my router but only for my device, and the tip venky716 posted. I usually get none, 1 or 2 drops wifi a day (which only come back if I restart the router) but let's see if these improve the situation
 

munjeni

Senior Member
Jun 2, 2011
9,204
21,873
WEP encryption can be cracked in less than 1 hour, i would not recommend it

Not true if you setup a strong password. In any way I just giving good solutions for everybody who have low cost router and problems with wifi random disconnections which is caused by bad wpa and wpa2 on low cost routers.
 

albysprx

Senior Member
Nov 10, 2012
441
143
Not true if you setup a strong password. In any way I just giving good solutions for everybody who have low cost router and problems with wifi random disconnections which is caused by bad wpa and wpa2 on low cost routers.

only some hours more... because with WEP you can use brute force attack, and with WPA/WPA2 only dictionary attack or WPS attack...
 
  • Like
Reactions: flastnoles11

Top Liked Posts

  • There are no posts matching your filters.
  • 63
    [HowTo][INFO] Wifi Drop Caused by "Sign-in to WiFi Network" Notification [KitKat BUG]

    Hi guys

    when i updated my phone from 4.2.2 to 4.4.2 samsung roms, i faced with this bug and it drives me to crazy and certainly the madness. :crying:

    i searched a lot but not found any solution, tried 2 days and finally got the solution.

    whats the problem ?
    When i connected my phone to my router [TP-Link] , the connection will stay for less than 2 minutes and show me this message!

    attachment.php



    Your device has been disconnected from this network. Your session has timed out.

    after this, my wifi dropped and need to sign-in again, show me this message "Sign into Wi-Fi network"


    and i found it caused by checking the wifi activity with Google servers, i don't know why Google should check our connectivity with their clients?!

    and we should block the google client servers to pass this check process.

    block this url:
    Code:
    clients3.google.com

    ----------------------------------------------

    Solution A :
    1- Goto your modem router configuration, type in your browser
    Code:
    192.168.1.1

    input your username and password of your modem, defaults are :
    username : admin
    password : admin

    if not works, read your modem's manual book. or check the behind info's label of your modem.


    2- goto "Access Management" , and select the "Filter" tab.

    do this settings:
    Filter Type Selection = URL Filter
    Active = Yes
    URL Index = 1
    URL = http://clients3.google.com/

    3- select "Save" button and done.

    your network will be fine! :good:

    it should be like this
    attachment.php


    -----------------------------------------------------------------------------------------
    Solution B , for who cant access to Modem settings, like free wifi services.

    All actions will be done from your device.

    1- goto Settings > WiFi settings
    2- long-press on Connection
    3- Select "Modify network config"
    4- check the "Show advanced options" tick.
    5- select proxy settings to Manual
    6- proxy host name , input the value from 192.168.1.1 to 192.168.1.225
    7- Proxy port = input one of them "8080" , "3128" , "80"
    8- press the "Save".
    9- turn wifi off and the On, you will not see the message ""Sign into Wi-Fi network"
    10-now repeat the steps from 1 ~ 4
    11- and revert back the proxy settings to "None", its Done.
    12- you will be fine with this network.

    ------------------------------------------------------------------------------
    I'll hope someone build the xposed module to bypass the "Sign into Wi-Fi network" process.


    Don't forget to hit the Thanks! :D


    In Persian Language , read here ,, برای فارسی زبان ها ، به اینجا مراجعه کنید
    3
    Reserved for more info..
    3
    Yes, all low cost routers have these drops since something android side break things while using wpa, wpa2... encription! If you set simple VEP encription on your router wifi your problem is solved!

    WEP encryption can be cracked in less than 1 hour, i would not recommend it

    ---------- Post added at 10:31 PM ---------- Previous post was at 10:24 PM ----------

    ok here is the netgear router steps...
    go to 192.168.0.1 , type: (if you not changed it)
    admin
    password
    THtnq0l.png

    next go to block sites, paste clients3.google.com on Type keyword or domain name here:
    WFBSZrx.png

    next click add keyword:
    nuS56Z3.png

    Enjoy!:
    lD6brin.png
    2
    This will break WiFi- HotSpot logins if you block it on Android device side (via hosts or AdAway).
    It is the Android Network Portal detection by querying the URL clients3.google.com /generate_204

    For more info visit: https://groups.google.com/forum/#!msg/android-platform/ATSxh0kG7cc/niuBMs05ip0J

    Should be safe to set it on blocklist in your Router.
    1
    Proper way to fix this would be to make an exposed module to prevent the framework from performing connectivity checks. By blocking clients3.google.com, you might stand a chance of blocking core Google services.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone