• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[HowTo][INFO] Wifi Drop Caused by "Sign-in to WiFi Network" Notification [KitKat BUG]

Search This thread

electricpete1

Senior Member
Aug 12, 2012
477
188
I blocked the google site on my router and it didn't seem to work.
Then I tweaked my location settings to disallow use of wifi for location. It seems to have worked.

Unless there was some delayed effect in my router setting, the router changes didn't work. Turning of location via wifi worked.
 
  • Like
Reactions: Simba501

Legatus Onoris

Senior Member
Apr 28, 2011
147
22
33
Rimini
I have this problem with my new note 4. I don't know if it's a bug, it's a not good compatibility with my Neatgear DG834v5 (it's a little old but it's a very good router and it's quite common). I tried everything and uff, now I only wait lollipop in order to find if the problem is software.
In the meantime I live with this bug and try something (for instance, now I'm trying to block the client.google url but I'm quite sure it won't work)

update: as I wrote, I can confirm that this solution doesn't work, I blocked the client.google but the wifi drops randomly.
 
Last edited:

electricpete1

Senior Member
Aug 12, 2012
477
188
I have this problem with my new note 4. I don't know if it's a bug, it's a not good compatibility with my Neatgear DG834v5 (it's a little old but it's a very good router and it's quite common). I tried everything and uff, now I only wait lollipop in order to find if the problem is software.
In the meantime I live with this bug and try something (for instance, now I'm trying to block the client.google url but I'm quite sure it won't work)

update: as I wrote, I can confirm that this solution doesn't work, I blocked the client.google but the wifi drops randomly.
I'd recommend going to location services and turning off "use wireless networks". Seems to have worked for me.
 

mike2246

Senior Member
Dec 29, 2006
159
3
I have a Nighthawk R7000 and Galaxy S5 (Optimal Rom) getting same sign-in requrired. when I added a proxy it went away. changed back to none and it came back. I did block the clients3.google in the router and still have this problem.
 

Ron007d

Member
Oct 22, 2015
49
4
Which address the android takes to login in to wifi??? Anyone have rooted android to see?

Sent from my Redmi 3S using Tapatalk
 

Sangeeth1

Member
Sep 11, 2014
9
0
This fixed the issue in my Galaxy note 10.1 also. But as far as I noticed, it's happening after a certain action related to the ISP in my case. I have BSNL fiber broadband internet connection that has a limit on the amount of free high speed internet. Once the limit is crossed whenever you sign in to the WiFi the first thing it does is to take you to a webpage of BSNL (which has no URL name but an IP address, and looks much like the sign in page of public WiFi points.) and you have to press the agree button to continue using the free yet speed limited internet. That is, the intermittent IP login, what causing the issue for me. Once I agreed to the IP page using the computer, the issue seems to be gone. My Galaxy Tab is functioning normally now. The interesting thing is, if the client 3.google .com is blocked, the above mentioned IP address page will not show up , even in my pc, hence in effect the issue will continue.
 

Eternal99

New member
Jun 19, 2018
2
0
Works

After almost throwing my ancient Note 2 4.4.2, against the wall. Solution B works 100% Thanks.... :good:
 

bionicbone99

Member
Dec 13, 2012
18
2
WORKED!!

Hi guys

when i updated my phone from 4.2.2 to 4.4.2 samsung roms, i faced with this bug and it drives me to crazy and certainly the madness. :crying:

i searched a lot but not found any solution, tried 2 days and finally got the solution.

whats the problem ?
When i connected my phone to my router [TP-Link] , the connection will stay for less than 2 minutes and show me this message!

attachment.php



Your device has been disconnected from this network. Your session has timed out.

after this, my wifi dropped and need to sign-in again, show me this message "Sign into Wi-Fi network"


and i found it caused by checking the wifi activity with Google servers, i don't know why Google should check our connectivity with their clients?!

and we should block the google client servers to pass this check process.

block this url:
Code:
clients3.google.com

----------------------------------------------

Solution A :
1- Goto your modem router configuration, type in your browser
Code:
192.168.1.1

input your username and password of your modem, defaults are :
username : admin
password : admin

if not works, read your modem's manual book. or check the behind info's label of your modem.


2- goto "Access Management" , and select the "Filter" tab.

do this settings:
Filter Type Selection = URL Filter
Active = Yes
URL Index = 1
URL = http://clients3.google.com/

3- select "Save" button and done.

your network will be fine! :good:

it should be like this
attachment.php


-----------------------------------------------------------------------------------------
Solution B , for who cant access to Modem settings, like free wifi services.

All actions will be done from your device.

1- goto Settings > WiFi settings
2- long-press on Connection
3- Select "Modify network config"
4- check the "Show advanced options" tick.
5- select proxy settings to Manual
6- proxy host name , input the value from 192.168.1.1 to 192.168.1.225
7- Proxy port = input one of them "8080" , "3128" , "80"
8- press the "Save".
9- turn wifi off and the On, you will not see the message ""Sign into Wi-Fi network"
10-now repeat the steps from 1 ~ 4
11- and revert back the proxy settings to "None", its Done.
12- you will be fine with this network.

------------------------------------------------------------------------------
I'll hope someone build the xposed module to bypass the "Sign into Wi-Fi network" process.


Don't forget to hit the Thanks! :D


In Persian Language , read here ,, برای فارسی زبان ها ، به اینجا مراجعه کنید

Solution B worked for me :)

Thanks a million!!
Kev
 

Sizzlechest

Senior Member
Dec 18, 2010
1,113
191
I had this issue, too. I tried blocking the google address from my router, but I could still ping it. I installed Blockada 4 and blocked that host. It's stable until I restart it. Blockada does start with the phone, but you have to open the app to get the wifi stable.

I think I'll root the phone and manually add it to the hosts file instead.

Edit: This problem existed on a factory reset of Android 6.0.1 Build MMB29M.G900TUVU1GQC2 until all the apps were updated on the Google Play store. It might have been one (or more) of the following updates that fixed the WiFi issue:

Samsung Security Policy Update
Samsung Push Service
Samsung Print Service Plugin

There were a bunch of other updates, including a whole slew of Google apps, too. I have disabled Blockada and WiFi is stable.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 63
    [HowTo][INFO] Wifi Drop Caused by "Sign-in to WiFi Network" Notification [KitKat BUG]

    Hi guys

    when i updated my phone from 4.2.2 to 4.4.2 samsung roms, i faced with this bug and it drives me to crazy and certainly the madness. :crying:

    i searched a lot but not found any solution, tried 2 days and finally got the solution.

    whats the problem ?
    When i connected my phone to my router [TP-Link] , the connection will stay for less than 2 minutes and show me this message!

    attachment.php



    Your device has been disconnected from this network. Your session has timed out.

    after this, my wifi dropped and need to sign-in again, show me this message "Sign into Wi-Fi network"


    and i found it caused by checking the wifi activity with Google servers, i don't know why Google should check our connectivity with their clients?!

    and we should block the google client servers to pass this check process.

    block this url:
    Code:
    clients3.google.com

    ----------------------------------------------

    Solution A :
    1- Goto your modem router configuration, type in your browser
    Code:
    192.168.1.1

    input your username and password of your modem, defaults are :
    username : admin
    password : admin

    if not works, read your modem's manual book. or check the behind info's label of your modem.


    2- goto "Access Management" , and select the "Filter" tab.

    do this settings:
    Filter Type Selection = URL Filter
    Active = Yes
    URL Index = 1
    URL = http://clients3.google.com/

    3- select "Save" button and done.

    your network will be fine! :good:

    it should be like this
    attachment.php


    -----------------------------------------------------------------------------------------
    Solution B , for who cant access to Modem settings, like free wifi services.

    All actions will be done from your device.

    1- goto Settings > WiFi settings
    2- long-press on Connection
    3- Select "Modify network config"
    4- check the "Show advanced options" tick.
    5- select proxy settings to Manual
    6- proxy host name , input the value from 192.168.1.1 to 192.168.1.225
    7- Proxy port = input one of them "8080" , "3128" , "80"
    8- press the "Save".
    9- turn wifi off and the On, you will not see the message ""Sign into Wi-Fi network"
    10-now repeat the steps from 1 ~ 4
    11- and revert back the proxy settings to "None", its Done.
    12- you will be fine with this network.

    ------------------------------------------------------------------------------
    I'll hope someone build the xposed module to bypass the "Sign into Wi-Fi network" process.


    Don't forget to hit the Thanks! :D


    In Persian Language , read here ,, برای فارسی زبان ها ، به اینجا مراجعه کنید
    3
    Reserved for more info..
    3
    Yes, all low cost routers have these drops since something android side break things while using wpa, wpa2... encription! If you set simple VEP encription on your router wifi your problem is solved!

    WEP encryption can be cracked in less than 1 hour, i would not recommend it

    ---------- Post added at 10:31 PM ---------- Previous post was at 10:24 PM ----------

    ok here is the netgear router steps...
    go to 192.168.0.1 , type: (if you not changed it)
    admin
    password
    THtnq0l.png

    next go to block sites, paste clients3.google.com on Type keyword or domain name here:
    WFBSZrx.png

    next click add keyword:
    nuS56Z3.png

    Enjoy!:
    lD6brin.png
    2
    This will break WiFi- HotSpot logins if you block it on Android device side (via hosts or AdAway).
    It is the Android Network Portal detection by querying the URL clients3.google.com /generate_204

    For more info visit: https://groups.google.com/forum/#!msg/android-platform/ATSxh0kG7cc/niuBMs05ip0J

    Should be safe to set it on blocklist in your Router.
    1
    Proper way to fix this would be to make an exposed module to prevent the framework from performing connectivity checks. By blocking clients3.google.com, you might stand a chance of blocking core Google services.