General HowTo: Root Joying SC9853i Head Unit

Search This thread


Jul 22, 2017
Hey I did a quick search of the thread about any
queries regarding Joying’s new Android 10 head units using a new chipset UIS7862, rather than SC9853i, having root but seems to be no clarity on that. So just asking if root is possible or perhaps in the making for the new products?


Senior Member
Aug 17, 2009
Just to check, does signing works for other branded fyt units?

Sent from my SM-N975F using Tapatalk


New member
Feb 25, 2018
Hey there I'm wondering if you can help me. I'm trying to root my joying head unit.. I placed both the files you listed onto a USB, the head unit picked it up and a message popped up saying its about to update. However, all that happened was the screen went black for 2 seconds then the head unit rebooted back up. Once it rebooted, the update message popped up again and the same thing happened. The device kept rebooting until I removed the USB. The head unit is working fine but there is no root access. Am I doing something wrong? any help will be appreciated. Thank you.


Senior Member
Jun 14, 2008
No command

I am having issues with rooting. I am on the latest firmware from April. The process looks normal until i get a message that says "No command". Then it just reboots. I am using the image from post #351. Really the only reason I am trying to get root is because after the last update my screen dimmer no longer works. It is at 100% no matter how low I put it. I am having to use a screen filter at night and I would like to auto launch it at certain times. Maybe I will try re flashing the stock image and it will fix itself.

Never mind. I searched No command and found the answer. It did not fix my screen brightness though.
Last edited:


Senior Member
Apr 29, 2015
hi guys, we're 3 friends with Prelingcar tesla style head unit with this cpu. We've installed latest android 10 firmware and now 2 of these head unit are withtou reverse camera; moreover, we're without parking sensors and I think it's related to che mcu version. We've carchoose.apk to download it but before first update from this apk, parking sensors were working!! Then, anyone has mcu file for FORD FOCUS MK3?


New member
Oct 23, 2020
MCU Problem with update, no sound


I am having trouble updating my MCU. I've been randomly losing this driver for a while now. After starting the car, the radio has a problem with starting (android works fine, no sound from the radio) when the MCU starts, the version is unknown. After 5 minutes, the device resets, sometimes the MCU will load and everything works until the car is turned off again.
During the update (SD Card FAT32, empty only with the original files from the joying blog - Trying few others), the information that SDCARD cannot be mounted

It goes to the line where the STM32UD was updated correctly, then the line with the description: "2019.09.07 10:40:57 JY_53_C63L_H32P48F64_Ver: 1.0" - the device is locked here, nothing happens - after 5 minutes, restart the device and loop.

How the device works properly MCU Version is:
2019.09.07 10:40:57 JY_53_C63L_H32P48F64_Ver: 1.0

CPU Info:
Intel X86_Octa-Coire 1.8Ghz [email protected] + 32 GB

Android 8.1

What should I do, what file should I use? Radio is:
Joying JY-UO135N4G

I don't speak perfect English, I use a translator. For thorough help, sending any files, I am able to use a grant. I am asking for help in solving the problem.

I am asking for information which data is still needed to solve the problem. The device is rotated.

After struggling to start the device, I did not have an MCU, I used Joying Extra Tool and the option -Rebot Option - Soft Reboot (Gui only, sufficient for all apk replacements)

After starting the car, the panel LEDs light up for 2 seconds and then they turn off, the device usually starts after a few minutes, the vehicle's logo is displayed with a countdown from 5 to 0, the device stops on the number 0. I have to hold power off and manually reset the device, then Andorid is charging correctly.

Twice after using it, the device started working properly. The MCU showed up in the settings.

System info:
Kernel: #451 SMP PREEMPT FRI MAR 29 2019
Platform: (24)6313 LF Full band carplay
touch: 911_1060(263efcda)E:0

APP 1024x600 2019-11-28 15:50:42
System 2019-11-28 09:40:06 Thursday
Last edited:


Oct 8, 2012
Hi, I am looking to root my headunit, but the firmware version is dated 2020-06-22 so I do not have a dump of it to modify using the method here. Can I just use the old bootloader and root?

[edit] - the unit is a JY-VO130N4GSN
Last edited:


Dec 26, 2013
Hello you experts
I have a Joying 10.25 universal unit Intel 1240 x 480 unfortunately flashed the wrong MCU and now I only have about 30-40% background lighting can help me? I read that you can adjust the brightness in the
for that you need root right I don't have that and I can't find Boot.img for
9853i OS 1280X480 Old UI 2019.11.28 mcu 32
Pleace Help me
Thanks Werner


Senior Member
May 4, 2010
Hello you experts
I have a Joying 10.25 universal unit Intel 1240 x 480 unfortunately flashed the wrong MCU and now I only have about 30-40% background lighting can help me? I read that you can adjust the brightness in the
for that you need root right I don't have that and I can't find Boot.img for
9853i OS 1280X480 Old UI 2019.11.28 mcu 32
Pleace Help me
Thanks Werner

Why don't you download the correct MCU firmware and flash that one?
Last edited:


Senior Member
Mar 16, 2011
Why don't you download the correct MCU firmware and flash that one?
I have a Atoto S8 ultra. I wanted root. I compared the patchedboot.img and it was comparable to Atotos boot.img for the same chip, resolution and GPU.

I downloaded the 1024x600 and it didn't brick my head unit.

But the radio stopped working, and the red letters "Need check active. ID 1.Area 2"
- what is that error referring to?

I can revert back to the Atoto firmware, but I'd really like root.


Senior Member
May 4, 2010
The rooting process as described in the first post using Magisk is really a general purpose rooting method. The latest Magisk makes it even more easy. Search for magisk on XDA.
The boot image is for a great deal the same (apart from architecture: ARM, Mips or intel) for all Android systems but can contain few changes that can completely brick your system or make certain hardware/software based options (in your case) not function. Especially those Chinese Android head units contain a lot of hardware normally not available in phones or tablets. Some of that config/drivers/software is included in the firmware (/vendor for example), some in the MCU firmware and some in the boot image.

Please create your own boot image for your system: You can use any "howto" that comes a bit close to your unit. Using Magisk "parts" you can even do that manually: pda has a post about that, but I currently can't find it (I didn't bookmark it as I don't need it ).


Senior Member
Jan 17, 2011
OnePlus 7 Pro
Hi there!

Apologies if this has already been asked and answered but Joying recently uploaded updated firmware files in April 2021. Included in these files is firmware for the 13.3 inch 1920x1080 resolution headunits!

Instead of 6521_1 it is 6315_zip

Does anyone happen to know if the instructions listed in could still apply to this firmware? Would love to actually be able to root my head unit as ADB is not natively available via usb ports or wifi, making any kind of modifications or application development a pain.



Senior Member
Jan 17, 2011
OnePlus 7 Pro
Don't use it!
6315 is for the uis7862 units, not for the sc9853i units.

Unfortunately I think I was just too late or too early with the purchase of this particular unit. When I bought this one, joying wasn't selling it on their site: instead i had to email sales directly to purchase it. It's a 13.3 inch 1920x1080 sc9853i unit. Works great but I guess joying decided to tweak it further before selling it to the public so the closest version available for sale from them is a 6 core version of this unit. Very similar but not exactly the same.
The i mentioned above found on joying's website is NOT compatible with my unit as you have mentioned.

All that said, I managed to talk joying into sending me the original firmware for MY unit which does include
Just to be safe, I even installed it on my unit (without any mods) and it installed and booted up just fine.

So at this point I tried following the instructions in in this post and made a patched boot.img
When installing this however It unfortunately results in a soft boot loop.
I can exit the boot loop by placing the unmodified update back onto the usb.

Any ideas what could be going wrong?
I think it's worth noting i followed the instructions in the readme pretty closely but had trouble getting magisk on my unit to agree to patch the boot img as in the instructions so instead i used another device to output a patched boot img using the same input file (the boot img from the file joying sent me)
That shouldn't cause any problems though should it?

If it helps the error I got in magisk on the headunit was "Cannot unzip zip, installation failed"

Edit: it looks like that was the problem.
Magisk kept insisting on updating on my unit to 23 version no matter what update channel i picked or if i disabled updates. Once magisk updates it is unable to unzip the boot image on my unit. A google search showed that a few other users have had the same issue with later magisk versions with no posted solutions that I could find.
What I did was I just created my own magisk update server using flask and python but where I told it that the latest magisk version was 20.4. this version was perfectly capable of patching my boot image and I was able to successfully flash this onto my unit. Woohoo!
Butttttt... I also am experiencing the google voice no feedback bug. Boooo!
I can revert the google voice bug by just uninstalling magisk but its really disappointing that there doesn't seem to be a solution for this yet. (unless I'm quite mistaken).
If this is a known issue, would it be possible to update the OP to provide this as a disclaimer? Just a suggestion.
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 21
    First off a big thanks to the guys at {Mod edit} for doing all the hard work, I'm just writing this post as a guide for those who don't speak Russian - like myself :)
    Second thanks to all those on the Original Thread ( for helping me finally find an android head unit worth buying.

    Compatible Firmware Versions:
    • 9853i 800X480 2019.3.20
    • 9853i 1024X600 2019.3.29
    • "New" 9853i 1280X480 新UI 2019.3.18
    • "Old" 9853i 1280X480 旧UI 2019.3.18

    Legacy Support

    • April 10 2019:
      • Added new files for several units

    Previous Changelogs:

    • April 4 2019:
      • Fixed typo in Developer instructions
      • Added "Ultra Wide" version
    • March 28 2019:
      • Simplified Installation Process
      • Reformatted instructions

    • I am not responsible for bricked devices. Proceed through this rooting process at your own risk.
    • Rooting your device will void Joying's waranty. (Even though it can be uninstalled in Magisk Manager).


    Rooting Your Device
    1. Plug your Flash Drive or MicroSD into your computer. Make sure there's nothing on it.
    2. Extract the contents of the device-appropriate archive to your flash drive. You should have 2 files: "lsec6521update" and "".
    3. Go to your head unit. Moment of truth; no turning back once you begin this next step! Plug your flash drive into the head unit. The update will be detected and the update will automatically begin.
    4. Your head unit will reboot into recovery and install the update containg root. DO NOT POWER OFF YOUR DEVICE OR UNPLUG THE FLASH DRIVE DURING THIS PROCESS!!! If you do, you may permanantly brick your device! Once prompted by the update process, remove your Flash Drive and let it boot back up into Android.

    If you would like the more in depth "developer" tutorial, attached is
    Inside I included "Readme.rtf" - a copy of the developer instructions with screenshots.
    Senior members, after following the above proceedure, I have a Joying-signed "" file containg Magisk.
    Is this file specific to my unit or will others be able to flash this file to get root? If so it would make the rooting process a lot faster and noob-friendly. Thanks!
    Please see attached update file.
    Unzip to root of an empty flash drive and plug into head unit. Device will update automatically.
    I got emailed the update link to this morning also for the new firmware, just flashed it and it fixed all my problems (voice, notification bar etc)
    Im stoked. :) Joying has been super good and responding to emails and fixing stuff. One of the reasons I bought a Joying over some of the other crap out there.

    Here is the patched boot.img with magisk file: Magisk 9853i 1024X600 or 800X480 Google 2019.5.15

    Cant upload the firmware at work unfortunately but was able to patch the boot.img while driving to work :p
    Starting any user app on boot

    So with the risk of looking like an idiot I want to share something for others in my situation on this Joying head unit:

    I originally only rooted and struggled for the past 2 weeks unsuccessfully with xposed, because I wanted a way to start a "tasker app" on boot.
    For some unknown reason (to me at least) neither Tasker, Automate or Macrodroid are allowed to start on boot. Don't know if it's Joying firmware or Oreo in general as google comes up with this issue in general for Oreo.

    So today I played around in Setting and in there are both "Start Navi app on launch" & an option to set the Navi app of choice. I never took much notice about this earlier, and I just assumed you could only choose installed Navi apps in there. But to my surprise you can choose any installed app.
    -So I have now solved my objective by simply setting Tasker in this setting and Tasker now starts on boot, and from Tasker I can start all other apps or tasks (like a Navi app so you dont loose that option). This is a perfect workaround and does not require root at all.
    Tasker can still only survive Sleep mode if you install the NoKill mod, but I dont use sleep mode anyway as boot is rather fast and ensure my 4g/wifi hotspot is already live when unit is done booting.

    I don't know if this has been there always in previous Android versions/units so please bare with me if this is the case.
    Previous terminal command apk wasn't fully compatible with magisk and not to ask superuser grants. I found a new one and tried to generate other files, hope it is good enough but it is not so easily from an average garage...

    This is exactly what I need. Thanks.
    I will start extending the JET apk