• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

General HowTo: Root Joying SC9853i Head Unit

Search This thread


Aug 30, 2020
I was able to use the latest Magisk on my newer unit to patch my boot image. The newest Magisk doesnt seem to do much and I had to search through Magisk a bit to find the patching function but was able to patch my boot image. As far a signing the patched boot image,I thought I had it done correctly but upon trying to flash the signed boot image,the unit failed to flash it. I then used one of the pre-made patched images and it worked for me. Pretty sad when Magisk does absolutely nothing anymore lol.
Yeah this is the issue I ran into. Just continually getting errors with Magisk, no matter what version I installed on Joying unit.


Senior Member
Jul 1, 2010
Yes, I've also read elsewhere that newer versions of Magisk do not work with my head unit which is similar to the Joying.

At one point I had Magisk installed and my head unit rooted. I then flashed a newer firmware and Magisk had updated to a newer version. The boot image patching no longer worked. I decided to not root my head unit and make the changes I wanted using another method. There is a thread in this forum that discusses this. The thread is "Modding your Joying/FYT SC9853i unit without root"

In any case, someone on the other forum, 4pda, discussed how to set up Magisk so that it updates or stays at the last version that worked. They indicate that version magisk version 20.3 is the latest that works and they were using MagiskManager 7.5.1 for installation. They indicated to go to Advanced Settings, select side channel and drive updates and use/enter the following after change hxxps to https:


So, whenever it checks for an update, it will not update Magisk and it will not update MagiskManager.

So, if you really want or need root, you can try the above yourself. I have not done this or tested it as I am happy with the changes I have made without rooting my head unit.

You should research this yourself. Anything you try or do to your head unit is your responsibility...as always :)


New member
Jul 19, 2009
Hello everybody.
I read again and again thoses 28 (interesting) pages but I think I need help.
I'm French and I buy a Joying 8.8 in May 2020 (EU-JY-HOS01N4GS-1) and I try many tips to resize screen (for a good use behind my Corvette C5 radio bezel).

-I try "direct" root method with file on post #33 of ojuniour but I've the red chinese message, the joying seems rooted but can't resize screen (and very slow).
-I try adb method with pc or special app with an other android phone but impossible to find the joying device.
-I try the developer.zip method but the installation of Magisk failed and I can't obtain a pached boot image.

Can you help me ?

(the only good thing is I can always do the update with original joying firmware and have a fully functional device)
Nobody to help me ?


New member
Jul 19, 2009
Overscan my screen is my goal.
A modified update, a modified boots image, tips or how-tow are welcome.


Aug 30, 2020
Strange. I will test tomorrow.
I don't use rooting anymore as it only reduces functionality of the unit, and and with the partial custom flashing almost all "root things" can be achieved as well.
Finally starting to understand what you meant with this post. I actually think you lose functionality after rooting.
Waze can no longer make any sounds, app problem? doesn't matter if radio or poweramp is running music/audio in background. Not sure what the issue is there?

Seriously think no use for root and I will be flashing the stock/original firmware back.
ADDIT: Actually tasker w/ autoinput will be my next endeavour. I think I could achieve more with that.
  • Like
Reactions: surfer63


Aug 30, 2020
I have another unrelated question as well. Is it possible to get my Sony headphones pairing over bluetooth and listening to audio from my Joying headunit? I would have thought this would have worked quite easily. However, it appears as if the bluetooth was only designed to connect to a mobile phone for downloading contacts and for calls.


Aug 30, 2020
Mapping of steerting wheel keys: 190000000_com.syu.steer.apk
Reading of configured steering wheels keys: 190000000_com.syu.ms.apk
CHeers, trying to mix New UI files with the old UI, due to control app not correctly triggering Home and Radio (AM FM) actions. The buttons appear to map and trigger other actions in the Control app. Seems to just be the app itself/probably that ms.apk will try that alone and see what happens

ADDIT: 190000000_com.syu.ms.apk fixes the steering controls, but is the same apk responsible for split screen, and now screen not half and half. more 35% / 65% (where it was with the clock embedded on the right) DOH !

I wonder if this setting can be fixed in the ms.apk
Last edited:


Jan 28, 2016
@surfer 63 hey my unit has a system version date of 2020-04-09. 1024x600 unit.. i kinda skimmed through the thread, found your 2020-04-07.. and wonder if thats compatible?


Senior Member
May 4, 2010
CHeers, trying to mix New UI files with the old UI, due to control app not correctly triggering Home and Radio (AM FM) actions. The buttons appear to map and trigger other actions in the Control app. Seems to just be the app itself/probably that ms.apk will try that alone and see what happens

ADDIT: 190000000_com.syu.ms.apk fixes the steering controls, but is the same apk responsible for split screen, and now screen not half and half. more 35% / 65% (where it was with the clock embedded on the right) DOH !

I wonder if this setting can be fixed in the ms.apk
Split screen is functionality from Android itself. The ms apk or any other FYT apk has nothing to do with that.
50%/50% or 33%/66% is determined by the layout set from the apk. Most apks only support 50%. Some apks have layouts that can work on 50% or 33%, or even other layout widths/percentages.
If you have a 33%/66% screen layout, you should be able to drag the separation bar to 50% and back again.
  • Like
Reactions: highkick05

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Then enjoy your new rooted / or gone back to original firmware which won't matter anyway because your audio mixing won't work anymore because its not rooted/patched the system correctly.

    I've done all of the above man. Sound will only work with the app you're using. i.e. voice won't work with Waze while listening to music
    Ahh yes. Good thing I have the later UIS7682 model. Either way, I never did voice command anything on my old airmont. I'm more button oriented (tasker).
    Yeah... hows the functionality on that thing? So you've rooted that succesfully, does the audio work well across all apps after rooting ?
    Like a champ. Is the most fluid device I've seen. I never noticed any issues on the airmont either. Again, I dont care for voice command anything.
    Working in hacking the radio app to a decent color/skin. More on this soon.

    I wish I knew where you got stuck, like error message or something. I feel like I could figure out whats missing
  • 20
    First off a big thanks to the guys at {Mod edit} for doing all the hard work, I'm just writing this post as a guide for those who don't speak Russian - like myself :)
    Second thanks to all those on the Original Thread (https://forum.xda-developers.com/an...ying-android-8-1-intel-airmont-eight-t3897206) for helping me finally find an android head unit worth buying.

    Compatible Firmware Versions:
    • 9853i 800X480 2019.3.20
    • 9853i 1024X600 2019.3.29
    • "New" 9853i 1280X480 新UI 2019.3.18
    • "Old" 9853i 1280X480 旧UI 2019.3.18

    Legacy Support

    • April 10 2019:
      • Added new files for several units

    Previous Changelogs:

    • April 4 2019:
      • Fixed typo in Developer instructions
      • Added "Ultra Wide" version
    • March 28 2019:
      • Simplified Installation Process
      • Reformatted instructions

    • I am not responsible for bricked devices. Proceed through this rooting process at your own risk.
    • Rooting your device will void Joying's waranty. (Even though it can be uninstalled in Magisk Manager).


    Rooting Your Device
    1. Plug your Flash Drive or MicroSD into your computer. Make sure there's nothing on it.
    2. Extract the contents of the device-appropriate archive to your flash drive. You should have 2 files: "lsec6521update" and "6521_1.zip".
    3. Go to your head unit. Moment of truth; no turning back once you begin this next step! Plug your flash drive into the head unit. The update will be detected and the update will automatically begin.
    4. Your head unit will reboot into recovery and install the update containg root. DO NOT POWER OFF YOUR DEVICE OR UNPLUG THE FLASH DRIVE DURING THIS PROCESS!!! If you do, you may permanantly brick your device! Once prompted by the update process, remove your Flash Drive and let it boot back up into Android.

    If you would like the more in depth "developer" tutorial, attached is Developer.zip.
    Inside I included "Readme.rtf" - a copy of the developer instructions with screenshots.
    Senior members, after following the above proceedure, I have a Joying-signed "6521_1.zip" file containg Magisk.
    Is this file specific to my unit or will others be able to flash this file to get root? If so it would make the rooting process a lot faster and noob-friendly. Thanks!
    Please see attached update file.
    Unzip to root of an empty flash drive and plug into head unit. Device will update automatically.
    I got emailed the update link to this morning also for the new firmware, just flashed it and it fixed all my problems (voice, notification bar etc)
    Im stoked. :) Joying has been super good and responding to emails and fixing stuff. One of the reasons I bought a Joying over some of the other crap out there.

    Here is the patched boot.img with magisk file: Magisk 9853i 1024X600 or 800X480 Google 2019.5.15

    Cant upload the firmware at work unfortunately but was able to patch the boot.img while driving to work :p
    Starting any user app on boot

    So with the risk of looking like an idiot I want to share something for others in my situation on this Joying head unit:

    I originally only rooted and struggled for the past 2 weeks unsuccessfully with xposed, because I wanted a way to start a "tasker app" on boot.
    For some unknown reason (to me at least) neither Tasker, Automate or Macrodroid are allowed to start on boot. Don't know if it's Joying firmware or Oreo in general as google comes up with this issue in general for Oreo.

    So today I played around in Setting and in there are both "Start Navi app on launch" & an option to set the Navi app of choice. I never took much notice about this earlier, and I just assumed you could only choose installed Navi apps in there. But to my surprise you can choose any installed app.
    -So I have now solved my objective by simply setting Tasker in this setting and Tasker now starts on boot, and from Tasker I can start all other apps or tasks (like a Navi app so you dont loose that option). This is a perfect workaround and does not require root at all.
    Tasker can still only survive Sleep mode if you install the NoKill mod, but I dont use sleep mode anyway as boot is rather fast and ensure my 4g/wifi hotspot is already live when unit is done booting.

    I don't know if this has been there always in previous Android versions/units so please bare with me if this is the case.
    Previous terminal command apk wasn't fully compatible with magisk and not to ask superuser grants. I found a new one and tried to generate other files, hope it is good enough but it is not so easily from an average garage...

    This is exactly what I need. Thanks.
    I will start extending the JET apk