• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

General HowTo: Root Joying SC9853i Head Unit

Search This thread

forgivegod

Member
Jun 21, 2011
20
3
Then enjoy your new rooted / or gone back to original firmware which won't matter anyway because your audio mixing won't work anymore because its not rooted/patched the system correctly.

I've done all of the above man. Sound will only work with the app you're using. i.e. voice won't work with Waze while listening to music
Ahh yes. Good thing I have the later UIS7682 model. Either way, I never did voice command anything on my old airmont. I'm more button oriented (tasker).
 
  • Like
Reactions: highkick05

forgivegod

Member
Jun 21, 2011
20
3
Yeah... hows the functionality on that thing? So you've rooted that succesfully, does the audio work well across all apps after rooting ?
Like a champ. Is the most fluid device I've seen. I never noticed any issues on the airmont either. Again, I dont care for voice command anything.
Working in hacking the radio app to a decent color/skin. More on this soon.

I wish I knew where you got stuck, like error message or something. I feel like I could figure out whats missing
 
  • Like
Reactions: highkick05

forgivegod

Member
Jun 21, 2011
20
3
I powered up my old intel headunit since the new UIS7682 is now installed and decided to see if I could root it. It took a couple of attempts but what finally worked was:

- creating an android virtual device on an intel machine using the x86_64 android image on API 27 (android 8.1)
- installing the latest magisk on that AVD and use it to patch the boot.img (from the 2020.4.7firmware)
- stuff the patched boot.img into the 6521_1.zip and then run the signing proess/tool on it
- take the new 6521_1.zip and put it and the other firmware update files on a usb stick and flash

I have root. Tho magisk is complaining about signature verification. Might have to install mods manually. No biggy.

Unit Specifics :
Joying 10.1'' 2006 - 2012 Toyota RAV4 Android 8.1.0 Plug and Play Car Auto Radio with DSP
SKU: JY-TO151N3-JY-TO151N4GS
Firmware: 9853i OS 1024X600 800X480 1280X720 2020.4.7 (8.1.0)
 

ciris

Member
Sep 13, 2009
37
14
Thanks for sharing! Ok so this takes a little work but not much to do! Can you share what tool you use to process/sign the rooted boot.img?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 20
    First off a big thanks to the guys at {Mod edit} for doing all the hard work, I'm just writing this post as a guide for those who don't speak Russian - like myself :)
    Second thanks to all those on the Original Thread (https://forum.xda-developers.com/an...ying-android-8-1-intel-airmont-eight-t3897206) for helping me finally find an android head unit worth buying.

    Compatible Firmware Versions:
    • 9853i 800X480 2019.3.20
    • 9853i 1024X600 2019.3.29
    • "New" 9853i 1280X480 新UI 2019.3.18
    • "Old" 9853i 1280X480 旧UI 2019.3.18

    Legacy Support


    Changelog:
    • April 10 2019:
      • Added new files for several units

    Previous Changelogs:

    • April 4 2019:
      • Fixed typo in Developer instructions
      • Added "Ultra Wide" version
    • March 28 2019:
      • Simplified Installation Process
      • Reformatted instructions


    Warnings
    • I am not responsible for bricked devices. Proceed through this rooting process at your own risk.
    • Rooting your device will void Joying's waranty. (Even though it can be uninstalled in Magisk Manager).

    Prereqs

    Rooting Your Device
    1. Plug your Flash Drive or MicroSD into your computer. Make sure there's nothing on it.
    2. Extract the contents of the device-appropriate archive to your flash drive. You should have 2 files: "lsec6521update" and "6521_1.zip".
    3. Go to your head unit. Moment of truth; no turning back once you begin this next step! Plug your flash drive into the head unit. The update will be detected and the update will automatically begin.
    4. Your head unit will reboot into recovery and install the update containg root. DO NOT POWER OFF YOUR DEVICE OR UNPLUG THE FLASH DRIVE DURING THIS PROCESS!!! If you do, you may permanantly brick your device! Once prompted by the update process, remove your Flash Drive and let it boot back up into Android.

    If you would like the more in depth "developer" tutorial, attached is Developer.zip.
    Inside I included "Readme.rtf" - a copy of the developer instructions with screenshots.
    6
    Senior members, after following the above proceedure, I have a Joying-signed "6521_1.zip" file containg Magisk.
    Is this file specific to my unit or will others be able to flash this file to get root? If so it would make the rooting process a lot faster and noob-friendly. Thanks!
    Please see attached update file.
    Unzip to root of an empty flash drive and plug into head unit. Device will update automatically.
    **FLASH AT YOUR OWN RISK, I AM NOT RESPONSIBLE FOR BRICKED UNITS**
    5
    I got emailed the update link to this morning also for the new firmware, just flashed it and it fixed all my problems (voice, notification bar etc)
    Im stoked. :) Joying has been super good and responding to emails and fixing stuff. One of the reasons I bought a Joying over some of the other crap out there.

    Here is the patched boot.img with magisk file: Magisk 9853i 1024X600 or 800X480 Google 2019.5.15

    Cant upload the firmware at work unfortunately but was able to patch the boot.img while driving to work :p
    4
    Starting any user app on boot

    So with the risk of looking like an idiot I want to share something for others in my situation on this Joying head unit:

    I originally only rooted and struggled for the past 2 weeks unsuccessfully with xposed, because I wanted a way to start a "tasker app" on boot.
    For some unknown reason (to me at least) neither Tasker, Automate or Macrodroid are allowed to start on boot. Don't know if it's Joying firmware or Oreo in general as google comes up with this issue in general for Oreo.

    So today I played around in Setting and in there are both "Start Navi app on launch" & an option to set the Navi app of choice. I never took much notice about this earlier, and I just assumed you could only choose installed Navi apps in there. But to my surprise you can choose any installed app.
    -So I have now solved my objective by simply setting Tasker in this setting and Tasker now starts on boot, and from Tasker I can start all other apps or tasks (like a Navi app so you dont loose that option). This is a perfect workaround and does not require root at all.
    Tasker can still only survive Sleep mode if you install the NoKill mod, but I dont use sleep mode anyway as boot is rather fast and ensure my 4g/wifi hotspot is already live when unit is done booting.

    I don't know if this has been there always in previous Android versions/units so please bare with me if this is the case.
    3
    Previous terminal command apk wasn't fully compatible with magisk and not to ask superuser grants. I found a new one and tried to generate other files, hope it is good enough but it is not so easily from an average garage...

    This is exactly what I need. Thanks.
    I will start extending the JET apk