[HSPL/HSPL2] HowTo flash everything ;)

Search This thread

bepe

Retired Recognized Developer
Dec 18, 2005
1,115
64
Munich
So, finaly here it is...

Release Notes:

------------------------------------------------------------------------------------
DarkForces Team HardSPL by bepe and Cotulla

Please read carefully before installing!

1) To install this HSPL there must be SPL 1.42.0000 on your device.
Otherwise the installation will fail!
To check your SPL version, hold the Volume Down button and do a reset.
It is possible to downgrade to this SPL, by just flashing to an Official ROM
with this SPL version.

2) Features
- Disabled CID Check, so you can flash any official ROM without using a Gold Card.
- Security Level = 0, so you can use all the boot loader commands (for developers).
- This HSPL will not get overwritten when flashing a full NBH with SPL via RUU.
- No NBH signatures check, so you can flash unsigned ROM images.

3) Warranty Issues
Be warned, Installing HSPL may void your warranty.
If you need to send your device to a Repair Centre,
make sure that you uninstall HSPL!

4) Uninstallation
Only way to remove the HSPL is to flash an original SPL from SD card.
- Take any "RUU_signed.nbh" from a ship ROM and copy it to SD card.
- Rename it to "leoimg.nbh"
- Reset the device while pressing the volume down button.

5) Disclaimer
This product is free to use, but at your own risk. We take no
responsibility for any conflict, fault, or damage caused by
this unlocking procedure. No warranties of any kind are given.
We have tested our product on several devices and have not
found any problems with it.

DFT, bepe and Cotulla 2010.

[SIZE=5][COLOR=Red][B]MOD EDIT: Android / WP7 / MAGLDR don't support HSPL3.03/OSPL3.03.
You need HSPL2.08 to run Android / WP7 / MAGLDR.[/B][/COLOR][/SIZE]

Thanks to:
Monkey, Laurentius26 and friends, Xmoo, tom_codon and Dutty for testing and support
------------------------------------------------------------------------------------


Troubleshooting:
  • I have SPL 1.42.666 on the device.... !!!! WAIT !!!! SPL 1.42.6666 is not the version of the SPL on your device!... it is the SSPL version. Most likely you have the needed 1.42.0000 SPL on the device, just try to install this HSPL if you need it. Don't worry, if there is not the right SPL on the device, then u will get an error message, but nothing will happen to your device ;)
  • "Your OS ROM isn't customized for your hardware. Please reflash the proper ROM code or contact the service center", !!! Problem NOT related to HSPL !!! ... this means that you flashed a region protected rom... flash any other rom that has your region ID... or patch it

hacked.jpg



22/03/2010


well, HSPL2 comes

To install/uninstall this HSPL there must be any SPL version from this list on your device:

SPL 1.42.0000 SPL 1.42.HSPL
SPL 1.62.0000
SPL 1.66.0000 SPL 1.66.HSPL
SPL 2.07.0000
SPL 2.08.0000 SPL 2.08.HSPL


Other versions are not supported. (They are rare however...)

Now you can uninstall HSPL via same program, you no longer need to flash rom from SD card!

In HSPL2 you can select which version of SPL you want to install in the device.

There included 6 SPLs:

OSPL 1.42, OSPL 1.66, OSPL 2.08 (Original SPL)
HSPL 1.42, HSPL 1.66, HSPL 2.08 (Hard SPL)

Remember that some ROMs have old SPLs, for example 2.10 ROM have 2.08 SPL, 1.72 ROM have 1.66 SPL and etc!

You can install any of them using HSPL2.


Disclaimer

This product is free to use, but at your own risk. We take no
responsibility for any conflict, fault, or damage caused by
this unlocking procedure. No warranties of any kind are given.
We have tested our product on several devices and have not
found any problems with it.

1024LEOs (from T-Mobile with 1024ROM) ARE NOT SUPPORTED

hspl208.PNG


DFT: bepe and Cotulla 2010.
Thanks everyone for testing and support!
 

Attachments

  • HSPL.zip
    722.7 KB · Views: 325,420
  • HSPL2_RUN.zip
    1.8 MB · Views: 383,843
Last edited by a moderator:

bepe

Retired Recognized Developer
Dec 18, 2005
1,115
64
Munich
[HSPL3] HowTo flash everything ;)

Cotulla: HSPL3 available

See original post here...http://forum.xda-developers.com/showpost.php?p=6891358&postcount=1893

so what about changes?

*Support 2.10 OSPL (in 2.13 ROM)

*Now included only 2.08.0000 and 2.08.HSPL.
Seems all ROMs based on 1.42, 1.66, 1.XX can work with 2.08 SPL without problems.*

*Now one HSPL for different LEO types: UsualLEO, TelstraLEO and 1024LEO*

*Because there no SPLs except 2.08, so no risk to brick 1024LEO with wrong version.

*Telstra LEO supported. Actually Model ID checked by first 4 letters.




21.06.2010.
-Cotulla
 

Attachments

  • HSPL3_PKG.zip
    984.8 KB · Views: 118,848
Last edited by a moderator:

bepe

Retired Recognized Developer
Dec 18, 2005
1,115
64
Munich
HSPL4... available!

Thanks to Cotulla

HSPL4 available

OSPL - Original SPL (Official)
HSPL - Hard SPL


*Includes 2.08 OSPL, 2.08 HSPL, 3.03 OSPL, 3.03 HSPL.
You can install any of this.


*To install any SPL there must be any SPL version from this list on your device:
SPL 1.42.0000
SPL 1.62.0000
SPL 1.66.0000
SPL 2.07.0000
SPL 2.08.0000
SPL 2.10.0000
SPL 3.03.0000
Otherwise the installation will fail!

3.03 SPL supports LEO1024.


This HSPL released for WM65 users, to provide better compatible with ROMs based on Official 3.XX ROM.

Android / WP7 / MAGLDR don't support HSPL3.03/OSPL3.03.
You need HSPL2.08 to run Android / WP7 / MAGLDR.


to moderators: please add copy of this message to start of this thread.

20.02.2011.
-DFT team
 

Attachments

  • HSPL4.zip
    1.4 MB · Views: 251,612
Last edited by a moderator:

Cotulla

Retired Senior Recognized Developer
Sep 8, 2007
881
5,449
HSPL 4

HSPL4 available

OSPL - Original SPL (Official)
HSPL - Hard SPL


*Includes 2.08 OSPL, 2.08 HSPL, 3.03 OSPL, 3.03 HSPL.
You can install any of this.


*To install any SPL there must be any SPL version from this list on your device:
SPL 1.42.0000
SPL 1.62.0000
SPL 1.66.0000
SPL 2.07.0000
SPL 2.08.0000
SPL 2.10.0000
SPL 3.03.0000
Otherwise the installation will fail!

3.03 SPL supports LEO1024.


This HSPL released for WM65 users, to provide better compatible with ROMs based on Official 3.XX ROM.

Android / WP7 / MAGLDR don't support HSPL3.03/OSPL3.03.
You need HSPL2.08 to run Android / WP7 / MAGLDR.



attachment.php
attachment.php


http://www.darkforcesteam.com.cn/forum.php?mod=viewthread&tid=29086&extra=page=1

20.02.2011.
-DFT team
 

Attachments

  • HSPL4.zip
    1.4 MB · Views: 116,595
  • HSPL4.jpg
    HSPL4.jpg
    67.3 KB · Views: 519,387
  • HSPL4_2.jpg
    HSPL4_2.jpg
    56.4 KB · Views: 518,322
Last edited by a moderator:

hbahaie

Senior Member
Feb 25, 2004
327
3
Troubleshooting:
  • "Your OS ROM isn't customized for your hardware. Please reflash the proper ROM code or contact the service center", !!! Problem NOT related to HSPL !!! ... this means that you flashed a region protected rom... flash any other rom that has your region ID... or patch it

So, I cannot use this HSPL to flash official rom not released for my region. Can I use Gold Card or SSPL to flash different region ROM in presence of HSPL installed?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 40
    HSPL 4

    HSPL4 available

    OSPL - Original SPL (Official)
    HSPL - Hard SPL


    *Includes 2.08 OSPL, 2.08 HSPL, 3.03 OSPL, 3.03 HSPL.
    You can install any of this.


    *To install any SPL there must be any SPL version from this list on your device:
    SPL 1.42.0000
    SPL 1.62.0000
    SPL 1.66.0000
    SPL 2.07.0000
    SPL 2.08.0000
    SPL 2.10.0000
    SPL 3.03.0000
    Otherwise the installation will fail!

    3.03 SPL supports LEO1024.


    This HSPL released for WM65 users, to provide better compatible with ROMs based on Official 3.XX ROM.

    Android / WP7 / MAGLDR don't support HSPL3.03/OSPL3.03.
    You need HSPL2.08 to run Android / WP7 / MAGLDR.



    attachment.php
    attachment.php


    http://www.darkforcesteam.com.cn/forum.php?mod=viewthread&tid=29086&extra=page=1

    20.02.2011.
    -DFT team
    31
    So, finaly here it is...

    Release Notes:

    ------------------------------------------------------------------------------------
    DarkForces Team HardSPL by bepe and Cotulla

    Please read carefully before installing!

    1) To install this HSPL there must be SPL 1.42.0000 on your device.
    Otherwise the installation will fail!
    To check your SPL version, hold the Volume Down button and do a reset.
    It is possible to downgrade to this SPL, by just flashing to an Official ROM
    with this SPL version.

    2) Features
    - Disabled CID Check, so you can flash any official ROM without using a Gold Card.
    - Security Level = 0, so you can use all the boot loader commands (for developers).
    - This HSPL will not get overwritten when flashing a full NBH with SPL via RUU.
    - No NBH signatures check, so you can flash unsigned ROM images.

    3) Warranty Issues
    Be warned, Installing HSPL may void your warranty.
    If you need to send your device to a Repair Centre,
    make sure that you uninstall HSPL!

    4) Uninstallation
    Only way to remove the HSPL is to flash an original SPL from SD card.
    - Take any "RUU_signed.nbh" from a ship ROM and copy it to SD card.
    - Rename it to "leoimg.nbh"
    - Reset the device while pressing the volume down button.

    5) Disclaimer
    This product is free to use, but at your own risk. We take no
    responsibility for any conflict, fault, or damage caused by
    this unlocking procedure. No warranties of any kind are given.
    We have tested our product on several devices and have not
    found any problems with it.

    DFT, bepe and Cotulla 2010.

    [SIZE=5][COLOR=Red][B]MOD EDIT: Android / WP7 / MAGLDR don't support HSPL3.03/OSPL3.03.
    You need HSPL2.08 to run Android / WP7 / MAGLDR.[/B][/COLOR][/SIZE]

    Thanks to:
    Monkey, Laurentius26 and friends, Xmoo, tom_codon and Dutty for testing and support
    ------------------------------------------------------------------------------------


    Troubleshooting:
    • I have SPL 1.42.666 on the device.... !!!! WAIT !!!! SPL 1.42.6666 is not the version of the SPL on your device!... it is the SSPL version. Most likely you have the needed 1.42.0000 SPL on the device, just try to install this HSPL if you need it. Don't worry, if there is not the right SPL on the device, then u will get an error message, but nothing will happen to your device ;)
    • "Your OS ROM isn't customized for your hardware. Please reflash the proper ROM code or contact the service center", !!! Problem NOT related to HSPL !!! ... this means that you flashed a region protected rom... flash any other rom that has your region ID... or patch it

    hacked.jpg



    22/03/2010


    well, HSPL2 comes

    To install/uninstall this HSPL there must be any SPL version from this list on your device:

    SPL 1.42.0000 SPL 1.42.HSPL
    SPL 1.62.0000
    SPL 1.66.0000 SPL 1.66.HSPL
    SPL 2.07.0000
    SPL 2.08.0000 SPL 2.08.HSPL


    Other versions are not supported. (They are rare however...)

    Now you can uninstall HSPL via same program, you no longer need to flash rom from SD card!

    In HSPL2 you can select which version of SPL you want to install in the device.

    There included 6 SPLs:

    OSPL 1.42, OSPL 1.66, OSPL 2.08 (Original SPL)
    HSPL 1.42, HSPL 1.66, HSPL 2.08 (Hard SPL)

    Remember that some ROMs have old SPLs, for example 2.10 ROM have 2.08 SPL, 1.72 ROM have 1.66 SPL and etc!

    You can install any of them using HSPL2.


    Disclaimer

    This product is free to use, but at your own risk. We take no
    responsibility for any conflict, fault, or damage caused by
    this unlocking procedure. No warranties of any kind are given.
    We have tested our product on several devices and have not
    found any problems with it.

    1024LEOs (from T-Mobile with 1024ROM) ARE NOT SUPPORTED

    hspl208.PNG


    DFT: bepe and Cotulla 2010.
    Thanks everyone for testing and support!
    21
    HSPL4... available!

    Thanks to Cotulla

    HSPL4 available

    OSPL - Original SPL (Official)
    HSPL - Hard SPL


    *Includes 2.08 OSPL, 2.08 HSPL, 3.03 OSPL, 3.03 HSPL.
    You can install any of this.


    *To install any SPL there must be any SPL version from this list on your device:
    SPL 1.42.0000
    SPL 1.62.0000
    SPL 1.66.0000
    SPL 2.07.0000
    SPL 2.08.0000
    SPL 2.10.0000
    SPL 3.03.0000
    Otherwise the installation will fail!

    3.03 SPL supports LEO1024.


    This HSPL released for WM65 users, to provide better compatible with ROMs based on Official 3.XX ROM.

    Android / WP7 / MAGLDR don't support HSPL3.03/OSPL3.03.
    You need HSPL2.08 to run Android / WP7 / MAGLDR.


    to moderators: please add copy of this message to start of this thread.

    20.02.2011.
    -DFT team
    17
    HSPL3

    HSPL3 available


    so what about changes?

    *Support 2.10 OSPL (in 2.13 ROM)

    *Now included only 2.08.0000 and 2.08.HSPL.
    Seems all ROMs based on 1.42, 1.66, 1.XX can work with 2.08 SPL without problems.*

    *Now one HSPL for different LEO types: UsualLEO, TelstraLEO and 1024LEO*

    *Because there no SPLs except 2.08, so no risk to brick 1024LEO with wrong version.

    *Telstra LEO supported. Actually Model ID checked by first 4 letters.

    21.06.2010.
    -Cotulla
    8
    [HSPL3] HowTo flash everything ;)

    Cotulla: HSPL3 available

    See original post here...http://forum.xda-developers.com/showpost.php?p=6891358&postcount=1893

    so what about changes?

    *Support 2.10 OSPL (in 2.13 ROM)

    *Now included only 2.08.0000 and 2.08.HSPL.
    Seems all ROMs based on 1.42, 1.66, 1.XX can work with 2.08 SPL without problems.*

    *Now one HSPL for different LEO types: UsualLEO, TelstraLEO and 1024LEO*

    *Because there no SPLs except 2.08, so no risk to brick 1024LEO with wrong version.

    *Telstra LEO supported. Actually Model ID checked by first 4 letters.




    21.06.2010.
    -Cotulla
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone