• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

HTC 10 Stock Oreo 8.0 Bugs & Issues Thread

Search This thread

Haldi4803

Senior Member
Oct 14, 2010
3,886
1,571
Amazon Fire HD 8 and HD 10
Xperia XZ2
Because the HTC 10 Updates Thread is getting hard to read and mainly about notifications for Updates i tought i'd create an extra Thread for know Bugs and bug searching.

There are currently two Updates out for Oreo. 3.16.xxx.3 and 3.18.xxx.1 but they're both about the same... or almost.

3.16.709.3
Known Bugs:
  • WiFi might activate Mobile Data and create huge Batterydrain in Standby (Post Nr4) Doesn't seem to happen frequently, most likely an exception.
  • Notifications are set Globally and not per App (Post Nr2) SOLUTION: Use U11 Settings.APK (You just have to set them correctly...)
  • HTCMode app is running in the Background for 30-120 Seconds after a reboot (HTC Support is useless....)
  • Battery Stats hamburger Menu shows duplications (Post Nr3, Hard to reproduce.)
  • Bluetooth doesn't show Media Info on all devices while music playback. some work, some dont
  • Some people seem to have huge standby drain from uncertain cause. Dialer app?

If you know anything else, report it here and i'll add it.
 
Last edited:

Haldi4803

Senior Member
Oct 14, 2010
3,886
1,571
Amazon Fire HD 8 and HD 10
Xperia XZ2
Notification Sound Issues Sticking to all apps:

Thanks but this is not solution for my and others issue with all apps using the same notification sound as currently HTC does not allow using different sounds for different apps.
I already have custom sounds in Notifications folder.
This can be achieved using 3rd party apps as suggested in previous posts.

I haven't personally had the chance to look into a fix for it yet.
Possibly as a temp work around, maybe try a 3rd party notification sound manager?
Something like this:
https://play.google.com/store/apps/details?id=notificon.gsy.com.notificon
No idea how well it works or if it does at all for Oreo on the 10.
Just an idea for now....


Just curious, are those issues reported (for example the one with notification sounds not sticking in different apps) contained to the RUU/firmware which got leaked and pulled, or is it a general HTC Oreo issue?

same thing here, it's impossible to change notification sound. if i change sound in one app, the same sound apply to all apps. wtf ??
 

Haldi4803

Senior Member
Oct 14, 2010
3,886
1,571
Amazon Fire HD 8 and HD 10
Xperia XZ2
Duplication of HamburgerMenu in Battery Stats:

Anyone had the same?
This is 3.16.709.3

Edit: It keeps increasing xD But a Reboot makes it go away.
 

Attachments

  • Screenshot_20180124-092247.png
    Screenshot_20180124-092247.png
    216.9 KB · Views: 6,142
  • Screenshot_20180125-021122.png
    Screenshot_20180125-021122.png
    227.5 KB · Views: 5,229
Last edited:

Haldi4803

Senior Member
Oct 14, 2010
3,886
1,571
Amazon Fire HD 8 and HD 10
Xperia XZ2
Bad Batterylife on WiFi / Activation of Mobile Network while on WiFi

WiFi Standby on 2.4ghz Wlan 2.5%
WiFi Standby on 5ghz Wlan 0.5%

Something is Off there right?

If you take a look at this graph here:
BSLe1pL.png

Left side green line WiFi On looses about 0.6%/h with WiFi. Right side with WiFi on is about 2.5%/h and you can see the red "Mobile Radio Active" points a few lines above.
I'm not entirely sure if it's tied to 2.4ghz and 5ghz WiFi or something else... i'm still investigating.

Edit:
The Mobile Radio Active during WiFI Bug is NOT related to 2.4ghz WiFi! Or at least not happen every time.
As you can see in this picture, after 3am - 9 am there was NO mobile activity during WiFi while it was in 2.4ghz WiFi and doze.
biHQF1m.png
 

Attachments

  • Screenshot_20180120-132428.png
    Screenshot_20180120-132428.png
    234.6 KB · Views: 2,004
  • Screenshot_20180120-152531.png
    Screenshot_20180120-152531.png
    231.8 KB · Views: 1,969
Last edited:

wiQbold

Senior Member
Oct 29, 2008
532
73
only for information. over KLWP (Kustom LiveWallpaper) I did recognized that the IP is from Mobile Data even if I connected to my WLAN.
 
Last edited:

phxzy

Senior Member
May 17, 2010
175
64
Arnhem
I'm having BT problems. My Ford Sync can't show any media info anymore. All my music shows unknown. After googling I've tried to change BT AVRPC in Dev mode to 1.5 and 1.6, but without success. Didn't have this on Nougat.

In Oreo 8.1 this problem should be solved, bit I'm guessing that 8.1 won't come to the 10. :(

Sent from my HTC 10 using XDA Labs
 

Si6776

Senior Member
Dec 29, 2009
111
3
I'm having a problem with some Bluetooth devices. My Ford Sync seems to still work perfectly, but my Sony headphones require manual activation every time, when they always just locked on automatically before. I've tried unpairing and re-pairing, but this hasn't helped.

Also, I've noticed a few times that my ring volume seems to randomly and dramatically drop to almost zero. I've not managed to link this to any particular activity or other functions, but it is annoying, as sometimes I've just not heard the phone ringing.

---------- Post added at 12:00 PM ---------- Previous post was at 11:55 AM ----------

Does anyone think we are likely to get a patch to fix these issues fairly soon? Otherwise, I may just have to revert back to my old Samsung S7, as I can't cope with all these bugs.
 

Haldi4803

Senior Member
Oct 14, 2010
3,886
1,571
Amazon Fire HD 8 and HD 10
Xperia XZ2
only for information. over KLWP I did recognized that the IP is from Mobile Data even if I connected to my WLAN.
Code:
C:\ADB>adb shell ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: bond0: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noop state DOWN group default
    link/ether 76:5f:63:a1:f3:85 brd ff:ff:ff:ff:ff:ff
3: dummy0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
    link/ether 4e:9c:fe:6c:72:e5 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4c9c:feff:fe6c:72e5/64 scope link
       valid_lft forever preferred_lft forever
4: [email protected]: <NOARP> mtu 1480 qdisc noop state DOWN group default
    link/sit 0.0.0.0 brd 0.0.0.0
5: rmnet_ipa0: <UP,LOWER_UP> mtu 2000 qdisc pfifo_fast state UNKNOWN group default qlen 1000
    link/[530]
6: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 80:7a:bf:3a:7a:e3 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.10/24 brd 192.168.1.255 scope global wlan0
       valid_lft forever preferred_lft forever
    inet6 fe80::827a:bfff:fe3a:7ae3/64 scope link
       valid_lft forever preferred_lft forever
7: rmnet_data0: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
8: rmnet_data1: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
9: rmnet_data2: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
10: rmnet_data3: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
11: rmnet_data4: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
12: rmnet_data5: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
13: rmnet_data6: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
14: rmnet_data7: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
15: r_rmnet_data0: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
16: r_rmnet_data1: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
17: r_rmnet_data2: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
18: r_rmnet_data3: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
19: r_rmnet_data4: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
20: r_rmnet_data5: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
21: r_rmnet_data6: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
22: r_rmnet_data7: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
23: r_rmnet_data8: <> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/[530]
Doesn't show the Public IP adress for me. what is KLWP ?

I'm having BT problems. My Ford Sync can't show any media info anymore. All my music shows unknown. After googling I've tried to change BT AVRPC in Dev mode to 1.5 and 1.6, but without success. Didn't have this on Nougat.
Bluetooth info works fine for my BMW.
Edit: i might have the Chance to try it on a Kuga soon.... /edit




But the 2.4ghz WiFI is like REALLY bad now....
Standing in front of the router i get about 150mbits. Standing 3-4m away in line of sight its a maximum 80mbits. Going slightly out of sight behind a Monitor i get 60mbits....
 

Attachments

  • Screenshot_20180124-133637.jpg
    Screenshot_20180124-133637.jpg
    254.4 KB · Views: 1,375
Last edited:

matekaneve

Senior Member
May 6, 2011
841
485
Stirling
Google Pixel 4 XL
I don't know guys, I'm still on stock HTC software (waiting on cleanslate kernel...), I really miss all my settings and set up I had on nougat with LeeDroid and Cleanslate, but there's one thing for sure. I never ever had such a good battery life before. All day and night on WiFi, on 4g for about 1 hour when I was out. XDA, Chrome (browsing), Facebook, Twitter, couple of YouTube videos. On nougat I usually got about 2.5 max 3 hours sot within 24 hours with the same usage...
The only issue and complain I have is the notification,, but apparently LeeDroid is working on it. ?
 

Attachments

  • Screenshot_20180124-142803.png
    Screenshot_20180124-142803.png
    149.8 KB · Views: 1,735

errikosd

Senior Member
Mar 24, 2014
619
500
I don't know guys, I'm still on stock HTC software (waiting on cleanslate kernel...), I really miss all my settings and set up I had on nougat with LeeDroid and Cleanslate, but there's one thing for sure. I never ever had such a good battery life before. All day and night on WiFi, on 4g for about 1 hour when I was out. XDA, Chrome (browsing), Facebook, Twitter, couple of YouTube videos. On nougat I usually got about 2.5 max 3 hours sot within 24 hours with the same usage...
The only issue and complain I have is the notification,, but apparently LeeDroid is working on it.

I personally saw huge improvement in battery life once I disabled the Facebook app (not Messenger). It got SOT up by half an hour.
 
  • Like
Reactions: matekaneve

spicypixel

Senior Member
Jul 3, 2007
110
10
I installed the 8 OTA in the UK, play store wouldn't update any apps anymore, so I had 50+ pending updates after a few days.

I factory reset the phone after deleting the play store cache, data, uninstalling it and side loading the APK, nothing seemed to help with the apps not downloading or updating.

Since I've obviously reset the phone I have no apps installed and it's now saying Completing setup, 0 of 140...

Any thoughts?

Edit: update, took the router out of the equation and just used a USB ethernet dongle I know works with the htc10 to bridge directly to the modem, seems to work.
Guessing wifi/DNS resolution broken.
 
Last edited:

lumiere1

Member
Jan 24, 2018
5
1
How do we exactly resolve the issue?

Bad Batterylife on WiFi / Activation of Mobile Network while on WiFi

WiFi Standby on 2.4ghz Wlan:
Screenshot_20180120-132428.png


WiFi Standby on 5ghz Wlan:
Screenshot_20180120-152531.png


Something is Off there right?

If you take a look at this graph here:
BSLe1pL.png

Left side green line WiFi On looses about 0.6%/h with WiFi. Right side with WiFi on is about 2.5%/h and you can see the red "Mobile Radio Active" points a few lines above.
I'm not entirely sure if it's tied to 2.4ghz and 5ghz WiFi or something else... i'm still investigating.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    Because the HTC 10 Updates Thread is getting hard to read and mainly about notifications for Updates i tought i'd create an extra Thread for know Bugs and bug searching.

    There are currently two Updates out for Oreo. 3.16.xxx.3 and 3.18.xxx.1 but they're both about the same... or almost.

    3.16.709.3
    Known Bugs:
    • WiFi might activate Mobile Data and create huge Batterydrain in Standby (Post Nr4) Doesn't seem to happen frequently, most likely an exception.
    • Notifications are set Globally and not per App (Post Nr2) SOLUTION: Use U11 Settings.APK (You just have to set them correctly...)
    • HTCMode app is running in the Background for 30-120 Seconds after a reboot (HTC Support is useless....)
    • Battery Stats hamburger Menu shows duplications (Post Nr3, Hard to reproduce.)
    • Bluetooth doesn't show Media Info on all devices while music playback. some work, some dont
    • Some people seem to have huge standby drain from uncertain cause. Dialer app?

    If you know anything else, report it here and i'll add it.
    3
    Bad Batterylife on WiFi / Activation of Mobile Network while on WiFi

    WiFi Standby on 2.4ghz Wlan 2.5%
    WiFi Standby on 5ghz Wlan 0.5%

    Something is Off there right?

    If you take a look at this graph here:
    BSLe1pL.png

    Left side green line WiFi On looses about 0.6%/h with WiFi. Right side with WiFi on is about 2.5%/h and you can see the red "Mobile Radio Active" points a few lines above.
    I'm not entirely sure if it's tied to 2.4ghz and 5ghz WiFi or something else... i'm still investigating.

    Edit:
    The Mobile Radio Active during WiFI Bug is NOT related to 2.4ghz WiFi! Or at least not happen every time.
    As you can see in this picture, after 3am - 9 am there was NO mobile activity during WiFi while it was in 2.4ghz WiFi and doze.
    biHQF1m.png
    3
    Not yet. With so many bugs & issues making the phone genuinely a bit s#it now. I can see I'm pretty much being forced down this route in order to solve them.. :( I can;t really see any other option now.

    My mums HTC 10, same update - Works perfectly!!

    There is a fix, but it may require root and modifying the system partition, maybe not, but haven't tested on a stock rom.

    Basically, taking the Settings.apk from the U11 will resolve this and after extensive testing there isn't any differences to be concerned about.

    The attached Settings.apk is taken from a dump on the U11 2.33.401.10 UHL (single sim)

    This is one of the many fixes in Leedroid thats been there for a while so sorry for the delay, so its simply in there, but you could try replacing /system/priv-app/Settings.apk (CHMOD 644 as well if needed) (it may also be necessary to delete /data/system/package_cache/1/Settings-* if that leads to odd behavior)

    Or you might also have luck installing it directly so it exists as an update in /data/app/ - not sure there as I haven't tried it.

    It is basically down to fix it, but good luck getting another HTC 10 update, I have been chasing them to acknowledge this bug on Twitter for a month and not had a single reply.

    But once correctly updated or in place, the correct notifications selector will pop up and allow you to set different notification tones where available without changing the system default.
    2
    I update my fone last week , not rooted ...just using openvpn connect and of course its drain the battery when i use mobile data ...the problem is after update this " extreme power saving mode " its drain the battery horribly without any explanation , more than 70% and its not happened before

    is there any ideas or solutions for this problem ??

    I am on Three uk and I resolved this problem by changing the preferred network type from "LTE/UMTS auto (PRL)" to "LTE/WCDMA" using using *#*#4636#*#*

    Made a huge difference to the battery drain. I am now back decent battery times and extreme power saving mode does not feature anymore in my battery stats.
    2
    I get double battery life on N compared to P, ATM
    Naptime I use for quick deep doze, seems to be working well

    What about 605 firmware and 617 radio? May give good doze + volte.

    You mean N vs O? I used Greenify on O, not Naptime but I understand Naptime may be better?

    I expect I can probably load N 617 RUU, get good battery & VoLTE, but the 10 should be able to go so much further... now that I've experienced Oreo I don't want to go backwards.

    I did 605 FW with 617 radio; 605 by itself only let me connect up to H+ on AT&T, flashing 617 radio unlocked LTE, but not VoLTE. And Doze kicks in very well w/ this combo.

    Next I flashed 617 CRadio, Modemst1, Modemst2, Rfg_2, Rfg_3, but VoLTE just won't work.
    I sort of gave up experimenting w/ mix & matching FW bits, for now...

    Edit: the battery drain on 617 appears to be due to HTC Weather app. I froze com.htc.weather & com.htc.widget.weatherclock with TB and now my battery is solid in standby - Doze kicks in beautifully.
    Hope this was it, will monitor...

    Edit2: that was temporary... Wakelock came back.
    New solution: used Tasker to kill Location w/ screen Off. Seems OK and survives reboot for now.