Search This thread

DaRekAndro

New member
Nov 15, 2022
2
0
Hi
I'm new to uploading roms etc. soo sory for stupid questions ;).

I have old HTC Desire C310 and Pentagram Monster phone, I wanted to turn it into navigation.
Tell me it is a possibility (and how to do it) to install a newer android on such an old phone. I want to install things from GooglePlay (or even better some navigation with onffline maps).
The instruction from first post will be good / up-to-date?
 

MaRtYy01

Senior Member
Jan 13, 2015
533
201
Plovdiv
Hi
I'm new to uploading roms etc. soo sory for stupid questions ;).

I have old HTC Desire C310 and Pentagram Monster phone, I wanted to turn it into navigation.
Tell me it is a possibility (and how to do it) to install a newer android on such an old phone. I want to install things from GooglePlay (or even better some navigation with onffline maps).
The instruction from first post will be good / up-to-date?
I updated the links earlier this year so the first post will be good.

The gps on this phone is generally pretty bad though, I wouldn't rely on it for seriouss navigation. Especially on a custom rom.

For navigation you can install the latest compatible version of iGO and load up the maps on an sdcard(I think this was possible).
 

Top Liked Posts

  • There are no posts matching your filters.
  • 37
    Thread update 15.04.2022, fixed some links, removed others, added RR 5.8.8 and did some formatting.
    So since there were many users who had questions for roms,root,firmware and stuff like that which was already available but only in small posts,I finally decided to make a big official thread for the HTC Desire 310 and 320. Why 1 thread for 2 phones? Well,they are practically the same phone but desire 320 is running on stock kitkat and has flash.
    Port guys and developers: @MaRtYy01 aka Martin Dimitrov @HTC Desire 310 aka 69techur aka Alija Huskic (Team N3GG3)
    @Swoopae (deserves to be here lel) and users in 4PDA Desire 310 and 320 threads
    New facebook group :D (tnx Swoopae) click


    1.ROOT
    Flashable SuperSU zip: in firmware flashing video
    (tested and working on 4.4.2) Kingroot: click password is amogus (I encrypted it so mega doesn't think I'm uploading malware or something)
    Kingoroot: you dont need to use that thing anymore
    (4.2.2 only) Universal Root: click password is amogus
    (4.2.2 only) Kingroot old offline version click password is amogus


    2.RECOVERIES
    Recommended-CWM 5(you dont need anything else,everything on 4.2.2 can be flashed with it): click
    CWM 6 click
    TWRP click
    Stock recovery(if something messes up with other recovery and you get into bootloop flash it with sp flash tools) click
    OTA - for android 4.2.2 click

    Steps:
    1.Put the OTA (named as update.zip) and the CWM on your SDCard
    2.Reboot to Recovery (Volume UP + Power)
    3.Select "apply update from sdcard"
    4.Choose our update.zip (OTA)
    5.It will return an error(if it doesnt then you should flash the stock rom with sp flash tools)(as our device is already updated) and it will let you choose two options. SELECT REBOOT SYSTEM NOW
    6.After the phone is fully booted up, proceed to install the recovery as you wish!!!RENAME THE RECOVERY TO RECOVERY.IMG OR YOU WILL END IN BOOTLOOP!!!(You can use Rashr or MobileUncle MTK Tools or whatever you want)
    7.After install, reboot to recovery

    4.4.2+
    These don't work if you are with the jellybean firmware(kernel 3.4.5), only for desire 320 firmware. Required to flash roms with version higher than 4.2.2
    - Philz Touch click in this archive you have all stuff required for the rooting and installing the recovery on the d320 kitkat rom. Password is amogus
    - Philz Touch mirror link without any other stuff coming with it: click mirror
    - Flash the OTA click mirror with the stock recovery and reboot, go to mobile uncle tools and flash the recovery (new recovery.img)
    btw OTA for android 4.4.2 is different from the jellybean one


    3.ROMS
    These roms are usually bugless or with minor bugs that dont interrupt the work. All ported from 4PDA users
    XPERIA C click (sometimes gives errors while installing apps)
    Lenovo(vibe ui) click
    MIUI 5 click (one of the best 4.2.2 roms)
    Lollifox click
    Moonmod click
    CyanogenMod 10.1 click (google play doesnt work)

    4.4.2/4.4.4

    WARNING:YOU NEED THE DESIRE 320 FIRMWARE TO FLASH ROMS WITH NEWER VERSION THAN 4.2.2
    [07.11.2016]MIUI 8 click (bugless) [ported by @Swoopae]

    [01.11.2016] AICP 10 click
    gapps(for AICP only) click [ported by @MilkyPL]
    [26.8.2016]CyanogenMod 12.1 click bugfixed version by @Swoopae
    Flyme OS 4.5 link in kk firmware flashing video (google play doesnt work,I will try to fix it soon;gapps built in) [ported by me]

    Not 100% of the roms are well tested, so have a working rom as backup in case the rom you try doesnt work properly, also report back if you experience this.

    IMPORTANT-If you own desire 320 flash this patch right after the rom or you will face wifi issue-click
    Its made for marshmallow roms,so work for lollipop and kitkat isnt guaranteed. Tbh it doesn't always work on marshmallow too lmao

    For mounting the sdcard as internal storage,here is @Swoopae 's patch click
    It's made for cm13 but will probably work on other marshmallow roms too.

    [14.11.2016]Mokee 3 click (bugless,vpn also works,just 2g switch bugged) [ported by @Swoopae]
    [01.11.2016]AICP 11 click (gotta be almost bugless as all new mm based roms) [ported by @MilkyPL ]
    [12.10.2016]TemastekPLUS click (improved and tweaked temastek cm13,bugless,vpn also should work) [ported by @Swoopae]
    [02.10.2016]SwoopaeOS r01 click (based on slim6,fixed lag and minor bugs plus a sexy theme) [yes its by @Swoopae]
    [04.9.2016]Paranoid Android 6.0.3(aospa) click (vpn and audio from headphones doesnt work) [ported by @Swoopae]
    [17.8.2016]CyanogenMod 13 click ( very stable, gps, google play work,just fm radio doesnt work) [ported by @Swoopae]
    [15.8.2016]Slim Marshmallow click (everything except fm radio works) [ported by @Swoopae]

    7.1.2
    |27.09.2017| Resurrection Remix N 5.8.4 by Swoopae: click
    (should work well,needs some testing)
    |15.04.2022| Resurrection Remix N 5.8.8 by me: post download
    Steps:
    1.Make sure the rom is on the sdcard
    2.If you wish you can make a backup of your current rom
    3.Wipe cache,data,system;dont mount anything/wipe for a new rom on philz recovery
    4.Select update from sdcard/zip from sdcard/whatever is it from sdcard
    5.Choose the rom zip and flash it
    6.Flash gapps if the rom requires it(pico gapps are strongly recommended)
    7.Reboot,first boot takes 3-8 minutes depending on the rom
    GAPPS: http://opengapps.org/
    Choose arm - whatever android version rom you are flashing - pico are recommended,if you have problems with gapps try with pico,flashing after rom and after 1 boot and then report if still doesnt work


    4.Firmwares



    - Have any problems with the gps? Try this: click and this: click
    - Desire 310 stock roms:
    single sim: click mirror mirror 2
    dual sim: click mirror
    - Desire 320 stock rom(works for both d310 single and dualsim): click ; When installed on desire 310 bugs of that firmware are little while line on top of the screen and auto rotation(screen flickering too but doesn't happen on 5.0+ roms)
    - SP Flash tools: click
    - Driver: click
    - Fix for driver signature error on windows 8/8.1: click
    - Stuff for fixing imei(including toolhero): click mirror
    - If you don't want to flash the desire 320 firmware and just want to unbrick this tutorial will be more helpful(also works if you have desire 320 and want to unbrick): click
    HTC Desire 310 aka 69techur reported that Lenovo A328 firmware also works without flickering on and white line,but volume buttons,camera,rotation and a lot of other things dont work.
    - Instructions for flashing D320 firmware on D310:
    1.Backup imei with toolhero on 4.2.2
    2.Install the driver on the pc,if it cant install them because they arent signed-disable signature verification(test mode) or try on other pc
    3.Run the sp flash tool with compatiblity mode windows 7(only if you are on newer os) and set everything on it like in the video, connect the phone to the pc without battery and holding volume down;da dl with cheksum,high speed,no battery in the options,select firmware upgrade and start to flash
    4.Root with the pc software,make sure you have enabled usb debugging in developer settings
    5.Flash the OTA with the stock recovery and reboot, go to mobile uncle tools and flash the recovery(new recovery.img)
    5.Now you have recovery.Wipe system,data and cache and flash the rom you wanna flash(the 4.2.2 roms dont work anymore) after that flash gapps if the rom requires it and reboot.
    KERNEL BUGS:Screen flickering(kitkat roms only),screen rotation,little white line on the top of the screen


    5.YOUTUBE



    Kitkat firmware,recovery and roms installation: click
    CyanogenMod 13: click
    How to fix imei: click
    CyanogenMod 12.1: click
    CyanogenMod 10.1: click
    MIUI 5: click
    Galaxy S5 mod: click
    The HTC Desire 320 rom: click
    AICP 6.0.1: click
    CyanPOP 5.1.1: click
    CleanKat 4.4.4: click
    Wanna port a rom on your own? Here is a video guide for android 5 and 6: click
    and written tutorial: click

    Credits:



    -The users of 4PDA for all 4.2.2 roms and all recoveries, cm12.1, guides, etc.
    -Me for translating the guides, youtube videos and ported roms
    -HTC Desire 310 aka 69techur for helping me test stuff, his porting tutorial, ported roms and youtube videos
    -Swoopae and Tomi Sudi for ported roms
    -other guys that I havent mentioned
    If you have questions, reports about bugs, requests or something feel free to ask.
    Don't forget to hit thanks ;)
    3
    There is a way to increase the storage in Marshmallow? In cm 12.1 the sd card is the default space to images, videos, whatsapp folder and other whereas in cm 13 it save everything in internal memory. In Lollipop i used link2sd for app, in Marshmallow it fuction?
    Probably,but when I get home I will port RR M 5.7.1,the dev of it said sdcard is mounted as internal,gps is officially fixed,etc.,sounded as a nice rom.
    3
    Sooo...
    Today, I´ve managed to install Galaxy S5 rom on gf cell phone. It was super easy.
    If I remember correctly, this was my step-by-step:

    1. Download CWM5. Unpack that file (contains OTA_v1_u.zip and recovery.img).
    2. Rename OTA_v1_u.zip to update.zip.
    3. Upload update.zip and recovery.img to SD. Upload Galaxy_S5_HTC_Desire_310_Dual_sim.zip on SD too.
    4. Reboot to Recovery (VUP + Pow).
    5. Select "apply update from sdcard".
    6. Choose update.zip.
    7. a) Will return an error and it will let you choose from two options.
    8. Select reboot system now.
    9. recovery.img (from CWM5) flashed from Rashr.
    10. Boot to recovery, flash Galaxy_S5_HTC_Desire_310_Dual_sim.zip
    11. Restart.
    12. Boot to recovery, full wipe and factory reset.
    13. Restart.
    14. Boot to recovery, flash gapps for 4.2.2. (from other source).
    15. Restart.

    Now, there was a few things:

    - Keyboard was not installed at all, so I´ve copied [censored] keyboard apk to SD and installed it.
    - Dialer not showing dialing number (this is probalby because this rom is for S5 which have bigger display). Solved with 3rd party dialer.
    - Same thing with date on unlocking screen. Not solved, ignoring for now. Can be probably solved with 3rd party screen locker. Will test it later.
    - There is very annoying pop-up about back cover. Did fast look through google and it is solved by xposed, but will not install it until someone from you confirms it will not brick this phone :)
    - When tap on those six dots in round shape (on desktop) to acces all icons of apps, and then tapping any upper icon (upper meaning first and second line from to), sometimes instead of running the app it will roll down status/notification? bar. Not a critical bug but can be annyoing.

    - ADDED: Well, it looks like we cant turn data on, when both sims are present. Yes, we have sim which we want to use for data in slot 1 but still, we cant turn data on (no sign of 3G above cell signal). But I remember, it works when there is just one sim. Major problem.
    - Another problem, GPS. It is working but it is still ON. We cant turn it off, not even in settings. Major problem. Will try it later without second SIM.
    - CONFIRMED: It is problem with second SIM. When we using just one sim in slot 1, there is no problem, data works, GPS works as it should. So if you could look at it, please (if solution exists).

    Last two bugs above (GPS and data) still occuring but not every time. Looks like switch is bugged.
    EDIT: Did full wipe, format SD, reflashed G5 mod and now works without those bugs. Probably my fault flash. Yay!

    So far so good.
    Maybe we will try CM13 but now gf will test it for a few days.
    THANKS guys, she is happy with her phone now. And you know, when gf is happy, you are happy too :)
    3
    Reading this comments makes me feel like my IQ decreasing
    2
    Only thing it does is that I hear sound of connecting device in W7. Phone should boot into something or it is just for connection with pc?

    the screen should stay black and sp flash tool should start flashing. Have you fb or any social media for faster replys?