HTC One camera purple tint possible fix

Search This thread

positiveg

Senior Member
Oct 17, 2012
241
10
Newton Ground
That's how mine was terrible. I never used to bother taking pics. And when they weren't pink they were blue

Sent from my HTC One using XDA Free mobile app
 
uploadfromtaptalk1434399369877.jpg
Pic taken in Dark. Replaced cam myself feels like back.to.life[emoji12]


http://www.aliexpress.com/item/Back...7-Original-new-Free-shipping/32242205804.html
 
  • Like
Reactions: doc_v15
I ordered one just like you showed me. I hope to be good. Thank you.
Yeah it will @positiveg only gave me the link. But I bought from this supplier as it was cheaper. Read few pages back @positiveg mentioned which he ordered. I also ordered almost similar.. it's some y.125 I dun remember now. But trust me it's awesome..
 
  • Like
Reactions: justion

Panpan_99

Member
Dec 24, 2010
30
2
Perea / Thessaloniki
I had the same problem in ONE M7 UL .
I tried to solve it. . . and made another to the parent.
Rather than a short circuit.
Can someone help me.
What materials can I check to repair.

(The board camera and all cables are OK. ! !! )

Thanks.
 
Last edited:
I had the same problem in ONE M7 UL .
I tried to solve it. . . and made another to the parent.
Rather than a short circuit.
Can someone help me.
What materials can I check to repair.

(The board camera and all cables are OK. ! !! )

Thanks.
It's better if u check video how to change. Maybe u didn't fix the battery cable.. few pages back u can find one. Or there r several on YouTube.
 
  • Like
Reactions: Panpan_99

positiveg

Senior Member
Oct 17, 2012
241
10
Newton Ground
Same for me going on two months. I take pics at night just to see how good it takes them lol


Sent from my HTC One using XDA Free mobile app
 

Attachments

  • 1435230332273.jpg
    1435230332273.jpg
    53.7 KB · Views: 741

pavelski

New member
Jul 3, 2015
1
0
Summarizing

So to summarize the info which we got so far from this thread.
Which model camera is fixing the purple and is without green.
When I was searching for new camera in aliexpress I found two options on 13P1BS402 model 1. M1434B1.0 - 16.01€ with delivery
2. M1436B1.0 - 19.21€ with delivery

For both people were saying that purple think disappears, but no one is saying anything about the green saturation or whatever it is.
 

positiveg

Senior Member
Oct 17, 2012
241
10
Newton Ground
So to summarize the info which we got so far from this thread.
Which model camera is fixing the purple and is without green.
When I was searching for new camera in aliexpress I found two options on 13P1BS402 model 1. M1434B1.0 - 16.01€ with delivery
2. M1436B1.0 - 19.21€ with delivery

For both people were saying that purple think disappears, but no one is saying anything about the green saturation or whatever it is.
This is the one I have
13P1BS402
There is no more purple neither a green saturation
Camera is wicked. here's a pic I took yesterday.
View attachment 3392954
It shows how seaweed is wreaking havoc on our beaches
 

Ilija88

New member
Aug 2, 2015
1
0
I have HTC One, it's purchased in Germany and I live in Serbia. Got red camera as most of you guys, and really had issue to send it to repair, first no one wanted to touch it then i sent message to HTC on facebook and support contacted me and they said to send it to Belgrade HTC service so they can ship it to reseller in Germany on repair. Had to agree on 60 days repair :eek:


On 15th august 2015. 60. days expires, what if I do not get my phone back on time ?
 

justion

Member
Oct 5, 2012
36
7
Corabia
I just installed new camera like the one you suggested me but my camera app doesn't connect to camera module. Either Google camera or Instagram or sth else. In /sys camera sensor is ov ov4688 4M. Have anyone faced this issue? Is the camera broken or is something about drivers? I have the latest version of maximus hd rom and elemental x kernel.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 12
    Just want to let every developer know, I have a possible way to fix the purple tint.
    This is my findings...

    When you set your saturation and explosure to -1, the purple tint just gone. But saturation -1 seems too much for the photo. It is ideal to have -0.5 or somthing.

    It is nice that if a developer know how to modify the Camera setting and make it default.

    UPFixE_zps52cc7648.jpg
    7
    Mine is stone cold and it still happens. Since it didn't happen prior to the 4.2.2 update, it definitely isn't a hardware issue.

    This is most likely an incorrect assumption. If you check out the primary thread for this issue http://forum.xda-developers.com/showthread.php?t=2317507 you'll see that it cannot be software alone and is mostly hardware. I'll spare you from reading through the 260+ pages in the thread, here's a summary of why:

    -For many it can be induced by heat (physical induction means physical problem). Some can be fixed by cooling below 20 degrees (same)
    -On both Google and normal editions
    -Independent of batch and factory (so far)
    -On all versions of OS and firmware (definitely not just 4.2)
    -Worsens with time (software doesn't behave like that)
    -Replacing the sensor temporarily fixes it
    -Replaced sensors seem to begin to develop it again with time
    -It is well known that some image sensors are more prone to this kind of heat noise problem

    Why do some phones not have it? Could be luck (a few better sensors in an ocean of not so good ones), maybe it hasn't developed yet (we know it gets worse with time), or maybe there's actually more than one problem going on here. The last possibility is interesting because while everyone seems to have the color issue, some aren't as impacted by factors, some have other patterns of noise, etc... It's hard to say.
    But it can't be entirely software given the above.
    6
    Arvato Germany Experience

    I am writing this post to let everyone know about my experience concerning the service that HTC offers in Germany through Arvato (in Bielefeld).

    My phone, a red unbranded HTC One with an August mfg. date, was purchased in the UK the last days of September 2013. It came with an ST sensor made in July. At first it was ok, then gradually its sensor began degrading. The firmware upgrade that came with android 4.3 and introduced the software fix (the one that defaults the iso at very low levels when in low light) at first did the trick, but as time passed the problem became so severe that the fix didnt work anymore.
    During the last month even daylight photos had a hint of purple. All this time I was hesitant to send my phone for repair due to 3 reasons: a) All the horror stories stated here (phone back with the same problem,or fixed phone that later on developed the same problem, or scratched/poorly handled phone), b) the fact that I didnt want to be left with a phone that cannot be s-offed, as well as c) the fact that I didnt want to lose my 40$ Spigen Glas.tr that I have fitted perfectly and that is so hard to find nowadays.
    I decided to bite the bullet and send it for repair, facing the concequences. Since I currently live in Germany, Arvato was my only choice. The whole procedure lasted 7 days, including a weekend and the days the phone was in transport.

    Results:

    -The phone came back very, very well packed. Its condition was INTACT. Except from 2 tiniest, pinhead-shaped dots in the apex of the chassis close to the volume rocker, marks that you cannot see (and trust me when I say that they are nearly invisible, I am heavily OCD) the phone returned in the same pristine condition exactly as I sent it, covered in plastic foil front and back, in a sealed plastic bag, in a ton of bubblewrap.
    -Except from the replaced camera sensor (which the enclosed repair details state as a SHARP one, although in the sensor info file it is stated as the classic OV) they replaced the top and bottom speaker covers, the volume rocker (with a more matte one) the already flimsy USB port, the headphone jack, and half a dozen of thermal insulation pads.
    -Lastly, the fact that blows my mind (in a good way) is that they didnt mess with my glass screen protector at all! Although they explicitly stated that the screen protector will be destroyed and discarded, I insisted on taking care of it if possible, and they did. My phone came back with the protector intact, and on top of that they even included a new HTC screen protector on the box!

    The aftermath:

    -The phone now takes crystal clear pics in every lighting condition. Its not only that there is not a single hint of purple in low light, the phone now focuses faster in any condition, and the resulting pics are sharper. I believe that during the last period the old sensor was so much degraded that even in broad daylight the photos produced were not only a little bit tinted, but also very very soft ( as if someone messed with the sharpness option of the camera)
    -The device now doesnt heat as much as it used to. Previously after a heavy game or video recording the phone was getting really hot, to the point that it still felt warm after a while even through my jeans pocket. Now it just gets a little warmer, and thats all.

    After this experience I have no choice but to undoubtedly reccomend Arvato Services in Germany, as they proved to be really good at what they are doing, at least with that particular problem. Should you live, or have the opportunity to send the phone for repair in Germany, dont hesitate. I wish I would have done it earlier, given the fact that I now see what I was missing by having a crippled camera.So, kudos to Arvato Germany, I wish that every official HTC repair center would act in such a professional manner.
    6
    So I was playing around a bit just to see what would make the pics better. I believe heat is certainly a contributing factor. I have an Otter Box Defender case which protects it well but, it may be part of my problem. Once I took the case off, the purple tint was virtually gone. Even pointed into a dark room, the screen stayed dark. The pics were okay but I found you really need the flash to be on to get a clear pic. My ISO was set to 200 and saturation was set to -1. Not sure if this will help anyone but I thought I would share.

    Sent from my HTCONE using xda app-developers app

    How is your weather where you are? is hot? how much?.
    The problem appears after you reach 34.5C° (95-94F), you can check the temp of your phone dialing *#*#4636*#*# and then choose battery.

    This problem is called "amp noise", and is electrical interference to the sensor, the sensor has a bad shielding.
    If they just keep replacing the same sensor (same model, same shielding) the problem WILL come back after some use and degradation of the shielding.
    You can correct (sort of) this noise using exposure-controller apps, like Camera FV-5.

    To reduce the heat from the phone, and have more time to make a shot or record a video, you can set power save mode on, and limit the CPU.
    All of this can HELP but not fix the camera, even replacing the sensors will NOT fix this issue until HTC improves the shielding of the sensor.
    This can be helped via FW also, but its a longshot, maybe with 4.4? some people reported to having the problem almost fixed with that.

    If in my country was winter right now, I will never gonna find out this, 'cause here we have 8 months of cold, below 16C°, and the phone under 34C° performs great.

    High ISO in a phone is a bad idea, little room and so much hot and noise.
    The Galaxy S4 have only 800 ISO max, and that's for a reason.

    Maybe the problem is the motherboard, or the design itself, and it's too expensive to totally fix it, who knows, but i know for sure, that ISO +800 in a phone is gonna be tricky, and that is why this problem is happening again to people who got the sensor replaced, from all over the world, and in differents time-frames.

    Amp noise happens to every camera, even the most expensives, the longer you got the camera on

    Wanna do a test? just go to a low lighted room, and turn on your camera and set the ISO at its highest (1600 i think?), and just focus something, but make sure that the corners of your camera are in a dark spot and wait, but do not let the camera go in sleep mode, we want to have ful exposition, and test how fast the sensor will heat up.
    Most of the cameras, after 15 minutes or so, wil show some blue-purple amp noise in the corners, that is normal.
    If your phone, after 5 minutes or less starts to show purple-blueish spots on the corners, then it's not properly shielded/heat protected, and that duration will go down with time.
    PD: If you live in a cold country its obvious that the test will be affected.

    Sorry for my english, its not my prim language.

    PD2: The explanation of why the screen will turn all purple/red when you cover the lens or enter a dark room is simple, is 'cause the phone, when detects no light at all, it will set the ISO to the max, in order to get some light, that makes the sensor heat up really fast, and if hets up, and had a bad shielding then the noise happens.
    The 4.3 "fix" just make this mechanism work backwards, now when the phone detects a lot of dark, or complety dark, it sets iso to 100, to prevent overheating.
    And thats why also some users experiment some "flashing" like a disco in some low light conditions after the 4.3 fix, 'cause the phone says:

    -OH SHT! THERE IS NO LIGHT NO LIGHT! I MUST TURN ISO 100, MUST FIX THIS HEAT!
    but then detects light
    -OH WAIT! THERES SOME LIGHT HERE! LETS RAISE UP THE ISO!
    but then you just move the phone a little to the left and...
    -OH NO! DARK AGAIN, LOWER THE ISO NAO!!

    Result: flashing screen disco madness xD
    5
    Just to add my 2 cents, so it’s not worth much. I tried an experiment bylocking the AE and AF on an object or color in a given light level, and then testing on a dark flat black surface. First I did it on a (low-light) red item, and got a fantastic blue noise. then i tried a low-light white object, locked that and got indigo noise. I then used a blue surface in bright light and had pure dark, no noise. When i remove the AE and AF lock, in the facedown all dark mode, it shifts to red noise.

    So, the pattern is (as I see it) is all that the sensor chip does is collect the data,what we see is what the software renders from the sensor. White balance and ISOlevel have a huge factor in what color noise, and when. If you have your ISOthrough the roof and no real info hitting the sensor, the software willdecrease the software based tolerance for noise by increasing the ISO until allyou have is noise. After that, the noise color is dependent on the color tempof what the auto WB sees, and will gradually work its way to"daylight" or "cloudy" equivalency. You can test this bygetting to the point where you have red noise, and then manually changing thewhite balance through the selections. As far as a fix, the sensor is doing itsjob. The software would have to be tweaked to not get so noisy in an ultra-darksituation, and use an algorithm to remove appropriate color noise in high ISOsituations based on the detected color temp (WB).

    You had the basic concept down up until you mentioned tweaking software. No algorithm can get rid of the shroud of noise that basically overwhelms the sensor and prevents it from capturing actual image data. The problem is that the old camera modules aren't properly shielded. Thermal and electrical noise from other parts of the phone are always interfering with the sensor, though in bright light, you won't notice it because the ISO (sensitivity) is turned down and you still have a large signal-to-noise ratio. In low light, where the signal is pretty weak, that's when you run into problems. At that point the noise is physically "blocking" the photons and the camera isn't able to distinguish between real and garbage data.