HTC One GSM Modaco switch boot loop

Search This thread


Aug 7, 2013
I installed Modaco switch Beta 8 on my HTC One after rooting it and installing TWRP custom recovery. I can't post a link in this because I haven't posted on the site enough. If you just google MoDaCo swtich, the information will show up. Sorry for the inconvenience but Switch is actually a very cool rom that gives the best of both worlds.

It was working well and I was not having any problems until I downloaded an app called Haxsync. Haxsync syncs Facebook information into People because stock does not support that like Sense does. I pulled the notification shade down and clicked the app, the phone proceeded to completely shut down. I was in the stock 4.2.2 rom when it cut out. I tried to reboot it and got the "htc quietly brilliant" screen. Then the GPE boot screen came on and once finished the "htc quietly brilliant" came back up and it goes nowhere. I can get into the boot loader and it says "unlocked" and "tampered", S-ON is also there. When I try to get into my TWRP recovery the TWRP splash screen comes up and then it jumps back to the "htc quietly brilliant" screen and it wont go away. When I select factory reset, it brings the TWRP screen again and then goes back to the "htc quietly brilliant".

I tried to unlock the boot loader again but when I tried to push the Unlock_code.bin file to the phone again, the unlock boot loader screen never comes up. I tried to unlock the boot loader again because it would presumably factory reset the phone so that I could reroot it and reinstall the Switch rom and go back the way it was before. Sadly that would not work.

I am on running Mountain Lion on my mac and windows 8 through bootcamp. The HTC One drivers do not work on windows 8 no matter how hard I try and what i do to try to upgrade them. If I need access to a WIndows 7 pc then so be it.

From my research I need to relock the boot loader and then run the RUU thing to factory reset it back to the stock firmware. I can't figure out how to relock it with my mac and the RUU wont won't on mac. I don't know how the "S-ON" works in here.

If my phone has to be completely wiped then so be it and I will work back from scratch. As long as I can get my phone back I will be a happy camper.

Suggestions and help are greatly appreciated.

Thank you
Last edited: