[Huawei] [Kirin 960/970] Stock Camera app for Treble ROMs

phhusson

Recognized Developer
Jul 23, 2009
2,448
4,682
203
Paris
Here is the stock camera app for Huawei devices, for Treble ROMs.


DISCLAIMER: Warning. This might brick your device, use with caution.
You must own a Huawei device to have the right to use this application


Build script:
https://github.com/phhusson/huawei_camera_aosp

Versions:
v1 (2018-01-15):
- Based on Mate 9's Oreo
Download

How to install:
You'll need a root file manager.
Install the apk in /system/priv-app/HwCamera2/HwCamera2.apk

Troubleshooting:
- The application crashes on start
> Did you actually install the APK to /system/priv-app/HwCamera2/HwCamera2.apk?
>> If you didn't, well tough luck. you'll need to factory reset.
>> If you did, well give me logs of the crash.
 
D

Deleted member 2405884

Guest
Hi @phhusson,

Firstly thanks for your work on treble (running v9 su and gapps on my p10 plus)

Created the folder and placed the apk as advised (folder permissions set to 755, apk to 644) rebooted but can't launch the app.

logcat attached
 

Attachments

  • Like
Reactions: kaeporan

v0ne

Senior Member
Jun 19, 2015
293
136
63
Here is the stock camera app for Huawei devices, for Treble ROMs.


DISCLAIMER: Warning. This might brick your device, use with caution.
You must own a Huawei device to have the right to use this application

Build script:
https://github.com/phhusson/huawei_camera_aosp

Versions:
v1 (2018-01-15):
- Based on Mate 9's Oreo
Download

How to install:
You'll need a root file manager.
Install the apk in /system/priv-app/HwCamera2/HwCamera2.apk

Troubleshooting:
- The application crashes on start
> Did you actually install the APK to /system/priv-app/HwCamera2/HwCamera2.apk?
>> If you didn't, well tough luck. you'll need to factory reset.
>> If you did, well give me logs of the crash.
Mate, tried the app (installed in /system/priv-app/HwCamera) but it crash. So I try to find the problem and i got that libHwPostCamera_jni.so in /vendor/lib64 is missing. So i extracted the missing file in stock emui rom and the camera is working now.

Btw, I used p10 plus. I attached the missing file.
If someone want to try, just copy to /vendor/lib64 and set to 644 permission

Also thank you mate. Your awesome :good:
 
D

Deleted member 2405884

Guest
Mate, tried the app (installed in /system/priv-app/HwCamera) but it crash. So I try to find the problem and i got that libHwPostCamera_jni.so in /vendor/lib64 is missing. So i extracted the missing file in stock emui rom and the camera is working now.

Btw, I used p10 plus. I attached the missing file.
If someone want to try, just copy to /vendor/lib64 and set to 644 permission

Also thank you mate. Your awesome :good:

Works!
 
  • Like
Reactions: howdid

IOmega666

Senior Member
Apr 26, 2009
857
83
58
Mate, tried the app (installed in /system/priv-app/HwCamera) but it crash. So I try to find the problem and i got that libHwPostCamera_jni.so in /vendor/lib64 is missing. So i extracted the missing file in stock emui rom and the camera is working now.

Btw, I used p10 plus. I attached the missing file.
If someone want to try, just copy to /vendor/lib64 and set to 644 permission

Also thank you mate. Your awesome :good:
How did you guys do it? I downloaded a Root Browser, made the folder HwCamera2 in system/priv-app/ but it fails when copying the .apk :( what root browser did you guys use?
 
D

Deleted member 2405884

Guest
How did you guys do it? I downloaded a Root Browser, made the folder HwCamera2 in system/priv-app/ but it fails when copying the .apk :( what root browser did you guys use?
You'll need to free up some space in /system or resize system image
 

theandroidguy

Senior Member
Aug 20, 2016
1,585
351
83
22
Kolkata
Those who are facing any problem while using any root browser, the best option will be Mixplorer, which is available in our XDA forum, no need to set permission, just copy the file, permission gets set automatically.
 
  • Like
Reactions: Swan Princess

MiKy2o

Member
Apr 4, 2016
18
2
0
Turin
Mate, tried the app (installed in /system/priv-app/HwCamera) but it crash. So I try to find the problem and i got that libHwPostCamera_jni.so in /vendor/lib64 is missing. So i extracted the missing file in stock emui rom and the camera is working now.

Btw, I used p10 plus. I attached the missing file.
If someone want to try, just copy to /vendor/lib64 and set to 644 permission

Also thank you mate. Your awesome :good:
Thanks, your fix works on my Honor 9 :D
And also huge thanks to Phh for the port!
 

IOmega666

Senior Member
Apr 26, 2009
857
83
58
tried to copy apk to new folder and not enough space. using mixplorer what am I doing wrong?
You gotta free space up. I deleted the apps that Google provides, Dialer, Contacts, Chrome and then installed the APK, and those I deleted I downloaded them from Play Store. Did everything with Mixplorer.
 

Pixel Power

Senior Member
Aug 28, 2014
58
8
28
Mate, tried the app (installed in /system/priv-app/HwCamera) but it crash. So I try to find the problem and i got that libHwPostCamera_jni.so in /vendor/lib64 is missing. So i extracted the missing file in stock emui rom and the camera is working now.

Btw, I used p10 plus. I attached the missing file.
If someone want to try, just copy to /vendor/lib64 and set to 644 permission

Also thank you mate. Your awesome :good:
Just want to say that using your file from p10 plus, it also worked on my mate 10 pro.
 
  • Like
Reactions: v0ne