• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Huawei P40 Pro - Google Services suddenly stopped working

Search This thread

Rolud

Member
Mar 30, 2006
34
1
Close to Fribourg
Okay guys, I have fixed the issue on my Huawei P40 Pro. It is working like in the YouTube Video posted by Badmania98.
If you want to do it with a step-by-step tutorial you can follow this link and read the website with the Google Chrome Translator:
So my P40 Pro+ stopped working today with GMS too... 😕

I was really happy to try with your solution... unfortunately it doesn't work with my P40 Pro+ EMUI 11! If possible, I'd like not to downgrade to EMUI 10 and loose everything, so if you have some tips to make it work, it will be really great!
Thanks a lot in advance!
 

Rolud

Member
Mar 30, 2006
34
1
Close to Fribourg
So my P40 Pro+ stopped working today with GMS too... 😕

I was really happy to try with your solution... unfortunately it doesn't work with my P40 Pro+ EMUI 11! If possible, I'd like not to downgrade to EMUI 10 and loose everything, so if you have some tips to make it work, it will be really great!
Thanks a lot in advance!
Sorry for the post above!

Actually, I just tried now to "force stop" Google Play Store, then clear the cache... and now the Google Play Store is working again...

So your solution is working without loosing anything... which is really great! 👍
Thanks a million!
 
  • Like
Reactions: furiousjay

furiousjay

Senior Member
May 4, 2015
61
16
Sorry for the post above!

Actually, I just tried now to "force stop" Google Play Store, then clear the cache... and now the Google Play Store is working again...

So your solution is working without loosing anything... which is really great! 👍
Thanks a million!
Happy to hear that it is working again. So after going through the guide you had to close google Playstore and clear cache? If that's correct I will add it to the guide.
 

TerrorToetje

Senior Member
Nov 30, 2014
220
90
Maastricht
I think all of those tricks only last for a while, sometimes my apps stop working again then reset trick works for some time. It is what it is.
 

Rolud

Member
Mar 30, 2006
34
1
Close to Fribourg
Happy to hear that it is working again. So after going through the guide you had to close google Playstore and clear cache? If that's correct I will add it to the guide.
Yes, exactly! Just after going through all your steps.... I still had the "Not certified device" message with every Google applications. Then I found somewhere in the forum that you have to "force close" the Google Playstore and clear the cache. I tried... and now my P40 Pro+ up and running with GMS... :)
 

sonnaalta

New member
Oct 15, 2021
3
0
Okay guys, I have fixed the issue on my Huawei P40 Pro. It is working like in the YouTube Video posted by Badmania98.
If you want to do it with a step-by-step tutorial you can follow this link and read the website with the Google Chrome Translator:
Thank you so much! It worked for me!!!
 

GuzXT

Member
Jan 31, 2015
32
9
Monterrey
Huawei P40 Pro
It is push notification fix (payed version). I am allowed to share by the creator of file but is not for free. Details in private.
Now, I want to see if the phones that use this fix are affected. Mine is not.

p40 pro affected here... just for statistics

GMS Rule 3.5 [21.39.16 (120400-402663742)]

Play Store 27.5.14-21 [0] [PR] 401824934

Play protect advice in any google apps and no push notifications.
 

Attachments

  • Screenshot_20211016_004556.jpg
    Screenshot_20211016_004556.jpg
    205.8 KB · Views: 20
  • Screenshot_20211016_005000.jpg
    Screenshot_20211016_005000.jpg
    86.1 KB · Views: 20

Afterglow93290

New member
Oct 16, 2021
1
0
Hi there,

Well, i don't know what i really did, but i have fully working google apps without any errors or notifications just by messing with googlefier and trying without going to last step.
I tried lot of tutorials and packages of google apps but nothing worked. So i will explain what i did.

First of all, i don't know what will happen if phone shut off as i never shut it off, so maybe it will not work after restart, so maybe someone should try it.

I used the last version of Googlefier app from XDA

  1. Install Googlefier app
  2. UNINSTALL ALL GOOGLE APPS (Drive, Youtube, Play Store, Maps, Android Auto, Google app, Vocal app ...) That's important that no more google apps are still on phone. Don't forget to delete data, force stop then uninstall to prevent phone from crash.
  3. Open Googlefier app
  4. Tap on "Clean" (last button) to delete remaining apps (SharedLibrary, ...) [IF YOUR PHONE CRASH ON GOOGLE PLAY SERVICES UNINSTALL, RETRY FROM STEP 4, BUT DELETE DATA BEFORE UNINSTALLING GOOGLE PLAY SERVICES APP]
  5. Then tap on first step, it will install MicroG app and ask you to sign-in to google account.
  6. Then, after login, follow step, install apps, until you install Google Play Services app (GMS STD 1 Step)
  7. Open playstore, you should be able to access to it, if you have an error, close it and open it until it shows
And, it works, no more notifications, no more play protect issues (Google, Gmail, Drive, Youtube, Maps tested. Android auto no tested yet)

Here are versions of packages if someone want to make a package with it :

com.google.android.gms.policy_sidecar_aps Version 2052073.215491873.215491873
Google Services Framework Version 10
Google Account Manager Version 4.4.4-1227136
Google Play Store Version 27.5.14-21 [0] [PR] 401824934
Google Play Services Version 20.09.14 (120400-300565878)
Contacts Sync Version 4.4.4-1227136

Hope this helps !
 

aKenn

New member
Oct 15, 2021
2
0
Hi all,
I solved my problem and used the current method.
1. removed all the google application from the phone
2. Go to ICTFix download Huawei package and Lazy App (chinese app with a G)
3. Follow the video Video tutorial
4. Remember to add all your account using the MicroG apps
 

flystarjay

Senior Member
May 1, 2020
66
4
WHen the google apps died, I was so annoyed, I nearly bought an iPhone but there was none in stock. Yesterday I noticed the google apps working again. But I have now preordered pixel 6 pro, I dont want to go through the hassle again.
 
  • Like
Reactions: addx972

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    @addx972 : You are using the same fix as I use. I will send you a solution in 3-4 hours from now via PM.
    1
    @addx972 : You are using the same fix as I use. I will send you a solution in 3-4 hours from now via PM.
    Could you post your solution in this thread? I'm sure many users are interested in it, me included!
    1
    Okay guys, I have fixed the issue on my Huawei P40 Pro. It is working like in the YouTube Video posted by Badmania98.
    If you want to do it with a step-by-step tutorial you can follow this link and read the website with the Google Chrome Translator:
    1
    So my P40 Pro+ stopped working today with GMS too... 😕

    I was really happy to try with your solution... unfortunately it doesn't work with my P40 Pro+ EMUI 11! If possible, I'd like not to downgrade to EMUI 10 and loose everything, so if you have some tips to make it work, it will be really great!
    Thanks a lot in advance!
    Sorry for the post above!

    Actually, I just tried now to "force stop" Google Play Store, then clear the cache... and now the Google Play Store is working again...

    So your solution is working without loosing anything... which is really great! 👍
    Thanks a million!
    1
    WHen the google apps died, I was so annoyed, I nearly bought an iPhone but there was none in stock. Yesterday I noticed the google apps working again. But I have now preordered pixel 6 pro, I dont want to go through the hassle again.