• We are moving to xdaforums.com!

    Posts made between now and when the migration is complete will not be carried over.
    You will be automatically redirected once the migration is complete.

Huawei Y6 2018 ATU-L21 bootloop after reflashing

Search This thread


Senior Member
so i got bricked ATU-l21 and the problem was that phone was displaying message "your device has failed verification..." and after pressing power button it was stuck at boot animation. So i reflashed the firmware using sdcard and it installed so it should work Right?? not in my case now the message disappeared but the phone is still stuck at the boot animation but this time after some time it restarts to eRecovery, so i tried another 3/4 firmware and always the same result also before flashing 1st firmware i could normalny do factory reset and after first flash i'm unable to do that becuase after 4% it stops and in the circle shows exclamation mark. after the last firmware phone started to display "your device has failed verification..." again

ps: sorry for any mistakes but english is not my native lang, i hope you can understand what is typed here


  • IMG_20230601_222944016.jpg
    1.5 MB · Views: 4
  • IMG_20230601_222800826_MF_PORTRAIT.jpg
    933.4 KB · Views: 5