I-545 Not taking Metro PCS Sim. What am i doing wrong?

Search This thread

Uzzyman18147

New member
Sep 29, 2015
2
0
I've tried T-mobile's APN and called metro for theirs still no luck.... all it says is no service and that "Sim card is not verizon." Not sure what im doing wrong. Set to global and LTE/GSM tried APN in both setting with reboot. Nothing....
It's stock 5.0.1 no root. Everyone says they have theirs working but the thing is i cant even get the service to start. Where am i going wrong here? Thank you in advance for any help.
 

gigilie

Senior Member
Feb 6, 2011
772
1,103
MN
I've tried T-mobile's APN and called metro for theirs still no luck.... all it says is no service and that "Sim card is not verizon." Not sure what im doing wrong. Set to global and LTE/GSM tried APN in both setting with reboot. Nothing....
It's stock 5.0.1 no root. Everyone says they have theirs working but the thing is i cant even get the service to start. Where am i going wrong here? Thank you in advance for any help.

you need to sim unlock your device I'm not sure that needed to be said but its kind of obvious... after sim unlocking you can easily enter in the metropcs-fast.metropcs.com or tmobile apn settings with any of my ROMs and get a signal. I know because thats my setup as well. i know their supposed to be factory unlocked or whatever but for me to rid myself of that sim error I had to call VZW and get the actual unlock code for the device and enter it in the old fashioned way. they are supposed to or will guide you if you call in and the phone is paid in full. then yes register the imei number and your metro sim card number with metro which takes maybe 5 min and you're set.