I can't seem to Flash Magisk after the most recent OTA

Search This thread

Isadorian

Member
Oct 12, 2019
9
3
I have TWRP installed but any time I try to Flash magisk, the boot image seems to corrupt and leaves me on the 'Bootloader unlocked' screen. I have to boot back into bootloader and use the 'repair recovery boot loop' option just to get back into my phone which then doesn't have Magisk available and root has not taken. Does anyone have any advice? Is there a boot image I need to flash after Magisk maybe? I'm fairly new to all this.
 

gwadalolo

New member
Jan 26, 2020
1
0
I have TWRP installed but any time I try to Flash magisk, the boot image seems to corrupt and leaves me on the 'Bootloader unlocked' screen. I have to boot back into bootloader and use the 'repair recovery boot loop' option just to get back into my phone which then doesn't have Magisk available and root has not taken. Does anyone have any advice? Is there a boot image I need to flash after Magisk maybe? I'm fairly new to all this.

Hello, would love to know because I have same issue here …
In fact I could effectively have root and magisk installed once, then I installed viper which didn't work... I removed viper module from Magisk Manager, then reboot, then got into the issue you describe. The 'repair recovery boot loop' allows booting but magisk is removed. And if I flash magisk again from TWRP, then the phone won't boot.
I tried reinstall TWRP/Magisk without success, tried lock/unlock bootloader (don't do that ! I could get out of it but no more success with magisk), also tried to remove the viper module with TWRP file manager (I could but it did not solve the issue), not sure what to do now.