Question I Need Help TMO to EU

Search This thread

craznazn

Senior Member
Nov 12, 2009
783
1
482
OnePlus 8T
Samsung Galaxy S22 Ultra
FYI if you are staying on OOS/COS, don't need to flash the old modem if you stay on wifi until the update. OTOH, if you want to unlock the bootloader, you must do it on A11 prior to A12/A13 updates because the A11 abl doesn't check for unlock_code.bin
 
  • Like
Reactions: tom78610

tom78610

Member
Nov 25, 2022
21
6
PARIS
FYI if you are staying on OOS/COS, don't need to flash the old modem if you stay on wifi until the update. OTOH, if you want to unlock the bootloader, you must do it on A11 prior to A12/A13 updates because the A11 abl doesn't check for unlock_code.bin
Thank you for your intervention, I intend to put the phone in official EU ROM.

I'm still on A11 with version 11.2.3.3.

I still encounter the same error. I have downloaded the same version many times from the link provided here, I always get the same result.

Now I will try on another windows computer.
 

tom78610

Member
Nov 25, 2022
21
6
PARIS
After a few hours, I can finally say that I succeeded, I upgraded to A12 and then I installed A13 in local version, I am now in 2125 global rom and last update F17.

I think I can't do better.

Thank you for your help and patience
 
  • Like
Reactions: Appreciative

tom78610

Member
Nov 25, 2022
21
6
PARIS
on the other hand I encounter a strange bug when I restart my phone it does not recognize my SIM card and tells me that there is no SIM card in the phone I just need to remove the SIM card slot and put it back to work. Same for airplane mode.

I think, if it's possible go back with msmtool, I'm really not a fan of Android 13.
i have latest update oxygen 13 L2125 f
1000004441.jpg
1000004442.jpg
17
 

Attachments

  • 1000004438.jpg
    1000004438.jpg
    1.4 MB · Views: 15

Appreciative

Senior Member
Mar 6, 2015
210
120
on the other hand I encounter a strange bug when I restart my phone it does not recognize my SIM card and tells me that there is no SIM card in the phone I just need to remove the SIM card slot and put it back to work. Same for airplane mode.

I think, if it's possible go back with msmtool, I'm really not a fan of Android 13.
i have latest update oxygen 13 L2125 fView attachment 5776471View attachment 577647317
I had this bug in my 7TP5G. I did a factory reset and it fixed it. It was not happening every time I started my phone but maybe 1/6 times. I couldn't get it back on with airplane mode or even reboot. It would just come back on whenever it felt like it. And never shut off again, until I reboot and got unlucky. I still don't know what it was from.


You can go back to OOS11 with LE2125 MSM tool if you want: https://forum.xda-developers.com/t/op9pro-repository-of-msm-unbrick-tools-tmo-eu-glo-in.4272549/
 

tom78610

Member
Nov 25, 2022
21
6
PARIS
I had this bug in my 7TP5G. I did a factory reset and it fixed it. It was not happening every time I started my phone but maybe 1/6 times. I couldn't get it back on with airplane mode or even reboot. It would just come back on whenever it felt like it. And never shut off again, until I reboot and got unlucky. I still don't know what it was from.


You can go back to OOS11 with LE2125 MSM tool if you want: https://forum.xda-developers.com/t/op9pro-repository-of-msm-unbrick-tools-tmo-eu-glo-in.4272549/
Thx,
Hi, I come to bring some experiments that I made.

From what I can understand, when going from L2127 to 2123/2125 we always encounter bugs with the sim card. I did factory reset, network parameter reset etc, Still the same problems,

Are there people for whom the L2127 works without problems after an EU/GLO conversion?
 

Appreciative

Senior Member
Mar 6, 2015
210
120
Thx,
Hi, I come to bring some experiments that I made.

From what I can understand, when going from L2127 to 2123/2125 we always encounter bugs with the sim card. I did factory reset, network parameter reset etc, Still the same problems,

Are there people for whom the L2127 works without problems after an EU/GLO conversion?
Yes, many of us are just fine. I have no problems using le2127 as Eu conversion. I flashed the modem back in because I'm staying on Android 11. If you go up to 13, I read it's not necessary to flash it back in anymore.

The only weird issue that comes to mind was forced Volte on. If I turn volte off, I get Edge network only in most areas. Very few spots will connect to LTE/5G. If I turn it on, I'm fine everywhere. I don't recall the forced Volte on my 7TP5G but all is well here for me.

I'm using Tmo sim and phone is unlocked but it worked fine when locked also. I'm not sure if your issue is maybe the sim itself or something with a13/oos13, I haven't gone to 13 to verify specific problems there
 

tom78610

Member
Nov 25, 2022
21
6
PARIS
Hello, I have just made some checks, and observations.

After each shift, I did a master reset of the phone wipe and data cache, the total to be simple. I have always gone through OTA updates since oxygen update. until 11.2.10.10.

Subsequently once on A12, I used the APK oxygen which offers you to do a local update I went up to C63 or 67 it seems to me.

Then I downloaded the EU F16 firmware and for the moment it seems to work at 99%

The only problem I encounter is when I restart the phone if the card is recognized as missing...

I can change the amount of RAM I want to allocate for the system without a hack.

My phone went from L2127 to L2123.

And I remember that I did wipe data cache factory resets at each update.
 

Attachments

  • Screenshot_2022-12-07-07-35-00-65_fc704e6b13c4fb26bf5e411f75da84f2.jpg
    Screenshot_2022-12-07-07-35-00-65_fc704e6b13c4fb26bf5e411f75da84f2.jpg
    236.6 KB · Views: 13
  • Screenshot_2022-12-07-07-38-12-85_9492aa3750dca76abb7c25b39a5f1e8e.jpg
    Screenshot_2022-12-07-07-38-12-85_9492aa3750dca76abb7c25b39a5f1e8e.jpg
    121.3 KB · Views: 13
  • Screenshot_2022-12-07-07-35-04-94_fc704e6b13c4fb26bf5e411f75da84f2.jpg
    Screenshot_2022-12-07-07-35-04-94_fc704e6b13c4fb26bf5e411f75da84f2.jpg
    93.6 KB · Views: 13

Appreciative

Senior Member
Mar 6, 2015
210
120
Hello, I have just made some checks, and observations.

After each shift, I did a master reset of the phone wipe and data cache, the total to be simple. I have always gone through OTA updates since oxygen update. until 11.2.10.10.

Subsequently once on A12, I used the APK oxygen which offers you to do a local update I went up to C63 or 67 it seems to me.

Then I downloaded the EU F16 firmware and for the moment it seems to work at 99%

The only problem I encounter is when I restart the phone if the card is recognized as missing...

I can change the amount of RAM I want to allocate for the system without a hack.

My phone went from L2127 to L2123.

And I remember that I did wipe data cache factory resets at each update.
Every time I've done a full cache wipe on my 7tp (I do from recovery) my sim is unrecognized for a short time. My wifi doesn't connect right away either. I leave it for a few mins and it will be detected, connect and be fine thereafter. I'm not sure if that's normal but now I'm wondering if maybe it is. (I figured it was too busy rebuilding app cache to do anything else useful but I dunno. That device had many apps installed)

Are you losing your sim recognizability after every reboot or only after reboots when you have cleared cache or reset device? When that happens, does wifi work right away or do they both have issues?
 

tom78610

Member
Nov 25, 2022
21
6
PARIS
Every time I've done a full cache wipe on my 7tp (I do from recovery) my sim is unrecognized for a short time. My wifi doesn't connect right away either. I leave it for a few mins and it will be detected, connect and be fine thereafter. I'm not sure if that's normal but now I'm wondering if maybe it is. (I figured it was too busy rebuilding app cache to do anything else useful but I dunno. That device had many apps installed)

Are you losing your sim recognizability after every reboot or only after reboots when you have cleared cache or reset device? When that happens, does wifi work right away or do they both have issues?
I lose detection of my sim card after each restart. The wifi connects very quickly.

I leave my phone on for 24 hours I'm waiting for tomorrow evening to restart the phone

I'll be back to report
 

tom78610

Member
Nov 25, 2022
21
6
PARIS
I come back to give news on some point that I had mentioned above.

Now I don't have any problem.

Everything works as it should.

When I restart or turn off the phone, my sim card is detected and recognized without any problems.

Connecting to the network after restarting takes about 1min. Everything is ok for me.

A big thank you to everyone.

And I insist, when you do the TMo to EU conversion after each installation, do a clear cache wipe data and file .
 
Mar 14, 2018
9
1
I come back to give news on some point that I had mentioned above.

Now I don't have any problem.

Everything works as it should.

When I restart or turn off the phone, my sim card is detected and recognized without any problems.

Connecting to the network after restarting takes about 1min. Everything is ok for me.

A big thank you to everyone.

And I insist, when you do the TMo to EU conversion after each installation, do a clear cache wipe data and file .
Dual sim bug still exist or not ?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    I don't understand anything anymore, View attachment 5773769
    I do. Try again and uncheck sha256 check and check use lite firehose and do your research instead of trying to have everything handed to you. If you did a search on your own, you would have found this tool on your own.
    2
    I come back to give news on some point that I had mentioned above.

    Now I don't have any problem.

    Everything works as it should.

    When I restart or turn off the phone, my sim card is detected and recognized without any problems.

    Connecting to the network after restarting takes about 1min. Everything is ok for me.

    A big thank you to everyone.

    And I insist, when you do the TMo to EU conversion after each installation, do a clear cache wipe data and file .
    1
    Hello community, I really need your help, I searched for hours but couldn't really find an answer and a simple tutorial. To explain to me step by step

    I have just acquired an OP 9Pro LE2127, it is in TMobile version 11.2.3.3 LE5ACB

    I want to flash it completely to see the phone put in EU or GLOBAL version.

    Is someone available to help me.
    The phone is unlocked from the T-MOBILE application.

    Thank you very much for your help.
    1
    Thank you, for this precious help, I see, but from what I see, I will always have to do some manipulation after making an update?
    Maybe, maybe not. Only one way to find out! I find staying with original stock firmware is less hassle or better yet, hassle free! Just a thought!