I need help with my Lenovo Tab 4 10 (TB-X304L)

Search This thread

Shutupboomer

Member
Oct 18, 2021
12
0
I have a Lenovo TB-X304L and I installed a custom ROM on it a few months ago. Everything was working perfectly except for some bugs and some specific apps crashing. So I thought of flashing the stock firmware to go back to the original ROM. I didn't take a backup when I installed the ROM. I used Lenovo's "Rescue and Smart assistant' to download and flash the right firmware for my tablet. I was able to flash it successfully and all but when I tried to boot it up. It was just stuck on the Lenovo screen for a minute or two and then turned off. I tried turning it on several times but every time it would turn off after staying on the 'Lenovo screen' for a minute or two. I even tried booting into the (stock) recovery and factory resetting it and also formatting the cache partition but nothing worked. I also noticed that the device's bootloader is locked and the TWRP recovery got removed. Now even if I want to flash a custom rom, I can't because to do so I need to turn on USB debugging and turn on OEM-unlock but I can't boot into the OS. I tried flashing in 2 times now but its always stuck on the boot screen. Please help me if there is anything I can do with this.

Thank you.

Device: Lenovo Tab 4 10 (TB-X304L)
 

Top Liked Posts