I screwed up, need help with HiSuite Proxy and Recovery mode

Search This thread

Rincewind

Member
May 10, 2005
9
0
Berlin
www.adlerpc.de
Hi,

I have a P40 and was running Google apps for a long time. Then I installed the latest EMUI update and a couple of days later the google apps stopped working and complained about the missing Play Protect. Im not sure if that is happening to everyone and somehow the google hack it not working anymore in general.

The I did a successful downgrade with HiSuite Proxy using the roms from firmfinder.ml to 10.1.0.132 and could re-apply the google hack. But after some days the google apps complained again and also my contacts wouldnt sync. I had installed an OTA update, so I had to do the downgrade again.

But this time instead of the "ANA-N29" files, I added "ELS-N29" files by accident. The installation went thru, but after that the phone was stuck in a boot loop. At that time I didnt know that I took the wrong files to update. I think I selected the correct "OS Type" for roll-back, but cant be sure. I still have the systemupdate logs, if these are helpful. I also have screens from the veneer info before the phone got bricked.

Then I setup everything to do a recovery with HiSuite and again tried to install the wrong files again. The installation went thru and didnt fix the boot-loop (of course). I realised my mistake and did the same with the correct files, but now the process in HiSuite is failing before the last step. The phone shows shortly this "Updating 5%" message, but the prompt from HiSuite Proxy "Are you sure? You can brick your phone" doesnt show up and it goes right to "Installation failed" on phone and HiSuite.

As the last step I tried different files and options in Proxy, but the installation always fails before the last steps of the recovery.

Any idea what else I could check? The recovery process was completing at least one time, but not anymore, why is that? Could a OTA update from USB-Stick work? And what version/files should I select for recovery? Can it be any version, or should I prefer the version that was installed before I started the first downgrade, which bricked the phone?

From what I read it could be a corrupted partition, any way to fix these separately?

Thanks for any help!
 

ivica122

Senior Member
Dec 17, 2012
257
96
9180.38km from Tokio
Hi, just follow this video, you also have links there where to download needed files. The guy speaks english really funny :) but tutorial works for sure, give it a try.

 

ivica122

Senior Member
Dec 17, 2012
257
96
9180.38km from Tokio
Ah, sorry, i was in a hurry and didn't read everything you wrote, when i saw famous play protect message i simply linked the video that will solve that problem and a few more.