I sent my HD2 for repair, now got it back, but still have issues!

Search This thread

Esaj2

Senior Member
May 11, 2010
89
16
0
Tampere
Hi,


I recently sent my HD2 for repair, because it had heat issues and GPS couldn't get a lock. Now I've got my HD2 back, but when I try to use the GPS, it either doesn't find signal at all or when I use for example Google Maps or TomTom, it causes the phone to reboot. I've used the QuickGPS software to get a faster lock, but this doesn't resolve the issue.

Also the heat issues still exist. Whenever I wan't to watch videos etc., the device heats up a lot and causes the phone to reboot. The bottom of the device gets always very hot.

The service center did change the touch screen, chassis and installed "HotFix-update", but these didn't solve anything. Does this mean, that the service center changed wrong parts? What actually can cause heat and GPS freezing/rebooting issues?


I'm now using stock WinMo 6.5 and the ROM version is WWE 3.14 and the radio version is 2.15.50.14.
 

johnerz

Senior Member
Jan 28, 2010
960
159
0
Chippenham
Watching video or any activity that constantly uses the screen also uses a lot of battery power and it will get very warm/hot.

Have you tried any other software to test gps usage?

Do you have ALL the settings for Google/gps/locations and maps set up in the correct manner?

Do you have a case or any other protection on the phone - if so remove it

If your ambient temps are high this just compounds any issues with heat
 

Esaj2

Senior Member
May 11, 2010
89
16
0
Tampere
Watching video or any activity that constantly uses the screen also uses a lot of battery power and it will get very warm/hot.

Have you tried any other software to test gps usage?

Do you have ALL the settings for Google/gps/locations and maps set up in the correct manner?

Do you have a case or any other protection on the phone - if so remove it

If your ambient temps are high this just compounds any issues with heat

I was able to get the GPS working fine. However it doesn't work in Android. If I turn on the GPS and the GPS starts looking signal and when it founds it, it causes instant freeze. This is a real mystery to me. What can cause this issue? WinMo 6.5 with WWE 3.14 and 2.15.50.14, GPS works great, but when I switched to nand Android RAFDROID 4.0.2, the GPS doesn't work anymore. Or it does work, it does look for the signal and everything, but when it founds it, it causes instant freeze. Screen stays on, nothing happens.

I should point out, that I was having this same exact problem, prior the repair. And some time ago, I was still able to get the GPS working in various versions of nand Android. But now, whatever Android build I use, I have the same issue. Something in Android is messing the GPS module.

The heat is not that bad of a problem in Android, so I can live with that. I'm not using any bumpers or any other protection.
 

SMS92

Senior Member
Apr 4, 2008
311
23
0
Send it back for replacement. Yeah the phones become warmer under certain conditions but I use mine to watch hour long XviDs one after the other in the sun and I have no such issues. It takes constant downloading of data with GPS locked and loads of apps open for mine to warm up! Sounds like you need a mainboard replacement to be honest, surprised they didn't switch the boards the first time and test .

I've never had mine reboot or go crazy on me due to heat, at worse the battery temp check kicked in in WM while charging to switch off charge (flashing orange led) with my cheap Chinese battery

Sent from my Nexus One
 
Last edited:

dbekris

Member
Jan 13, 2011
41
2
0
Athens
I have heard that the high temperature causes by 3g... If you use 3g data, try to disable it and then try gps and movies again.
The conclusion, btw, is to sent the phone back for repair or replacement.
 

ThomasHd2

New member
Feb 25, 2010
3
0
0
Same here my brother's hd2 working perfectly fine but mine every time temperature exceeds 33 celcius gps cause phone reboot and if i manage to turn gps on can't find fix