I used a magisk module that modified some DRM and now NOTHING fixes it

Search This thread

jld2k6

Member
Jan 21, 2011
32
6
The module that did this was "liboemcrypto disabler" and was advertised as allowing DRM content to be viewed in full HD despite my bootloader being unlocked. It immediately put me in a boot loop after installing. I removed the magisk module from recovery but I was stuck in a boot loopstill and ended up having to wipe. I've done a full wipe, I've fully erased and decrypted the phone with ALL IN ONE tool and then installed a new stock ROM via fastboot. I then used TWRP to wipe EVERYTHING and then used ALL IN ONE TOOL to erase the phone and then used MSM tools to reflash a stock ROM and start from scratch while also choosing to wipe all data in the process. Netflix not working has persisted through all of this, it seems this module has touched a drm file that is normally out of reach in the wiping process / it's not replaced when doing a clean install. Another odd thing is that throughout this whole process, Nova Launcher stayed installed throughout all of the wipes. Any time I try to open Netflix it either says I need to update and clicking okay brings me to the play store where it tells me Netflix is not compatible on my device. Sometimes I get other error messages but it's always the same, Netflix doesn't work. The odd thing is I got it working on Pie in the process of unlocking my tmobile bootloader with the Android 10 DP3 so I could root it. Netflix actually worked for a second while I was on Pie, up until I updated to Android 10. This leads me to believe that the drm Android 10 is using is different from Pie and upgrading put me back to relying on the ruined drm file. I've even tried installing and uninstalling the magisk module that screwed all of this up hoping it would replace the original drm file but I've had no luck. This is such an odd problem. I had no clue any magisk module had the power to give your phone problems that literally can't be fixed through full wipes and reinstalls. I've tried removing netflix from ADB and reinstalling the apk manually but there's still no luck. The other streaming services that normally rely on this DRM are fine. If anyone has the slightest idea of what to do here I'd love to hear it! Are all drm files the same for everyone? If I were to aquire the drm file that was replaced while installing this thing could that possibly fix it? The file that is modified is under /vendor/lib/ and is named "liboemcrypto.so"
 
Last edited:
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone