Search This thread

TheDoctor549

New member
Jan 20, 2022
2
1
Hey, everyone. This is my first time on this site. I don't have a lot of experience with android as I am more of an iphone guy. I'm the manager of a small doctor's office here in south Texas and, until recently, we've been using the PAX A920 to take payments on. Doc said he didn't want the devices anymore and that I could have them to play around with. I'd like to completely wipe the devices and install just a straight android OS on it. But I have tried literally everything I can think of. I'll list a few things about the device, everything I have tried, and a few pictures below. Any help would be greatly appreciated.

Device specs and things I've tried:
  1. When I plug the device into my computer (OS X Monterey) and open the Android File Transfer tool, I can see a little bit of stuff that is on the device, and a notification pops up on the PAX that says "USB debugging connected. Touch to disable USB debugging"
  2. I can drag and drop APK's to the device but none will successfully installDeveloper Options cannot be accessed. When I try to tap the build number, a message displays at the bottom of the screen that says "You are not debugging and have no access to developer mode !" In exactly that format. I've also tried to enable developer mode with ADB using "adb shell settings put global development_settings_enabled 1" but that didn't work either.
  3. When I turn off the device and power it back on, while holding the power button and volume up button, it displays the PAX boot logo but it says "Firmware Developer Mode" underneath it. It does nothing else from that point. I tried letting it sit for like 6 hours and nothing ever happened.
  4. It appears that PAX devices use their own custom android based OS called Paydroid and I can't find anything about it after some pretty extensive google searches.
  5. The build number is PayDroid_5.1.1_Aquarius_V02.3.17_20181026
  6. The Kernel version is 3.10.49
  7. It's running on Lollipop
  8. Underneath processor, it says "Qualcomm Technologies, Inc MSM8909
  9. The device has it's own store called PAXStore but it's pretty useless
  10. You can't browse the internet on it
  11. There's a whole bunch of crazy looking applications loaded on the device but you can't access any of them.
  12. ADB recognizes the device but almost any command I use that targets the device literally does nothing. No success message when using "adb install" and no output with "adb shell getprop" or adb wm size". Zero. Zilch. Nada. The only one that actually gave me some form of output was the "adb pull /system/build.prop" and that one was "adb F 01-20 10:43:25 72984 1577471 file_sync_client.cpp:499] protocol fault: failed to read stat response: Undefined error: 0
    zsh: abort adb pull /system/build.prop"
  13. Fastboot does not recognize that there is a device connected even when I boot it up by holding down the power button and volume up.
  14. This is the WEIRD part. I made a new user on the device and when it switched to the new user, it popped up with the usb debugging notification AND "sdcard is mounted". But there's no sd card listed in the storage or in the files app. There's a slot in the battery bay for a micro sd card, but I haven't put one in and I verified that there isn't one in there. Makes me think that there might be some sort of storage drive physically installed somewhere on the motherboard.

I'm serious. ANY help would be greatly appreciated. This isn't even about why I was originally trying to do this. I've invested days into this and quite frankly just want to be able to say I've done it.
Screen Shot 2022-01-20 at 2.54.37 PM.png
IMG_5619.jpeg
IMG_5620.jpeg
IMG_5621.jpeg
IMG_5622.jpeg
IMG_5623.jpeg
IMG_5624.jpeg
IMG_5625.jpeg
IMG_5626.jpeg
IMG_5627.jpeg
IMG_5628.jpeg
IMG_5629.jpeg
IMG_5630.jpeg
 
Last edited by a moderator:

professorbruno

New member
Jul 8, 2022
1
0
hello, i have several tools for dobby a910 and a930, except for a920 would you like to work together to achieve it?
você pode ajudar com duas maquinas? a910 e a930 queria usar elas com o whatsapp, imprimindo fixa de caixa, ganhei elas do meu antigo patrão! e queria usar de algum modo! mas nao acho o paydroid e nada sobre, parece segredo da maçonaria kkkk sou professor de robotica manjo um pouco de programação mas essa rom que vem nesses dispositivos são fechdas

Mod translation via GT: can you help with two machines? a910 and a930 I wanted to use them with whatsapp, printing fixed cash, I got them from my old boss! and wanted to use it somehow! but I don't find paydroid and nothing about it, it seems a secret of Freemasonry lol I'm a robotics teacher I know a little bit of programming but this rom that comes in these devices are closed
 
Last edited by a moderator:

dper

New member
Aug 16, 2022
2
0
You can use a sequence of commands to get some fastboot output:

Bash:
adb reboot bootloader

The device will restart. then...

Bash:
fastboot devices

You will see the device listed. Then you can use the fastboot commands
 

Top Liked Posts