How To Guide Install Google Mobile Services (GMS) on EMUI 11 or Harmony OS 2.0 W/O rolling back to EMUI (Test Feb 2023)

Search This thread


New member
May 21, 2023
i have Nova 9 (NAM-LX9) running harmony OS 2.0
i have a problem when i try instal Purple G application it's not working (not compatible)

can you give me the solution ?


New member
Jul 27, 2020
I did this and then this. Everything works fine. I have latest Google-Play-Services and Google-Play-Store and notifications.
But how can i get the same now in PrivateSpace?


Senior Member
Sep 4, 2017
are you asking if your stock firmware is Harmony OS3? If you are getting the error of Play Protect, follow the following video to fix it.


Chrome sign-in
fixed after i gave Chrome permissions manually
Last edited:


New member
Aug 23, 2023
Hi, I have a mate 40 pro and tried to the provess several times, I always get stuck at the backup.
I am able to install the older backup version. Then I do see nov 11 2019 backup.
When I check inside the backup there is 1 app with the size of 0B.
When I press restore it always fails to restore that app.
What I tried to do to fix this:
I downloaded the required files from 2 locations. Because maybe something was corrupted.
I installed an older version (oct 2022) of hisuit.

What am I doing wrong?

I fixed the problem by using another laptop to download, unpack and copy the files to phone and USB-stick. Something (anti-virus?) on the first laptop corrupted the backup file.
Last edited by a moderator:

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    You can find the video instructions in the following:

    Video of successfully installed Google apps:

    *** IMPORTANT NOTE ***
    Do NOT give up if your first attempt fails. Factory reset is recommended if failure happens, try again and I am sure you can get it done by following this guide, however you will need to make sure you follow all the steps one by one, and do NOT try jumping. Even the button of "OK" , "Open", "Done" or selecting app from Muti Task Manager instead of re-enter apps from the Home screen at different timing or sequence may impact the result.

    This method has been tested on the following devices (model# ending with ANxxx or ALxxx after "-") running on Harmony OS 2.0:

    Mate X Series: X2
    Mate 40 Series: 40 / 40 Pro / 40 Pro+
    Mate 30 Series: 30 4G / 30 5G / 30 Pro 4G / 30 Pro 5G,
    P40 Series: P40 / 4G / Pro / Pro+
    Mate Pad Series:Pro WIFI / Pro 5G

    Note: international versions may not compatible

    In this video, I am showing you how to Install Google Mobile Services (GMS) directly on Huawei Harmony OS 2.0 without rolling back your devices to EMUI 11 / 10 or even earlier. (this video is using Mate X2 as an example).

    1. Download the ZIP file (if the links are no longer working, please kindly leave comments and let me know)



    2. Extract “”
    3. Copy foler "111" onto your computer C drive root directory
    4. Copy "huawei" folder onto your mobile/tablet device root directory
    5. Copy the balance files to somewhere in your mobile/tablet device (wherever you like)

    Step by Step instructions:

    1. Backup your data then Factory Reset your device (phone/tablet), ensuring it is in a clean condition

    2. Go to Settings---About Phone----“Quickly click the Build number at least 7 times (this guide here is using (C00E230R9P3patch03) to activate the “Developer options”

    3. Go to “System & updates”, and turn off the ”App Guard” (skip this if using EMUI 11)

    4. Return to Settings, at the top search section, enter keyword “HDB”, select and turn on “Allow connection via HDB”

    5. Go to “Settings & updates” --- “Developer options”, turn on “USB debugging”

    6. Use your cable to connect your device with computer

    7. Swipe down from the top of your screen and change the connection from “Charing via USB” to “Transfer files” mode. Enter the “Connection verification code” that is showing up on Hisuite screen from your phone onto the Hisuite on your computer

    8. Copy the GMS files onto your device

    9. In your computer, click ”WIN” key,then enter “cmd” to enter “Command Prompt” (skip this if using EMUI 11)

    10. Enter below commands one by one (make sure you see the message “success” before entering the next command. (skip this if using EMUI 11)

    1) Cd\111

    2) adb devices

    3) adb uninstall com.huawei.localBackup

    4) adb install Legacy.apk

    11. after finish entering the commands from your computer end, return to your device. Install “Backup & restore” following the instruction from the phone. (skip this if using EMUI 11)

    12. Disconnect your cable

    13. Go to “Settings & updates” --- “Date & time”. Turn off “Set automatically” and change the date to July 10, 2020

    14. Connect your USB-C storage device, wait for 30 seconds then go to “System & updates” ---“Backup & restore”, continue selecting “ALLOW”,then select “External storage”--- “USB storage”,select and restore “the 5:21am, Nov 11, 2019” backup; enter password: “a12345678”

    16. Go to HOME screen, you will see and new app called “谷歌服务助手”, open it. Select “ALLOW” (you will delete this app after you have no issues running Google Suites), then “ACTIVATE”; You will see lots “!”, ignore that and click “开始下载”(start download),it will fail to download anything, ignore it as well. As soon as you see the loading spin, go back to HOME screen (do NOT close the app, just return to main screen)

    17. Goto “Files”,Install “01_MicroG.apk”

    18. Go to “Settings & updates” --- “Date & time”. Turn on “Set automatically”

    19. The first time you click “SIGN IN“” will fail to open and flash exit, it is normal, click “SIGN IN” once again to login to your Google account. Once success, click “ I agree” and “CANCEL” (if you received error message “Sorry… You don’t have a network connection…” then restart your device and try again starting from “谷歌服务助手”,)

    20. If you have multiple google account, repeat previous step
    21. Go back to “Files”,Install “02_Google Account Manager” until “07_Google Services Framework.apk”

    22. Go to “Settings”---“ Users & accounts”, click “Google”, and then click “your account”, then click “Sync contacts”, then “sync now”

    23. Return to home screen, click “Play Store” (WARNING: DON’T get too exciting and do NOT stop here. This is NOT done yet, otherwise I am sure you will see lots of errors while using the device. Do NOT even try to do anything until you finish this guide). You will find an error message “Authentication is required…”, this is normal. Ignore it.

    24. return to home screen and uninstall MicroG

    25. Go back to “Files”,Install “08_Google Play Services v19.2.75”

    26. return to home screen and click “Pla yStore” (you may receive DF-DFERH-01 error, just click retry). You will hear lots of error notifications, ignore it.

    Search and install “device id” which is the one from VtechSevi but not other developers,open “device id” once done,check if you can obtain the Google Service Framework (GSF) number

    27. Go to “Settings”---“Apps and services”---“Apps”---search “Google Play services” ,click “FORCE STOP” until it is grey out, then “UNINSTALL”

    28. Go to “files” and install“09_Google Play Services v19.4.20.apk”

    29. Go to “Settings”---“Apps & services”---“Apps”---search keyword “Goo”, click the “4 docks” located at the right top corner”, select “Show system processes”, select “Google Service Framework”

    (time sensitive here!!! needs to be quick and do not operate your device rather than following all the steps) click “FORCE STOP” (if it goes blue again, keep forcing it stop until it is grey), then click “Storage”---" CLEAR CACHE” and then “CLEAR DATA”, and then Press the power button---Restart your device right away

    30. goto “Play Store”, you may receive DF-DFERH-01 error, this is normal and this is only time message, would not impact future operates

    31. goto “DeviceID” check if the GSF number has become Unknown, if so, return to “Playstore” try click retry. If this error repeats, restart your device and wait for at least 2 mins before opening PlayStore again. If the error still shows up, unfortunately you will need to restart this guide again)

    32. return to home screen, clear all the running tasks, then goto “DeviceID” and check if you can still have the GSF#

    33. Go to“Settings”---“Apps & services”---“Apps”---search “Google Play services”, click “UNINSTALL”, you will be in “device administrator, then click “DEACTIVIATE AND UNINSTALL”

    34. Go to “Files” and install “10_Google Play Services v20.12.14”

    35. Return to main screen, restart your device and wait for at least 2 mins until the startup is done. If you hear tons of error notifications, then unfortunately you will need to restart this guide again

    36. Open “Play Store”, check if it is working fine. If so, congrats but not done yet we need to move onto the final steps to ensure your device can pass the Google certify checks in the near future, so then you can feel free to update Google Play or other google related apps

    37. install Chrome

    38. goto “DeviceID”, click on the “Copy“ icon and copy your GSF#

    38. goto “Files” and open the link in chrome, scroll to the bottom, paste the GSF# in the text box and check mark the robot test, then click “register”, then you will see a bunch of number at the bottom, which it means your device has been registered successfully.

    37. goto “Play store”, search “Google Play service” and install “Play Services Info“, then open it and click “PlayStore” and open by “Google Playstore”, update the Google Play Service

    38. return to home screen and restart your device

    39. open “Playstore” and check if everything works fine

    40. GMS installation is done : )
    This is a very nice article, congratulations !
    However, I would need an extra help, I am blocked at step 10, indeed, when I am typing Cd\111 and then click on "enter" computer says that "Le chemin d'accès spécifié est introuvable" (the specified path way was not found), any suggestion ?
    The easiest way is to go to the destinated folder (111) and hold shift and right click. Then click on "open PowerShell/CMD here"

    If it opens PowerShell, simply type "CMD" and hit enter and you're in CMD
    Then you can proceed with uninstalling the backup app
    I was Instaling this on a HarmonyOS 2 Matepad 11 and when I try to do the step 20 the google accunt n the settings app deletes itself with the uninstalled applicaton so I cannot continue. I am basically stuck here please help.
    Ps. When I add the google account there is no "CANCEL" button coming up on the screen returns directly to the googlefier app and the 1st option disappears.
    Hey XDA,

    Anyone else just suddenly getting: this device isn't play protect certified

    I can't get rid of it, tried reinstalling google Play services etc.
    Yes, this happened earlier this week.

    Here is the solution
    The easiest way is to go to the destinated folder (111) and hold shift and right click. Then click on "open PowerShell/CMD here"

    If it opens PowerShell, simply type "CMD" and hit enter and you're in CMD
    Then you can proceed with uninstalling the backup app
    Thank you, it works :)