How To Guide Install GSI ROM - Xiaoxin Pad Pro 2021 [TB-J716F]

Search This thread


Senior Member
Jan 4, 2021
I'm currently on zui 14.
I tried to install pixel experience gsi but getting error.

I'm using this post method to installed it as well as using the vbmeta.img that this post provided.

can someone guide me to install the gsi on zui 14?
When you updated to ZUI14, vbmeta probably changed, so you have to get it on your own, but I'm not sure.

It would be interesting if something changed in ZUI14 with the vendor files.
Maybe it's possible to make GSI ROM run better now.
  • Like
Reactions: Drethis


New member
Dec 29, 2022
Help-me, please!

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    How to install GSI ROM - Xiaoxin Pad Pro 2021 [TB-J716F]

    I tried to install a GSI ROM on this tablet, because there is only a chinese version available.
    The tablet supports treble and I managed to get different GSI ROMs booting on it, but with a few annoying bugs I couldn't solve.
    I thought I will share my experience here and maybe someone with more expierence can help to solve these problems.
    Your data will be deleted, try at your own risk.

    Treble Device Information (Treble Info):
    Required Image: system-arm64-ab.img.xz
    Supports modern version of treble and uses VNDK30.0
    Supports System-as-Root, uses A/B operating system
    Supports seamless upgrades and uses dynamic partitions (super partition)
    1. Go to "Settings" ->"System" -> "About Phone", tab on it until developer settings are enabled.
    2. Go to "Developer Settings" and enable "USB Debugging", allow USB-Debugging if tablets asks.
    3. Reboot to bootloader: "adb reboot bootloader"
    4. Flash vbmeta.img: "fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img", you only need to flash it once
    5. Reboot to fastbootd: "fastboot reboot fastboot"
    6. Flash GSI-ROM: "fastboot flash system lir-v313+211012-arm64-bgZ-lite.img" and wait
    7. Using volume keys on tablet select "Enter recovery" and then select "Wipe data/factory reset", reboot device.
    8. Now it tries booting the ROM, after the "bootloader unlocked" warning, the lenovo logo should show up. Here I often had the problem that it didn't boot at first try. If, after waiting for 20-30s the ROM doesn't boot, press the power button to reboot tablet. After trying it a few times it always worked. This problem only occurs at first boot up, after setting the ROM up, it boots normally.
    9. Now after booting, when using the LiR-ROM, you have to set up the tablet. In the fourth setup window, the ROM is asking for a SIM-Card even though the tablet doesn't support GSM. You can skip this by entering to adb commands "adb shell settings put secure user_setup_complete 1" and "adb shell settings put global device_provisioned 1". After sending these two commands, then pressing return in the setup, it should complete.
    10. After successfully booting, the "Home" and "Tasks" button is missing. After a reboot they should appear and work normally but I recommend to set a lock pin first.
    Known Bugs/Problems:
    When activating autorotate, the display is always orientated in the wrong direction by 270°.​
    I tried to solve it with two different commands added to build.prop:​
    1. "ro.sf.hwrotation=270" -> didn't do anything​
    2. "ro.surface_flinger.primary_display_orientation=ORIENTATION_270" -> the screen rotated in right direction, but the touchpanel did not.​
    Workaround: using an rotation controll app, but I'm not a fan of it.​

    Overlay - AutoBrighness, Magnetic Screen Lock, Battery Save Mode
    I tried creating an overlay according to the instructions but sadly the "FrameworksResTarget.apk" from the vendor folder doesn't provide much configuration information including for the above mentioned issues. I tested values from similiar devices but didn't have any success. If someone is interested to try, here are the files I extracted from the tablet and the current overlay I created.​

    Hopefully, someone here knows how to solve these problems.
    We should spam this forum thread, maybe then they will eventually react :D
    After a lot of jumping through hoops, I was able to get custom ROMs running on the tablet. Though I do want to share my experience with it.

    I chose to run BlissOS 15.3 on it the first time, and it worked quite well, despite the known bugs such as the rotation, adaptive brightness not working, and the phhTreble settings not working either. (Not sure if it is specific to the ROM but there's that.)

    A few things I noticed, TWRP would encrypt the partitions if you enabled a password on the system, and the decryption password is not the same as the one you set as the system password.

    Another thing is setting the screen cutout to anything else other than the default, to which it will cause the whole screen to turn to black, rendering it useless unless you wipe the data in recovery mode.

    I also found out that by changing the boot animation, it doesn't actually write on it, turning the file to 0 bytes when moved, a.k.a. it becomes non-existent, and thus when rebooting the tablet, it will drastically slow your device down. Sometimes it even heats up the device, I can even feel it through the casing.

    I also tried other Android 12 GSIs, including Android 12L ones, but it had a few more issues, especially the navigation bar on Android 12L.

    So for me, BlissOS works fine the best for me.

    If anyone can find out how to fix these kinds of issues, let us know.

    Thanks to @Tropaion for the instruction guide!
    @gunalarix8 Sadly not possible because there is no kernel source.
    @TheNiceGuy11999 I created a GitHub issue before.
    I you read through the first thread page you can finde everything you wanted.
    Lenovo uploaded the open source file for global variants. I could not find the chinese variants. 🤣 It was uploaded very recently. 😁