How To Guide Install GSIs on Samsung Galaxy A32 4G (Experimental)

Search This thread


May 11, 2023
yep. my a32 is running project elixir 3.6 gsi with magisk v25.2 so it works amazingly. i made overlays for gsi's which will be included in new gsi's from now on. project elixir 3.6 includes them. so it will enable auto brightness and stuff
Hi, how did you set up the elixir project? And is it possible to install it with Oneui 5.1, I just really don't want to use Oneui
I also noticed that the vendor.img file disappeared in the subject, where can I get it or can I flash it without it?
After flash magisk 25, im stuck at lockscreen
if you used flashing via recovery then yes that was expected. now try flashing orignal boot
img from stock firmware. you can download it. its inside the ap file. you'll also have to decompress it from.lz4 once extracted from ap file. flash in twrp it shld be back. rather patch the whole ap file with magisk. then flash it along with all other files (put HOME_CSC instead of CSC in csc slot if you dont want data loss. However if you use gsi. immediately reboot back into recovery so one ui doesnt encrypt. otherwise your gonna have to wipe.
Bluetooth is not working, can you share me your vendor img?
there is no vendor.img.

to fix bluetooth. Now gsis have been updated. just turn on whatever one of these options you see.

Settings> phh settings> misc > enable system wide bt hal

or if you cant find systemwide bt hal

Settings. phh settings > misc > Force disable ad2p offload.

reboot and see if it works now
Every time when I try to set it up, the whole system ui crashes.
currently there is not much hope for fingerprint. you can try using the kernelsu kernel which is permissive. u can find it here on a32 threads. then try giving it another go. currently a user is helping devs debug problems with our fingeprint and hopefully it can be fixed in future builds. For Aod you can flash the magisk module i attached it contains updated overlays for a32. i have already opened a pr so they merge it but they havent yet. so for now you can use this module. it will make sure aod doesnt get stuck. Although if ur on elixir and aod is not working there is not much hope. u can switch to another rom. works fine on most roms i tested. but elixir had issues for some reason.


    32.6 KB · Views: 10

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    I have tested 2 GSI's so far, phh's AOSP and AndyYan's LineageOS 19.1.

    Everything works so far except:
    • MTP file transfer
    • Fingerprint reader
    • File encryption (GSIs don't boot if you dont disable encryption)
    So, if you wanna install one, here's what I did:

    Install Prove N's Unofficial TWRP and follow his guide. DONT INSTALL MAGISK, IT HAS THE IMEI PROBLEM AND ITS NOT TESTED WITH GSIs

    Download your preferred GSI, I recommend lineage-19.1-20220320-UNOFFICIAL-arm64_bvS.img.xz, comes without GAPPS (Use bgS if you want em).
    Extract it and rename the .img file to system.img

    (Optional) Download this vendor.img, I made a treble overlay and added it to the image. The rom should be more stable and power management should be fixed with that. I still have to push the changes to github.

    Download, it's a tool to flash dynamic partitions. It checks your storage for system.img and vendor.img.

    Get a microSD card, and copy to the root of it the, system.img and vendor.img.

    Boot to TWRP, and install the ChonDoe zip, wait till it finishes flashing.

    Reboot to TWRP again, so it can mount the vendor partition again, go to the terminal and type multidisabler, so we remove encryption.

    Format data, internal storage and reboot, you should be ready to go.

    Settings in PHH Treble Settings
    • Go to Samsung features and check "Enable extended brightness range" and "Enable access to all cameras".
    • Go to Misc features and check "Use alternate way to detect headsets"
    • To get the display working at 90hzs go to "Force FPS" and check the option.
    • On camera check "Expose Aux cameras" and "Force Enable Camera2API HAL3" (In theory you should get better photos with that but I didn't go outside today lol)
    For the lack of MTP file transfer, I'm using ADB instead of MTP with this tool for uploading and getting files from internal storage: Python ADB File Explorer. Suprisingly it's faster than MTP for some reason...

    I know MTP can be fixed changing the kernel driver, I have compiled the kernel from @Prove N. , he had some USB fixes, but I don't know how to pack it for Samsung, It could be nice to have it for GSIs. If anyone wants to help me with these small issues it would be awesome.

    Report bugs, workarounds and fixes here in this thread, let's try to make this phone usable!
    Ok, I'll try not to mess it all up this time...

    Here is the link to download: {Mod edit: Link removed. is not accepted as file host on XDA}. That is super.img I've created using my script, it is packed into a tar archive and zipped to reduce the size for file sharing. It is specifically for SM-A325F, based on the NPB (Nepal/Butan) version of the firmware and contains LiR v3.16. After unzipping it is ready to be flashed using Odin into the AP slot over the stock NPB firmware. That means, you have to download and flash it first, then flash the super.img. After each flashing go straight into the Recovery mode and do factory reset, only then boot the system.

    But that's not all, additionally you have to extract and flash optics.img from your regional firmware. Here is how to do it. Changing optics.img to your regional one is not compulsory but with the Nepalese/Butanese one you'll only have a few major cellular providers working. You can do it at any time after flashing the system, it does not require factory reset.

    I have chosen the NPB stock firmware as the basis because after analyzing contents of other regional firmware I've found that it is probably the most non-bloated and privacy-respecting of all (the worst were Russian and European).
    all good please create one ui firmware
    Do you really need it? First, OneUI is not to be trusted as it's proprietary and not fully open-source, second, the only GSI version of it I can find (repacked by erfanoabdi) is very old (2019).
    Would love this tbh.
    gapps would be preferred
    I tried to download it, but it took 1 hour and chrome said "network error", so i only can get the lineage os gsi.
    Maybe it is because they have bad servers
    @Thau1811 and @craaziik I have translated your posts to English. Please use English on XDA, per Rule 4. Thank you.

    Everyone else: Regarding Telegram links and conversations, refer to the XDA Telegram Policy.

    Only ONE telegram link is allowed per thread, posted by the thread owner, on the condition that full support and updates are still provided on XDA. You may not use XDA to divert users to other platforms such as Telegram. Please continue to use threads such as this one for discussions and support.

    @Captain_cookie_200 We do NOT allow drop and run Telegram links or usernames.

    @90__AM Please check your PM inbox.