How To Guide Install GSIs on Samsung Galaxy A32 4G (Experimental)

Search This thread

Franzyy

Senior Member
Does A32 have a real dedicated fingerprint sensor? It seems to me it's just the same capacitive touchscreen used in a slightly unusual way. Therefore the OS must know this quirk, and it seems that LineageOS does to some degree, as it shows the green spot on the screen which I must touch for reading a fingerprint. Still, at least for me, the phh Treble's workaround does not help, and the screen backlight just does dark when I touch the spot (which is weird).
The same thing is happening to me too, it shows a green spot and when i press on the green spot, the screen gets darker.
 

bmDomianatezz

Member
Mar 10, 2021
34
3
UPDATE: lineage os 19.1 booted successfully. but its very laggy. probably a vendor issue. the vendor file supplied in the first message causes my device to hang at samsung logo. or maybe it takes longer to boot and i am impatient? Either way please check again because some parts of the ui are actually responsive and i wont have to reflash stock firmware due to this lag.

could you please confirm if the vendor still works?
Vendor file doesnt work for me

Did you just flash the zip?
Yep
 

Franzyy

Senior Member
nope. i dont know. did you try the crdroid build? does it work on that? because my sensor is physically broken i cant test it. Maybe you could also try enabling workaround for broken fingerprint in phh's aosp treble settings under the samsung section and after a reboot maybe it works. give it a shot and let me know on how it goes.
When i press on the fingerprint sensor, it goes back to the lock screen.
 
When i press on the fingerprint sensor, it goes back to the lock screen.
thats wierd. i don't know how to solve this tho since as i said my sensor does not work at all. i have to send it for repair. but i even forgot that this phone had a fingerprint sensor i am living happily without it since the face recognition is amazing.
 
Is there a working vendor image yet?
i dont think so. i tried installing one ui 3.1 then flashing the vendor image. it still didnt boot got stuck at samsung logo had to do a one ui 4.1 reflash. I quit GSI'S since there are no android 13 gsi's yet except google (half of the stuff doesnt work but demn it is so smooth. even better then samsung at some parts. Some features were also missing like google monet and the bluetooth refused to work which i use every day). i am using an older version of one ui 4.1 that doesnt have the mobile data bug and works fine.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    I have tested 2 GSI's so far, phh's AOSP and AndyYan's LineageOS 19.1.

    Everything works so far except:
    • MTP file transfer
    • Fingerprint reader
    • File encryption (GSIs don't boot if you dont disable encryption)
    So, if you wanna install one, here's what I did:

    Install Prove N's Unofficial TWRP and follow his guide. DONT INSTALL MAGISK, IT HAS THE IMEI PROBLEM AND ITS NOT TESTED WITH GSIs

    Download your preferred GSI, I recommend lineage-19.1-20220320-UNOFFICIAL-arm64_bvS.img.xz, comes without GAPPS (Use bgS if you want em).
    Extract it and rename the .img file to system.img

    (Optional) Download this vendor.img, I made a treble overlay and added it to the image. The rom should be more stable and power management should be fixed with that. I still have to push the changes to github.

    Download ChonDoe_Flasher.zip, it's a tool to flash dynamic partitions. It checks your storage for system.img and vendor.img.

    Get a microSD card, and copy to the root of it the ChonDoe_Flasher.zip, system.img and vendor.img.

    Boot to TWRP, and install the ChonDoe zip, wait till it finishes flashing.

    Reboot to TWRP again, so it can mount the vendor partition again, go to the terminal and type multidisabler, so we remove encryption.

    Format data, internal storage and reboot, you should be ready to go.

    Settings in PHH Treble Settings
    • Go to Samsung features and check "Enable extended brightness range" and "Enable access to all cameras".
    • Go to Misc features and check "Use alternate way to detect headsets"
    • To get the display working at 90hzs go to "Force FPS" and check the option.
    • On camera check "Expose Aux cameras" and "Force Enable Camera2API HAL3" (In theory you should get better photos with that but I didn't go outside today lol)
    For the lack of MTP file transfer, I'm using ADB instead of MTP with this tool for uploading and getting files from internal storage: Python ADB File Explorer. Suprisingly it's faster than MTP for some reason...

    I know MTP can be fixed changing the kernel driver, I have compiled the kernel from @Prove N. , he had some USB fixes, but I don't know how to pack it for Samsung, It could be nice to have it for GSIs. If anyone wants to help me with these small issues it would be awesome.

    Report bugs, workarounds and fixes here in this thread, let's try to make this phone usable!
    2
    Ok, I'll try not to mess it all up this time...

    Here is the link to download: {Mod edit: Link removed. ufile.io is not accepted as file host on XDA}. That is super.img I've created using my script, it is packed into a tar archive and zipped to reduce the size for file sharing. It is specifically for SM-A325F, based on the NPB (Nepal/Butan) version of the firmware and contains LiR v3.16. After unzipping it is ready to be flashed using Odin into the AP slot over the stock NPB firmware. That means, you have to download and flash it first, then flash the super.img. After each flashing go straight into the Recovery mode and do factory reset, only then boot the system.

    But that's not all, additionally you have to extract and flash optics.img from your regional firmware. Here is how to do it. Changing optics.img to your regional one is not compulsory but with the Nepalese/Butanese one you'll only have a few major cellular providers working. You can do it at any time after flashing the system, it does not require factory reset.

    I have chosen the NPB stock firmware as the basis because after analyzing contents of other regional firmware I've found that it is probably the most non-bloated and privacy-respecting of all (the worst were Russian and European).
    2
    all good please create one ui firmware
    Do you really need it? First, OneUI is not to be trusted as it's proprietary and not fully open-source, second, the only GSI version of it I can find (repacked by erfanoabdi) is very old (2019).
    2
    Would love this tbh.
    gapps would be preferred
    I tried to download it, but it took 1 hour and chrome said "network error", so i only can get the lineage os gsi.
    Maybe it is because they have bad servers
    1
    ok, can i install a gsi which is for a/b slot (e.g Pixelexperience 12)
    yea it works. although install v414 v415 causes the device to immediately reboot on samsung logo.