How To Guide Install Stock ROM - Xiaoxin Pad Pro 2021 [TB-J716F]

Search This thread

Paulo Rios

New member
Oct 8, 2022
3
0
Por isso, gostaria de parabenizá-lo pelo tutorial. Meu tablet estava travado no fastboot, estava em loop.

" http://cdn.zui.lenovomm.com/developer/tabletboot/[seu número sn]/sn.img" - basta colocar o número de série na parte de trás do tablet no lugar [seu número sn] tira tudo ai do link acima e coloque o número de série no navegador e a imagem começará a baixar. Tive que baixar o programa anexo, lá colei a imagem dentro da pasta do programa, e executei o bootloader de desbloqueio que fica dentro da pasta do programa quando você extrai. E pronto o Bootloader desbloqueado então é só instalar a sala chinesa original da Qfil.
Fala Carlos tudo bem?
Rapaz eu tentei acessar esse link, mais da erro 404, estou desesperado, tem uma semana que estou travado na mesma tela que vc estava, se puder me ajudar. Agradeço
 

rollie006

New member
Oct 3, 2022
1
0
Anyone knows how to downgrade from zui 14 to zui 13?..i manually upgraded to zui 14 last week but it has a lot of bugs, pc mode was removed and i experienced boot loops when the battery is below 10%, also, it sometimes stutter especially when you have floating apps opened.. experience was very bad on zui 14 for now, it needs a lot of fixing
 

z4mora

Member
Oct 7, 2022
14
1
Google Pixel 6
Please help, my tablet was bootloop and i used QFIL, after finish donwload with QFIL, my tablet wont rotate now:(

Update:
I managed to get auto rotate back, just load stock persist.img using QFIL, now widevine and auto rotate back to normal
 
Last edited:

z4mora

Member
Oct 7, 2022
14
1
Google Pixel 6
You can restore your serial number and unlock your device. You probably erased your fpinfo partition. There are five essential partitions for our device( I learned this the hard way, by checking Erase All Before Download) - fpinfo, persist, uefivarstore, secdata and frp.
BACK THEM UP AT ALL COST, IF YOU WANT TO EXPERIMENT WITH YOUR DEVICE (like I said, I learned this the hard way) TWRP does not back them up unfortunately...

Your serial number lives in the fpinfo partition and on a sticker on the back of your xiaoxin pad pro box. It`s the first 8 characters in the partition.
You can read the partition by going to Tools->Partition Manager in QFIL ,then right clicking on the fpinfo partition and clicking on "Read Image". The partition will be stored in %AppData%\Qualcomm\<port number of your QDLoader port>\something-like-current-date.bin
Open the downloaded partition with a Hex-Editor (e.g. HxD) and insert your serial number under "Decoded text" by selecting the dots one by one and typing your serial number one character at a time or by copying your serial number marking 8 dots at a time in HxD and pasting it. Now save the bin-file. Then click in Partition Manager on "Load Image" and choose the bin file you just edited. Your Serial number should be restored after you restart, you can unlock your device like Tropaion explained in the other thread.
Sorry i really dont know how to edit serial number. I manage open the .bin file using hex editor, but there is 00 number ini hex, and dont know which number to edit. If you have a screenshot, it would help me. Thanks
 

z4mora

Member
Oct 7, 2022
14
1
Google Pixel 6
How did you flash the persist.img? Did you use the persist.img from the provided rom? What rom ver.?
Using QFIL, while in EDL Mode choose "manage partition" in tools tab. Pick persist and load persist.img from stock rom
how-to-backup-firmware-from-a-qualcomm-android-phone-using-qfil-11.jpg
 

carlosfla21

Member
Sep 26, 2022
29
13
Fala Carlos tudo bem?
Rapaz eu tentei acessar esse link, mais da error 404, estou desesperado, tenho uma semana que estou travado na mesma tela que vc estava, se puder me ajudar. Agradecer
O meu tablet estava travado na tela de fastboot, ai gerei a imagem através daquele link, colei a imagem dentro da pasta do programa que coloquei em anexo no ultimo post, executei o programa e destravou o bootloader, ai ele saiu da tela de fastboot e instalei a rom cheinesa, atualizei manualmente até a atualização, ai bloquei o bootloader de novo ai deu tudo certo, mas só consegui pq gerei a imagem por esse link, sem a imagem ele não desbloqueava.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    did you change the HAHAHAHA sn.img before locking it?
    Yes, I put back the original serial number
    1
    Thanks. Also, were you able to request sn.img or did you use the HAHAHA sn.img? I'm having no luck requesting from zui unlock website.
    I used HAHAHAHA sn.img. It was the only way I found
    1
    Last time I tried to lock this tablet it says device corrupted i didn't do it in fastboot let me try your steps and let's see. Thanks.🤞


    It worked!! Thanks a lot for sharing info here!
    Device is showing certified in Play store but still L3 not L1. That's fine as long as it is locked now.
    this is weird, you can try watching something on netflix, you might be able to watch it in high resolution. If not, you can try the process again. but then you will have to unlock it. the bootloader, and manually install the versions, and then lock the bootloader. you can put here what will happen after trying to watch Netflix or other services
    1
    To follow the instructions, do you need an unlocked bootloade yes, it better be unlocked. Many things can go wrong, and you can have many problems to try to solve
  • 18
    How to install Stock ROM - Xiaoxin Pad Pro 2021 [TB-J716F]

    I tried installing a GSI-ROM on this tablet, which basically worked except for three/four bugs I coulnd't solve.
    So I tried to restore the Stock ROM in the meantime and will share my experience.
    Your data will be deleted, try it at your own risk.

    Requirements:
    Installation:
    1. Boot tablet in EDL-Mode, there are two ways (in EDL-Mode screen always remains off):
      • If tablet is fully booted: use adb command "adb reboot edl"
      • If tablet is off or can't be booted: press the volume up button and hold, plug the usb cable into the tablet and PC and wait a few seconds
    2. Now this should appear in your device manager:
      device_manager.png
    3. Start the QFIL-Programm, it should detect the port with the same name.
    4. Go to "Configuration" -> "FireHose Configuration". At device type select "ufs" and tick "Reset After Download" then press ok:
      qfil_1.png
    5. Back in the main window select "Programmer Path" and browse to the ROM-Folder, select the file "prog_firehose_ddr.elf".
    6. Select "Content XML" and browse to the ROM-Folder, select the file "contents.xml"
    7. Click "Download Content" and wait, may take a few minutes
    8. After its done, this status message should a appear and the tablet should reboot.
    qfil_2.png


    Done, Stock-ROM should boot now.
    10
    Hi guys, I'll leave my contribution here. I was forced to reinstall the ROM as I had the excellent idea to lock Bootloader with the 'Global' ROM installed. Everything went wrong and my tablet didn't start anymore, it was just on the Fastboot screen. The “Tropaion” tutorial helped me a lot.

    I was using Windows 11, and it didn't recognize the tablet at all and when it did, it gave an error at the time of “download content” in QFIL, the famous error of “sahara fail”. At least in my case, I had to do the procedures for Windows 10 newly installed on the machine.

    Starting from the beginning

    • I used the QFIL that comes with QPST_2.7.496. Qualcomm's driver installer came with it as well. (https://qpsttool.com/)
    • After installing QPST I put the ROM folder inside the bin folder. Example: "C:\Program Files (x86)\Qualcomm\QPST\bin\TB-J716F_CN_OPEN_USER_Q00209.3_R_ZUI_12.6.211_ST_210730_qps"
    • I started QFIL and configured it according to what “Tropaion” taught.

    The EDL Dilemma

    • As my tablet was already stuck on the Fastboot screen, so I turned it off and pressed the volume up button, connected the cable to the PC and tablet, waited a few seconds and released the button.
    • Soon it went into EDL mode (It stays with the screen off, but connected to the PC) and I continued the procedure in QFIL. (If there is any error and you want to exit this mode just press the volume up & Power On/Off button together for ~30s, but if everything works out you won't need to)
    • Then he did the installation and the Lenovo Xiaoxin Pad Pro 2021 worked perfectly. But with the bootloader unlocked.

    Locking Bootloader with Chinese ROM installed


    - When I turned on the Xiaoxin Pad it already had an update from Lenovo. And it was updated successfully!
    - I installed the Play Store through the lenovo store, and even the tablet is with the Play Protect Certificate activated and Widevine L1 everything ok.


    Important: This method worked for me, but it doesn't mean it will work for you. Unforeseen events can happen during the procedure. As I've never installed a ROM in my life, it took me quite a while to fix my error and get my Tablet back up and running :). So do it at your own risk.

    Hope this helps ;)


    New update Lenovo
    20211024_095359.jpg


    DRM Info
    Screenshot_2021-10-25-01-01-10-1625424965.jpg


    [Update] ZUI 13.0.364 is now available!!​

    Screenshot_2021-11-20-09-37-40-0847653534.jpg

    Screenshot_2021-11-20-09-37-24-0718768572.jpg
    8
    Finally managed to install China ROM. I started with unlocked bootloader and Banggood tablet with global ROM.
    Everything OK, finally got Widevine L1, OTA. Only English and Chineze languages. Netfix works in FullHD.

    I have run into sahara fail issue on windows 11. To resolve this, I followed @PHRS and @Tropaion guides. USB debugging has to be enabled first in the tablet menu.

    1. Install Qualcomm USB Driver v1.0 and restart computer
    driver.jpg


    2. Install QPST Tool in default path ProgramFiles(x86) https://qpsttool.com/qpst-tool-v2-7-496
    3. Extract ROM content in C:\Program Files (x86)\Qualcomm\QPST\bin\TB-J716F_CN_OPEN_USER; I guess this is important, because if I left the ROM in a Desktop folder, I got Sahara fail. May be due to windows 11 security implementation and ProgramFiles file access stuff...
    4. Connect tablet in EDL mode - I did it with with adb command "adb reboot edl"
    5. Check if the tablet is visible in Device manager, under Ports (COM&LPT); note the port number. Tablet screen is black.
    6. Execute as Administrator "C:\Program Files (x86)\Qualcomm\QPST\bin\QFIL.exe"; the port number from step 5 should be visible in QFIL.
    7. Setup QFIL / FireHose Configuration as indicated in Opening post (0-Sahara, ufs, reset after download)
    8. Browse Programmer path with "C:\Program Files (x86)\Qualcomm\QPST\bin\TB-J716F_CN_OPEN_USER\prog_firehose_ddr.elf" and Content XML with "C:\Program Files (x86)\Qualcomm\QPST\bin\TB-J716F_CN_OPEN_USER\contents.xml"
    Screenshot 2021-11-24 182003.png


    9. Click download content. For me it worked fast, the log showed the processes running in a few steps. I had a USB3 connection, maybe this is why it went very fast (~20-30 seconds).
    10. Tablet can be rebooted with the new ROM, but still Widevine L3
    11. To lock the bootloader, first install LenovoUsbDriver_v1.1.47
    12. Use @Tropaion lock batchscript https://forum.xda-developers.com/t/...n-pad-pro-2021-tb-j716f.4347321/post-85775623
    13. The bootloader is locked and the tablet is reset. Widevine L1 and OTA after this.
    14. A bit weird boot with all the Chineze, but embedded apps can be easily uninstalled. I installed Aptoide, then Google Play, Netflix, Swiftkey instead of the chinese one, etc.

    Thank you @Tropaion, @PHRS and the rest of XDA community. All the best!

    LE. By the way, when I first got the tablet I thought the wifi module is broken or something, because it connected my wifi, but with limited connection. I finally realized that the date/time was wrong (because of the empty battery I guess), and after I manually adjusted the date, internet connection was established.
    4
    It has multi-language and on the product page banggood says it comes rooted with Chinese ROM with play store installed and multi-languages.
    If it was original Chinese rom, it should have update option. Am I right?
    Hello @sabaku_chris! Your tablet has unofficial Chinese ROM.

    The official Chinese ROM does not come with the Google Play Store pre-installed and only comes in two languages, English and Chinese. It comes with firmware upgrade option (via OTA), with Widevine L1 and, if you install Google Play Store, comes with Play Protect Certificate.

    An advice: But if you don't need these features, continue with the version that was already installed on it. In case of doubt, do not change the ROM.
    4
    This is a guide for anyone that is trying to lock the bootloader and receiving a "Your device is corrupt" message.

    I just got my Xiaoxin Pad Pro 2021 [TB-J716F] which had the global rom and unlocked boot loader. I followed CleberJorge's amazing guide to put the original Chinese rom on which worked perfectly up until you have to lock the bootloader, which I then got the “Your device is corrupt…” message.

    To solve this you have to manually update to the latest version ZUI 13 before locking the bootloader again. Once you have done this you will be able to do OTA updates and you will have widevine L1 support for HD Netflix etc.

    CleberJorge's guide to flash to stock chinese rom is here https://forum.xda-developers.com/t/...n-p11-pro-2021-original-rom-tb-j716f.4446671/

    The process for updating manually is the following:

    1) download the update.

    2) use a file explorer and move it to the root folder of your device.

    3) rename it to "update.zip".

    4) Got to Settings => System Update => "Select the 3 dots top right and select 'Use the install package update'

    Repeat these steps for each individual update

    The order of updates are (this is from the stock Chinese rom version of TB-J716F_CN_OPEN_USER_Q00209.3_R_ZUI_12.6.211_ST_210730_qpst

    1) TB-J716F_CN_OPEN_USER_Q00209.3_R_ZUI_12.6.238_ST_210824_to_TB-J716F_CN_OPEN_USER_Q00209.3_R_ZUI_13.0.346_ST_211108.zip - download link https://mega.nz/file/4h13DI4R#09imnGFk0c16CPNG635AYIClewuF5rXkiaj3xqGmjA8

    2) TB-J716F_CN_OPEN_USER_Q00209.3_R_ZUI_13.0.346_ST_211108_to_TB-J716F_CN_OPEN_USER_Q00209.3_R_ZUI_13.0.364_ST_211115.zip - download link https://mega.nz/file/l5ljWChS#rL44OM0-PuIFGZWSwr46pJr5S8NcY0JuYH7ctEeVTNs

    3) TB-J716F_CN_OPEN_USER_Q00209.3_R_ZUI_13.0.364_ST_211115_to_TB-J716F_CN_OPEN_USER_Q00209.3_R_ZU...zip - download link https://forum.xda-developers.com/at...j716f_cn_open_user_q00209-3_r_zu-zip.5522973/

    4) TB-J716F_CN_OPEN_USER_Q00209.3_R_ZUI_13.0.430_ST_220113_to_TB-J716F_CN_OPEN_USER_Q00209.3_R_ZU...zip - download link https://forum.xda-developers.com/at...j716f_cn_open_user_q00209-3_r_zu-zip.5598667/

    So the version you need to be running before attempting to lock the bootloader is 13.1.555 so double check your version in settings => My Device

    @CleberJorge you might want to add this to your guide.

    Spent alot of time cracking this annoying issue, so hope it helps a few people out.
    *Note this procedure works as of 25/5/22, it may change if there's a new update.