How To Guide Install Stock ROM - Xiaoxin Pad Pro 2021 [TB-J716F]

Search This thread


Dec 18, 2022
The same happen to my today, i check and the tablet is running 14.0.127, could you share me the steps you do to block the bootloader ?

( By the way in mines PlayStore is working fine, i installed it trough the Lenovo AppStore, this before i update to Zui13 )

Thank you
First, turn off the tablet and press the power and volume down buttons together. Open cmd and type: fastboot flashing lock. I did like this


Oct 7, 2022
I used HAHAHAHA sn.img. It was the only way I found
Last time I tried to lock this tablet it says device corrupted i didn't do it in fastboot let me try your steps and let's see. Thanks.🤞

It worked!! Thanks a lot for sharing info here!
Device is showing certified in Play store but still L3 not L1. That's fine as long as it is locked now.
Last edited:


Dec 18, 2022
Last time I tried to lock this tablet it says device corrupted i didn't do it in fastboot let me try your steps and let's see. Thanks.🤞

It worked!! Thanks a lot for sharing info here!
Device is showing certified in Play store but still L3 not L1. That's fine as long as it is locked now.
this is weird, you can try watching something on netflix, you might be able to watch it in high resolution. If not, you can try the process again. but then you will have to unlock it. the bootloader, and manually install the versions, and then lock the bootloader. you can put here what will happen after trying to watch Netflix or other services
  • Like
Reactions: xiaofan99


Jan 21, 2023
Nothing with that. I have reponsed you in this thread with a photo of the problem.

small pp

New member
Jan 26, 2023
Need help please
Can't enter EDL mode
port not showing
In device it is showing as


New member
Mar 9, 2015
I have a xiaoxin pad and some day it cannot connect to google play.
I reinstall rom -> the installer said it corrupt -> the xiaoxin pad stuck in fastboot.
The way to fix is:
1. Install ADB driver -> it show device as ADB composite device
2. Command: fastboot oem edl -> go to EDL mode from fastboot
3. Change serial number to HAHAHA then unlock bootloader by this trick:
4. Install origin rom (first thread)

Hope this help anybody see the same situation


New member
Dec 29, 2022
Help-me please!


New member
Feb 5, 2023
Hi everyone, new here.

I wrote a tutorial which is working on 6th November 2022.

1. Please follow this tutorial to flash the stock ROM.
2. Then update the tablet manually by installing 5 different packages up to 13.1.560
3. Lock the bootloader
4. You will have the Widevine L1 license (FULL HD for Netflix, Mycanal, Prime Video) managed by SnapDragon 870 (2 times faster than SD 730)

Follow the order, otherwise the bootloader will be blocked, you will spend hours to unblock the situation .

Hope it helps.
what command you use to lock , after downgrade and up to 13.1.560 then I locked after that cannot boot it say corrupted

Top Liked Posts

  • There are no posts matching your filters.
  • 18
    How to install Stock ROM - Xiaoxin Pad Pro 2021 [TB-J716F]

    I tried installing a GSI-ROM on this tablet, which basically worked except for three/four bugs I coulnd't solve.
    So I tried to restore the Stock ROM in the meantime and will share my experience.
    Your data will be deleted, try it at your own risk.

    1. Boot tablet in EDL-Mode, there are two ways (in EDL-Mode screen always remains off):
      • If tablet is fully booted: use adb command "adb reboot edl"
      • If tablet is off or can't be booted: press the volume up button and hold, plug the usb cable into the tablet and PC and wait a few seconds
    2. Now this should appear in your device manager:
    3. Start the QFIL-Programm, it should detect the port with the same name.
    4. Go to "Configuration" -> "FireHose Configuration". At device type select "ufs" and tick "Reset After Download" then press ok:
    5. Back in the main window select "Programmer Path" and browse to the ROM-Folder, select the file "prog_firehose_ddr.elf".
    6. Select "Content XML" and browse to the ROM-Folder, select the file "contents.xml"
    7. Click "Download Content" and wait, may take a few minutes
    8. After its done, this status message should a appear and the tablet should reboot.

    Done, Stock-ROM should boot now.
    Hi guys, I'll leave my contribution here. I was forced to reinstall the ROM as I had the excellent idea to lock Bootloader with the 'Global' ROM installed. Everything went wrong and my tablet didn't start anymore, it was just on the Fastboot screen. The “Tropaion” tutorial helped me a lot.

    I was using Windows 11, and it didn't recognize the tablet at all and when it did, it gave an error at the time of “download content” in QFIL, the famous error of “sahara fail”. At least in my case, I had to do the procedures for Windows 10 newly installed on the machine.

    Starting from the beginning

    • I used the QFIL that comes with QPST_2.7.496. Qualcomm's driver installer came with it as well. (
    • After installing QPST I put the ROM folder inside the bin folder. Example: "C:\Program Files (x86)\Qualcomm\QPST\bin\TB-J716F_CN_OPEN_USER_Q00209.3_R_ZUI_12.6.211_ST_210730_qps"
    • I started QFIL and configured it according to what “Tropaion” taught.

    The EDL Dilemma

    • As my tablet was already stuck on the Fastboot screen, so I turned it off and pressed the volume up button, connected the cable to the PC and tablet, waited a few seconds and released the button.
    • Soon it went into EDL mode (It stays with the screen off, but connected to the PC) and I continued the procedure in QFIL. (If there is any error and you want to exit this mode just press the volume up & Power On/Off button together for ~30s, but if everything works out you won't need to)
    • Then he did the installation and the Lenovo Xiaoxin Pad Pro 2021 worked perfectly. But with the bootloader unlocked.

    Locking Bootloader with Chinese ROM installed

    - When I turned on the Xiaoxin Pad it already had an update from Lenovo. And it was updated successfully!
    - I installed the Play Store through the lenovo store, and even the tablet is with the Play Protect Certificate activated and Widevine L1 everything ok.

    Important: This method worked for me, but it doesn't mean it will work for you. Unforeseen events can happen during the procedure. As I've never installed a ROM in my life, it took me quite a while to fix my error and get my Tablet back up and running :). So do it at your own risk.

    Hope this helps ;)

    New update Lenovo

    DRM Info

    [Update] ZUI 13.0.364 is now available!!​


    Finally managed to install China ROM. I started with unlocked bootloader and Banggood tablet with global ROM.
    Everything OK, finally got Widevine L1, OTA. Only English and Chineze languages. Netfix works in FullHD.

    I have run into sahara fail issue on windows 11. To resolve this, I followed @PHRS and @Tropaion guides. USB debugging has to be enabled first in the tablet menu.

    1. Install Qualcomm USB Driver v1.0 and restart computer

    2. Install QPST Tool in default path ProgramFiles(x86)
    3. Extract ROM content in C:\Program Files (x86)\Qualcomm\QPST\bin\TB-J716F_CN_OPEN_USER; I guess this is important, because if I left the ROM in a Desktop folder, I got Sahara fail. May be due to windows 11 security implementation and ProgramFiles file access stuff...
    4. Connect tablet in EDL mode - I did it with with adb command "adb reboot edl"
    5. Check if the tablet is visible in Device manager, under Ports (COM&LPT); note the port number. Tablet screen is black.
    6. Execute as Administrator "C:\Program Files (x86)\Qualcomm\QPST\bin\QFIL.exe"; the port number from step 5 should be visible in QFIL.
    7. Setup QFIL / FireHose Configuration as indicated in Opening post (0-Sahara, ufs, reset after download)
    8. Browse Programmer path with "C:\Program Files (x86)\Qualcomm\QPST\bin\TB-J716F_CN_OPEN_USER\prog_firehose_ddr.elf" and Content XML with "C:\Program Files (x86)\Qualcomm\QPST\bin\TB-J716F_CN_OPEN_USER\contents.xml"
    Screenshot 2021-11-24 182003.png

    9. Click download content. For me it worked fast, the log showed the processes running in a few steps. I had a USB3 connection, maybe this is why it went very fast (~20-30 seconds).
    10. Tablet can be rebooted with the new ROM, but still Widevine L3
    11. To lock the bootloader, first install LenovoUsbDriver_v1.1.47
    12. Use @Tropaion lock batchscript
    13. The bootloader is locked and the tablet is reset. Widevine L1 and OTA after this.
    14. A bit weird boot with all the Chineze, but embedded apps can be easily uninstalled. I installed Aptoide, then Google Play, Netflix, Swiftkey instead of the chinese one, etc.

    Thank you @Tropaion, @PHRS and the rest of XDA community. All the best!

    LE. By the way, when I first got the tablet I thought the wifi module is broken or something, because it connected my wifi, but with limited connection. I finally realized that the date/time was wrong (because of the empty battery I guess), and after I manually adjusted the date, internet connection was established.
    It has multi-language and on the product page banggood says it comes rooted with Chinese ROM with play store installed and multi-languages.
    If it was original Chinese rom, it should have update option. Am I right?
    Hello @sabaku_chris! Your tablet has unofficial Chinese ROM.

    The official Chinese ROM does not come with the Google Play Store pre-installed and only comes in two languages, English and Chinese. It comes with firmware upgrade option (via OTA), with Widevine L1 and, if you install Google Play Store, comes with Play Protect Certificate.

    An advice: But if you don't need these features, continue with the version that was already installed on it. In case of doubt, do not change the ROM.
    This is a guide for anyone that is trying to lock the bootloader and receiving a "Your device is corrupt" message.

    I just got my Xiaoxin Pad Pro 2021 [TB-J716F] which had the global rom and unlocked boot loader. I followed CleberJorge's amazing guide to put the original Chinese rom on which worked perfectly up until you have to lock the bootloader, which I then got the “Your device is corrupt…” message.

    To solve this you have to manually update to the latest version ZUI 13 before locking the bootloader again. Once you have done this you will be able to do OTA updates and you will have widevine L1 support for HD Netflix etc.

    CleberJorge's guide to flash to stock chinese rom is here

    The process for updating manually is the following:

    1) download the update.

    2) use a file explorer and move it to the root folder of your device.

    3) rename it to "".

    4) Got to Settings => System Update => "Select the 3 dots top right and select 'Use the install package update'

    Repeat these steps for each individual update

    The order of updates are (this is from the stock Chinese rom version of TB-J716F_CN_OPEN_USER_Q00209.3_R_ZUI_12.6.211_ST_210730_qpst

    1) - download link

    2) - download link

    3) - download link

    4) - download link

    So the version you need to be running before attempting to lock the bootloader is 13.1.555 so double check your version in settings => My Device

    @CleberJorge you might want to add this to your guide.

    Spent alot of time cracking this annoying issue, so hope it helps a few people out.
    *Note this procedure works as of 25/5/22, it may change if there's a new update.