Question Instapay banking app detects root help please

Search This thread

xxqxpxx

Senior Member
Oct 14, 2014
380
32
27
banha
Hello everyone,

So my banking app instapay is a harsh one when it comes to root, I've tried everything to hide it but failed. I have magisk 24.3, zygisk and lsposed installed. Stock may update pixel 6

I have tried to enforce deny list and normal, also installed a bunch of hiding tools like Enhance mode for HideMyApplist, Shamiko , Universal SafetyNet Fix, xprivcylua and all failed.

I would appreciate your help the app would crash on first start. Im also okay with any virtual space solution that would work as well i tried island with work profile and parallel space both failed too

 

Strephon Alkhalikoi

Senior Member
Aug 3, 2010
7,189
3,305
Vulcan
Samsung Galaxy S4
Nexus 6
Not sure if anyone here is going to have a solution, especially where you have tried all the standard solutions. You may simply have to deal with not using the app on your device.

The only thing I can suggest is getting rid of your Xposed clone. The app I believe is almost certainly detecting it.
 

tom1807

Senior Member
Similar situation for me recently with Citibank, I have only Universal SafetyNet Fix and MagiskHide Props Config installed as modules, nothing else.
Magisk 24.3 was hidden, Citibank worked until May 14. This day it suddenly detected Magisk and told me me right out your mobile is rooted with Magisk or any other app.
I added a second user, installed Citibank for the second user and it worked. (seems it doesn't care that the bootloader is unlocked).
Then, I tried the following as Main user::
1. deleted Data and Cache from Citibank
2. Unhide Magisk, Hide it again but this time a new name (not the standard suggestion "Settings")
3. Opened Citibank again, logged in and it worked.
4. Deleted the second user again (optional)
Why? Can't give a specific reason, but a possibility is, that 2 x Settings in the AppDrawer was flagged as suspicious.
So you could try to have a second profile on your mobile or try the steps above.

Cheers
Tom
 

spida_singh

Senior Member
Mar 3, 2011
525
166
If you are using adaway to block ads via root, run the DNS log to see what urls the app is trying to connect to.

I had this issue with a UK Halifax banking app, all was working fine until middle of May, and then i found a new URL the app was connecting to, when i blocked it, it worked OK,

Moe information on this here:-

 

shoey63

Recognized Contributor
@xxqxpxx
Instapay detects zygisk
Only way around is Magisk Alpha with magisk hide activated (It's on Telegram)
Riru, Riru Universal Safetynet fix and Riru xposed (if needed).
Configure the deny list as per screenshot.
Reboot and you're good to go Screenshot_20220526-085914.png
 
Last edited:

xxqxpxx

Senior Member
Oct 14, 2014
380
32
27
banha
This is what they use : any ideas?

public static boolean isRooted(Context context) {
String str = Build.TAGS;
if ((!isEmulator && str != null && str.contains("test-keys")) || new File("/system/app/Superuser.apk").exists()) {
return true;
}
return !isEmulator && new File("/system/xbin/su").exists();
}