Intermittent loss of touch response

Search This thread

TBacker

Senior Member
Sep 12, 2008
174
58
Just retired my 2 XL and got a like-new 4 XL. Loving it so far, except one nagging issue.

Randomly the top 30-50% of the display stops registering taps (touch). It's easy to fix by turning the display off then back on, but I'm concerned it may be a hardware issue.

Interestingly, when this happens and something that is full screen and scrollable such as a contact list or app drawer is in the foreground, I can drag from below the "no touch area" to the top of the screen, but I can't start a drag at the top. So, it can sense touch in the troubled half, it just won't register taps.

I have done tons of searches. I see lots of people saying Android 12 had touch issues out of the gate, but was supposedly fixed. I disabled the block_untrusted_touches. I have checked any app that has draw over other apps permissions. I have tried with high touch sensitivity on and off. I have paid attention to running apps when it happens. I installed a LogCat reader looking for touch related issues when the problem occurs. I tried safe mode, but due to the intermittent nature of the problem, and the fact that safe mode disables most functionality, it really wasn't a good long term test.

I have yet to pinpoint this.

Sometimes it doesn't happen for a day, other times it's multiple times per day. So trial and error takes time because just when you think you licked the problem, it rears it's ugly head again.

I'm running LineageOS 19.1 at the moment (which I had also run on my 2XL with no issues). It is rooted. No apps force closing or crashing.

Has anyone else seen this on the 4XL?
 
Last edited:

#mcl

Senior Member
Definitely interesting, never heard of that. I had some touch issues, specially if the display gets wet where it register touch, but poorly to the point I need to restart the device and dry out the screen. Though in my case the creen is completely cracked, so I suspect that's the cause as it didn't happened before.
Though I had a similar to yours but with the battery.
The problem was that the phone would randomly shut down, and that would happen more often when it was on my pocket.
This made the phone very un stable as sometimes I would have the phone completely off and didn't even know about it.
So I decided to open it and have a look at it. It turn out that the problem was the flex cable that connected the battery with the logic board, it was just slightly tore on one side, but just a tiny I couldn't nearly see it, I had to use another phone to zoom in.
As it was torn, depending on the way the phone was changed the force the gravity made over the cable, causing that sometimes it not enough energy got the phone, causing it to shut down.
Once I replaced it, it never happened again, not a single time.
Maybe you have a similar problem, though as you are rooted and using a custom ROM, that may be the reason, my case was extremely rare.
anyway, good luck 🤞🏻