• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

intermittent serious UI-feedback lag

Search This thread

babbar559

Senior Member
Jul 4, 2013
291
68
Fresno, Ca
Mine was lagging a lot but then i find out one of the xposed moudule was causing it..after disabling that module now my phone just works fine... hope this will fix some of urs lagging problems.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Most of the time, my Note 7 is instantly responsive no matter how heavily loaded it is.

    Every few hours, though, it gets into a mode with serious UI-feedback lag. In this mode, when I tap any key or icon, the corresponding click-and-vibration feedback is delayed by up to one or two seconds. Often I can type several characters with no feedback, followed a second later by a rapid-fire sequence of the delayed clicks and vibrations.

    When the phone is in lag mode, the lag occurs in all apps and with both keyboards I've tried (Samsung and Google). And it's not just during typing; tapping on any icon produces the same lag. Lag mode is not fixed by closing all apps, turning on Airplane mode, clearing the clipboard, switching to a different keyboard app, or clearing the keyboard cache or data. (Clearing the clipboard did seem to fix the problem on one occasion, but not subsequently.)

    Rebooting the phone does fix the problem--until it comes back again a few hours later. I've tried booting into recovery and clearing the system cache, but the problem still comes back in a few hours. I have not had time to try a factory reset. But the phone is completely stock (APH1), no power-saving turned on, no debloating or esoteric settings or apps.

    As I said above, most of the time the phone doesn't have this problem, no matter how many apps are running. And when the lag occurs, the phone is not hot and is not draining the battery. So it's not a matter of the phone being overloaded; rather, it's a specific bug in the UI feedback.

    The problem arises at seemingly random times. I have not noticed any pattern as to what triggers it.

    Here's a video demonstrating the problem, both for typing and for icon-tapping:
    https://vid.me/iYya

    And just for contrast, here's a video of the phone when it's working properly, with no UI-feedback delay:
    https://vid.me/GF82

    Again, when the phone is in lag-mode, it lags in all apps, for typing and for all icon-taps, etc. The videos show only one particular app for illustration.
    1
    Further discovery: when the phone is in lag mode, if I turn off keyboard-sound feedback but leave keyboard-vibration feedback enabled, then there is no lag on the vibration feedback (but the sound feedback from icon-tapping still lags). When keyboard sound- and vibration-feedback are both enabled, then both the sound and the vibration lag. (When just the sound-feedback is enabled, the sound-feedback still lags.)

    Also, when the phone is in lag mode, if I start using BT earphones, the lag stops (or rather is replaced by a uniform ~100ms lag, which is less annoying). When I disconnect my BT earphones and go back to speaker sound, the sound and vibration lag both resume. Wired earphones, unlike BT earphones, do not affect the lag at all.
    1
    Noticed this a bunch today. Does get rather irritating on a week old phone.
    1
    My lag is progressively worse. At this point I'm not sure if I even want the recall replacement. It's a shame because I absolutely love it, but the lag is almost a deal breaker. Everything from opening the camera to typing to even fingerprint unlocking he screen there is a serious stutter it seems system wide. I may just swap for an S7 edge or just return it and (gasp!) pre order an iPhone 7