• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Invalid Scatter in SP Flash Tool problem

Search This thread

NoveNoki

Member
Dec 6, 2021
21
1
Hi! I am experiencing a problem where SP Flash Tool is saying that my Scatter file is incorrect, i have tried like 15 different versions, but all of them say a different error about the scatter, so i thought that if i run it on Ubuntu it will work becouse i already had Ubuntu dual booting with Windows. Ubuntu had no problem at all opening the scatter tried different versions and it worked perfectly fine but if i run it from Ubuntu, it can't detect my phone (Alcatel 1X 5059D) becouse it's hard bricked and not booting up... So in Windows it can detect it, well for like 30 seconds and connect/disconnects.. So here is more info specified:

OS: Windows 11 on Laptop Lenovo 81HN

Android Phone: Pre-installed 8.1.0, GSI Custom Rom Android 10Q, then while installing 11 [R] hard bricked
MediaTek chip: MT6739

Main problem is that on Windows 11 it can't detect the scatter file, but in Ubuntu it can
Any help will be apriciated.. :)
 

SubwayChamp

Senior Member
Aug 6, 2016
3,403
3
1,443
Hi! I am experiencing a problem where SP Flash Tool is saying that my Scatter file is incorrect, i have tried like 15 different versions, but all of them say a different error about the scatter, so i thought that if i run it on Ubuntu it will work becouse i already had Ubuntu dual booting with Windows. Ubuntu had no problem at all opening the scatter tried different versions and it worked perfectly fine but if i run it from Ubuntu, it can't detect my phone (Alcatel 1X 5059D) becouse it's hard bricked and not booting up... So in Windows it can detect it, well for like 30 seconds and connect/disconnects.. So here is more info specified:

OS: Windows 11 on Laptop Lenovo 81HN

Android Phone: Pre-installed 8.1.0, GSI Custom Rom Android 10Q, then while installing 11 [R] hard bricked
MediaTek chip: MT6739

Main problem is that on Windows 11 it can't detect the scatter file, but in Ubuntu it can
Any help will be apriciated.. :)
Do you happen to know if your device needs an auth file, or did you flash it successfully before on Windows?

Also, can you enter to recovery and fastboot?

Did you try the Auto format flash (whiteout preloader)?
 
  • Like
Reactions: NoveNoki

NoveNoki

Member
Dec 6, 2021
21
1
Do you happen to know if your device needs an auth file, or did you flash it successfully before on Windows?

Also, can you enter to recovery and fastboot?

Did you try the Auto format flash (whiteout preloader)?
I'm pretty sure it needs an auth file, and i never succesfully flashed with SP Flash Tool

I cannot enter recovery and fastboot

I cannot use Auto flash on Ubuntu becouse when i select the preloader.bin file it says that it is invalid and that's why..

i don't know if this info is needed, but it tries to boot up every time i connect it to USB and fails, also it connects and disconnects every like 5 seconds after i connect it to USB
 

SubwayChamp

Senior Member
Aug 6, 2016
3,403
3
1,443
I'm pretty sure it needs an auth file, and i never succesfully flashed with SP Flash Tool

I cannot enter recovery and fastboot

I cannot use Auto flash on Ubuntu becouse when i select the preloader.bin file it says that it is invalid and that's why..

i don't know if this info is needed, but it tries to boot up every time i connect it to USB and fails, also it connects and disconnects every like 5 seconds after i connect it to USB
Ok, then your device probably need to bypass the auth file.

Follow this carefully in Windows https://forum.xda-developers.com/t/...d-flash-in-edl-with-no-auth-for-free.4229683/

As per the connection issue is because you are not getting the device totally off, always that you can shut down, from there is needed to press (in some devices) the two volume buttons, and once SP Flash tool detects it properly the operation start safely.

Adding to the thread I'm linking you, actually newer devices need to be connected through BROM mode, not through preloader, that is where the OEM permission lies and the connection refuses to operate in some way.
 

NoveNoki

Member
Dec 6, 2021
21
1
Ok, then your device probably need to bypass the auth file.

Follow this carefully in Windows https://forum.xda-developers.com/t/...d-flash-in-edl-with-no-auth-for-free.4229683/

As per the connection issue is because you are not getting the device totally off, always that you can shut down, from there is needed to press (in some devices) the two volume buttons, and once SP Flash tool detects it properly the operation start safely.

Adding to the thread I'm linking you, actually newer devices need to be connected through BROM mode, not through preloader, that is where the OEM permission lies and the connection refuses to operate in some way.
I'm not home at the moment, but i am going to try right away when i get home, thanks :)
 

NoveNoki

Member
Dec 6, 2021
21
1
Ok, then your device probably need to bypass the auth file.

Follow this carefully in Windows https://forum.xda-developers.com/t/...d-flash-in-edl-with-no-auth-for-free.4229683/

As per the connection issue is because you are not getting the device totally off, always that you can shut down, from there is needed to press (in some devices) the two volume buttons, and once SP Flash tool detects it properly the operation start safely.

Adding to the thread I'm linking you, actually newer devices need to be connected through BROM mode, not through preloader, that is where the OEM permission lies and the connection refuses to operate in some way.
Hi! So i did bypass the Auth file, and downloaded the Stock ROM from another site, and the problem with the scatter was the site i'm not sure why but yeah, tho now when i click on Download, it just says another error:

ERROR : STATUS_PRELOADER_INVALID (0xC0030004)

The Preloader file format is invalid!
[HINT]:
Please retry another official load.

So i cannot select the preloader.bin becouse it says:

Please check the load image file is correct or not?


I am not sure if the preloader is corrupted becouse it is a fresh one just downloaded.
 

SubwayChamp

Senior Member
Aug 6, 2016
3,403
3
1,443
Hi! So i did bypass the Auth file, and downloaded the Stock ROM from another site, and the problem with the scatter was the site i'm not sure why but yeah, tho now when i click on Download, it just says another error:

ERROR : STATUS_PRELOADER_INVALID (0xC0030004)

The Preloader file format is invalid!
[HINT]:
Please retry another official load.

So i cannot select the preloader.bin becouse it says:

Please check the load image file is correct or not?


I am not sure if the preloader is corrupted becouse it is a fresh one just downloaded.
Try with other version from the tool.
Also, you should try with flashing the partitions just one by one.
This could be risky, but formatting could fix the issue depending on what leaded your device to this state. lol.png
 

NoveNoki

Member
Dec 6, 2021
21
1

Attachments

  • Screenshot (4).png
    Screenshot (4).png
    179.5 KB · Views: 9
Last edited:

NoveNoki

Member
Dec 6, 2021
21
1
Flash only preloader, lk and lk2 partitions and see if it works, for next flashing you also can try in the UART mode at the 921600 max speed and see if it makes a difference. And also what did you get with trying every partition one by one?
When i tried flashing one by one, i got the same error, also tried formatting, and tried using SP Flash Tool the latest V3.x but in the V3 version i don't get any errors, but it is just stuck at 0% and doesn't move
 

SubwayChamp

Senior Member
Aug 6, 2016
3,403
3
1,443
When i tried flashing one by one, i got the same error, also tried formatting, and tried using SP Flash Tool the latest V3.x but in the V3 version i don't get any errors, but it is just stuck at 0% and doesn't move
Weird, I heard something years ago about this device having some issues with the hardware. With some MediaTek devices, you don't have to touch the preloader, or it gets corrupted, don't you have someone to provide you a back-up of the PreLoader from a functional device?

I'm assuming that you are trying every operation once at a time, as you know SP Flash tool is just one-action per time, this means you need to put it in download mode every time you try to flash even a single partition. And what about the UART mode, I talked?
 

NoveNoki

Member
Dec 6, 2021
21
1
Weird, I heard something years ago about this device having some issues with the hardware. With some MediaTek devices, you don't have to touch the preloader, or it gets corrupted, don't you have someone to provide you a back-up of the PreLoader from a functional device?

I'm assuming that you are trying every operation once at a time, as you know SP Flash tool is just one-action per time, this means you need to put it in download mode every time you try to flash even a single partition. And what about the UART mode, I talked?
I was always flashing with UART mode, 921600 how it said in the forum you sent, and i have no one to send me a back up, tho right now i tried flashing with preloader, lk and lk2 and now it just says Download DA 100% with red bar, and it disconnects and connects then i tried using the bypass tool, but it can't do anything with it becouse it says that my device is booted in preloader mode and says that it will try crashing it but it fails and just repeats that, then i removed the battery and i was able to run the bypass tool
 

SubwayChamp

Senior Member
Aug 6, 2016
3,403
3
1,443
I was always flashing with UART mode, 921600 how it said in the forum you sent, and i have no one to send me a back up, tho right now i tried flashing with preloader, lk and lk2 and now it just says Download DA 100% with red bar, and it disconnects and connects then i tried using the bypass tool, but it can't do anything with it becouse it says that my device is booted in preloader mode and says that it will try crashing it but it fails and just repeats that, then i removed the battery and i was able to run the bypass tool
Ok then repeat the process while it is bypassing the preloader mode.
 
  • Like
Reactions: NoveNoki

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi! I am experiencing a problem where SP Flash Tool is saying that my Scatter file is incorrect, i have tried like 15 different versions, but all of them say a different error about the scatter, so i thought that if i run it on Ubuntu it will work becouse i already had Ubuntu dual booting with Windows. Ubuntu had no problem at all opening the scatter tried different versions and it worked perfectly fine but if i run it from Ubuntu, it can't detect my phone (Alcatel 1X 5059D) becouse it's hard bricked and not booting up... So in Windows it can detect it, well for like 30 seconds and connect/disconnects.. So here is more info specified:

    OS: Windows 11 on Laptop Lenovo 81HN

    Android Phone: Pre-installed 8.1.0, GSI Custom Rom Android 10Q, then while installing 11 [R] hard bricked
    MediaTek chip: MT6739

    Main problem is that on Windows 11 it can't detect the scatter file, but in Ubuntu it can
    Any help will be apriciated.. :)
    Do you happen to know if your device needs an auth file, or did you flash it successfully before on Windows?

    Also, can you enter to recovery and fastboot?

    Did you try the Auto format flash (whiteout preloader)?
    1
    I was always flashing with UART mode, 921600 how it said in the forum you sent, and i have no one to send me a back up, tho right now i tried flashing with preloader, lk and lk2 and now it just says Download DA 100% with red bar, and it disconnects and connects then i tried using the bypass tool, but it can't do anything with it becouse it says that my device is booted in preloader mode and says that it will try crashing it but it fails and just repeats that, then i removed the battery and i was able to run the bypass tool
    Ok then repeat the process while it is bypassing the preloader mode.
    1
    Ok, I forgot here two main things, the first is what about the Alcatel Mobile Upgrade tool? It does allow flashing official firmware to repair the device. And the second, if you still don't know of it, mtk-client can work with your device.
    OMG THANKS!! The MTK-Client Tool has worked! Thank you alot, again!