IR Blaster does not work

Search This thread

KostasR

Senior Member
Dec 16, 2012
168
20
Guys mine was as it turned out burnt. Use your warranty and make them change your module. It also includes the front camera and the light and proximity sensor. After changing that, mine works as new. It is not a software issue. It's a hardware failure.

Cheers

Sent with my thumbs using Tapatalk 4 VIP
 

KostasR

Senior Member
Dec 16, 2012
168
20
Mine is C. They fixed it for free of course.

Cheers

Sent with my thumbs using Tapatalk 4 VIP
 

rj6530

New member
Jun 22, 2015
1
0
I tried the IR blaster today but it does not work. I used the stock app, Asmart and many more IR app in the playstore but it didn't work. I checked if the IR LED is functional by viewing it in a digital camera and it does lit up. Now I used the same app (Asmart) on multiple TV on my brother's note 3 to make sure it's not the app or the tv. I found out that its not the app or the tv but my phone. Model is SM 910C. Anyone else having the same problem?

I have an Unlocked note 4 SM910c and my IR blaster also stopped working (i only used the phone about a week) .... i guess its a common fault in this model...
 

KostasR

Senior Member
Dec 16, 2012
168
20
Mine died again for a 2nd time ??. I am furious. All C models must have a crappy batch of IR Blasters. I have to go to service again. I am afraid it will get burnt a 3rd time as well after I change it... ?

Sent with my thumbs using Tapatalk 4 VIP
 

oatcpe

New member
Feb 20, 2014
2
0
www.facebook.com
Mine died again for a 2nd time . I am furious. All C models must have a crappy batch of IR Blasters. I have to go to service again. I am afraid it will get burnt a 3rd time as well after I change it...

Sent with my thumbs using Tapatalk 4 VIP

Yes, IR part in NOTE4 is very crappy.
If you test with dial *#0*# . and not IR light emit from IR port (IR light can view by any digital camera/phone camera), It's IR bulb is totally dead.
You need to replace it. NO any software can fix.
 

Scarpellini

New member
Jul 26, 2015
1
0
Try Changing Dalvik to ART

Hello guys,

My problem was solved by changing the configs at developer options. Go to the 4º option and change from DALVIK to ART.

I didn't need to test several TV's options like i did before, the "Smart Remote App" worked from first try.

After you change the config the phone will restart to improve some apps, it take some time.

Let me know if that worked for you guys;


Sorry for my english.
 

amrpharm

New member
Aug 1, 2015
1
0
ir blaster not work

I asked if this problem will solved with last update android 5.1.1 or not
And this hardware or software?????
 

recDNA

Senior Member
Aug 24, 2011
1,626
97
Hello guys,

My problem was solved by changing the configs at developer options. Go to the 4º option and change from DALVIK to ART.

I didn't need to test several TV's options like i did before, the "Smart Remote App" worked from first try.

After you change the config the phone will restart to improve some apps, it take some time.

Let me know if that worked for you guys;


Sorry for my english.
I don't remember what problems it causes but I do remember people switching back to Dalvik because ART caused some major issues. Wish I could remember what. Looks like the Note 5 won't even have an ir blaster. I think the note 3 is the best one but I don't know how much longer my note 3 will last. I had so hoped to go to note 5 but it isn't even a note imo. I almost bought note 4 with 200 dollar rebate from Samsung but then I saw this thread and thought why switch to a phone that doesn't work?
 

cicakpoyo

New member
Sep 9, 2015
1
0
Found my device issue (N910F) Lollipop 5.1.1

I have same issue on my phone Original samsung galaxy note 4 SM-N910F. I bought the phone with Kitkat 4.4.4 ROM installed and i found that IR blaster cannot be used at all. I read all forum about IR blaster problem on note 4 and i flash my phone upgrade to 5.1.1 lollipop. After done upgrade and troubleshoot upgrading issue, IR blaster still cannot been used. :crying::crying:
However i found how to check the IR blaster is working or not by using other camera phone pointing to IR blaster censor and i saw that there is no light at beginning. After some days i carefully check again in dark room and found very low light, thats mean my IR blaster is working maybe IR blaster device either not in proper place or the power is very weak.:eek::eek:
To prove that my assumption is correct, i try remote my tv with peel from far but cannot work and try again very near to tv remote censor and wallaaaaaaa its works. I will send my sucks phone to warranty tomorrow.. :victory::victory::victory:
 
Last edited:

jess1

New member
Oct 9, 2015
1
0
Hi i also have the same problem with my note 4 and the problem croped out when i had the firmware update from Samsung..
I googled into some other forums and some of them pointed out that this is a firmware problem..
How many days and weeks should we wait for an update or at least a patch ti resolve this frustating issue..
Guys make preassure on Samsung to rectify this issue asap..
Tks
Jes
 

rosoftway

Member
Aug 21, 2010
5
1
ir blaster

From the begining ir blaster was inconsistently usable. Now with last update ir blaster doesnt work at all. I try to change front camera module with F version (mine is C) and ir blaster IS working but front camera is not. So I swap again with original in order to wait C version arrival from ebay.

With F version installed I see a very very powerful lite comming from ir blaster .... so...

May be a resistor attached (soldered) in parralel with ir blaster (from behind) will save ir blaster from burning by current intensity splitting.

If is there anyone who can do the math ....
 

milan979

Member
Apr 28, 2012
10
0
Just realized now that mine isn't working either. I think it was something with the latest firmware, n910cxxu1coi4 which is the last one I got OTA.
 

Kinsman-UK

Senior Member
Sep 4, 2008
393
167
Just realized now that mine isn't working either. I think it was something with the latest firmware, n910cxxu1coi4 which is the last one I got OTA.

I got COI4 for my N910C this week too - mine is still working. Just confirmed by using Touch Squid to control the TV (set to Alternate IR Driver).
 

milan979

Member
Apr 28, 2012
10
0
I got COI4 for my N910C this week too - mine is still working. Just confirmed by using Touch Squid to control the TV (set to Alternate IR Driver).

Oh that's strange. Mine does not seem to work with neither the smart remote app that came pre-installed or the app by Anymote...
Would hate to do a factory reset for this.
Any ideas on what the problem might be?

EDIT: Wow, I just installed touch squid and it presented me with a message that said "No IR blaster found."
 
Last edited:

Kinsman-UK

Senior Member
Sep 4, 2008
393
167
EDIT: Wow, I just installed touch squid and it presented me with a message that said "No IR blaster found."

That's odd - definitely didn't get that message on mine, but I did have to go into Clipboard Icon/Settings/Advanced and choose 'Alternate IR Driver' - then it worked fine. Perhaps the 'No IR blaster found' message is indicative of a hardware problem? Just to confirm, this is the TouchSquid version I'm using (if I remember correctly, I did have some issues with the trial version, but it did work well enough to convince me to buy it. The purchased version has had no such issues):

https://play.google.com/store/apps/details?id=remote.home.samsung

The free trial is: https://play.google.com/store/apps/details?id=ts.universal.remote.control

EDIT: By the way, I have the built-in 'Smart Remote' app disabled - don't know if that makes any difference though.
 

milan979

Member
Apr 28, 2012
10
0
It worked fine before the firmware update so it would be strange if it suddenly was a hardware problem.
I also have the built-in smart remote disabled and it was the trial version I tested. Furthermore, I cannot do anything else in the app when the message appears...
 

KaliKot

Senior Member
Sep 15, 2010
471
39
My N910c IR blaster stopped working after tinkering with Zazaremote. It worked fine before that for about a month. I think the n910c blaster really has a hardware defect.
 

dejang84

New member
Nov 8, 2011
3
0
Just realized now that mine isn't working either. I think it was something with the latest firmware, n910cxxu1coi4 which is the last one I got OTA.

I have absolutely same issue on same firmware.

EDIT: Touch squid presented me also with a message that said "No IR blaster found."
I have looked on ebay and it seems it is pretty cheap part to replace (couple of $).
It is a flex cable with front camera, ir blaster, proximity and light sensor.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    I wrote mail to the Samsung support and they answer me that they are working in this issue.
    2
    Interesting.. I'm considering buying the app. Do you have to do modify the buffers string by string or is there a global setting you apply to fix this?

    There's a global setting - feel free to buy the app, and send us an email at [email protected] (mention your xda username) so we can enable the setting for you. As with everyone else, if you don't like the app, it doesn't work for you, or any other reason, we'll manually refund your purchase.
    1
    The ir remote control is working or not? My answer are yes and no. It starts working for a while. Then don't know what happen it will stop suddenly. I don't think it is app related as other ir app will stop working as well after that. The phone must be turning off the service after something triggers it. After reboot the phone, it works again.

    Anyone who experience this, restart your phone and start again

    Sent from my SM-N910C using XDA Free mobile app
    1
    Strange.. when I updated to NK5 it worked for the first few days then eventually became intermittent again. From the Anymote reviews they say the workaround involves changing the way IR codes are sent from the Note 4, note sure what that means.

    AnyMote dev here - from what we've found, samsung messed up some buffers in the IR Blaster driver, which is why sending of IR signals seems to inconsistent. Our workaround includes working with those buffers to make sure commands get pushed through.
    1
    Found a workaround, close all applications and the IR blaster will be ok again.

    Sent from my SM-N910C