Is possible to reinstall the Outlook Mail and Calendar app (hard reset breaks it) ?

Search This thread

Puppy2016

Member
Dec 16, 2016
26
7
Hi,

there is a reproducible bug confirmed by many users (I can not post link yet) on release (no Insider Preview) Redstone 1 build. After hard reset, live tiles of Outlook Mail and Calendar apps no longer updates. No new versions of the app helps, no unpin/pin of tiles, no regular monthly update to a new Windows build. The only known fix is to use the WDRT tool and load any pre-Redstone 1 build (while available) and then update to recent Windows version. In case of older Lumia phone it means to restore Windows 8.1 and go through the whole Windows 10 upgrade process. Just because of a minor bug in Outlook Mail and Calendar app after hard reset procedure :(

Since there is no effective way to report bug to Microsoft (nobody reads Technet posts nor Feedback app reports) I am trying to fix it myself. Some users indicates the bug persists in Insider builds as well.

I belive the issue is just a missing/wrong registry entry that can be fixed manually or better if there was a way to completely remove the Outlook Mail and Calendar app and reinstall it again. I think I can get some tips here :)

Thanks.
 
Last edited:

gus33000

Senior Member
Aug 9, 2016
452
587
Bordeaux
Hi,

there is a reproducible bug confirmed by many users (I can not post link yet) on release (no Insider Preview) Redstone 1 build. After hard reset, live tiles of Outlook Mail and Calendar apps no longer updates. No new versions of the app helps, no unpin/pin of tiles, no regular monthly update to a new Windows build. The only known fix is to use the WDRT tool and load any pre-Redstone 1 build (while available) and then update to recent Windows version. In case of older Lumia phone it means to restore Windows 8.1 and go through the whole Windows 10 upgrade process. Just because of a minor bug in Outlook Mail and Calendar app after hard reset procedure :(

Since there is no effective way to report bug to Microsoft (nobody reads Technet posts nor Feedback app reports) I am trying to fix it myself. Some users indicates the bug persists in Insider builds as well.

I belive the issue is just a missing/wrong registry entry that can be fixed manually or better if there was a way to completely remove the Outlook Mail and Calendar app and reinstall it again. I think I can get some tips here :)

Thanks.

The issue is actually just the recent outlook apps being buggy and that doesn't actually update the tiles properly. Nothing can be done about this. If you want to uninstall them anyway Interop Tools can do that via the Application manager (only in 1.9 pre-releases)
 

Puppy2016

Member
Dec 16, 2016
26
7
The issue is actually just the recent outlook apps being buggy and that doesn't actually update the tiles properly.
Please read my post carefully. It works without any problem until first hard reset, the issue started in Redstone 1 regardless of the Mail and Calendar app version. I just want to revert it back to the same state before the hard reset that always breaks it somehow, to prevent the complicated WDRT procedure currently known as the only fix.

I am .NET developer of PC apps but I have no knowledge of mobile OS, that's why I am asking here:

  • My idea is to export registry when it works (repaired system by the WDRT procedure) and then after the hard reset when it breaks and compare it.
  • Is there something similar to Event Log in PC Windows ? It might have some error events related to the broken live tiles update.
  • Or is there anything else I can do to diagnose it ?
It seems as the live tile notification channel setup is corrupted after the hard reset because the tile content updates when resized manually only.

Again, there is no live tile update issue until the hard reset has been performed on the device.

Thanks.
 
Last edited:

gus33000

Senior Member
Aug 9, 2016
452
587
Bordeaux
Please read my post carefully. It works without any problem until first hard reset, the issue started in Redstone 1 regardless of the Mail and Calendar app version. I just want to revert it back to the same state before the hard reset that always breaks it somehow, to prevent the complicated WDRT procedure currently known as the only fix.

I am .NET developer of PC apps but I have no knowledge of mobile OS, that's why I am asking here:

  • My idea is to export registry when it works (repaired system by the WDRT procedure) and then after the hard reset when it breaks and compare it.
  • Is there something similar to Event Log in PC Windows ? It might have some error events related to the broken live tiles update.
  • Or is there anything else I can do to diagnose it ?
It seems as the live tile notification channel setup is corrupted after the hard reset because the tile content updates when resized manually only.

Again, there is no live tile update issue until the hard reset has been performed on the device.

Thanks.

I read your post carefully, that's why I also added how you can uninstall the app if needed, but that issue won't get solved easily. It's due to a new version of outlook which has a known bug with live tiles. It does work for a short period of time but not permanently. The registry doesn't contain any data related to live tiles, what you're looking for is ESED databases. Which are actually files stored on disk. To clean them, you need to uninstall the concerned app.
 
  • Like
Reactions: Luxon and Puppy2016

Puppy2016

Member
Dec 16, 2016
26
7
It's due to a new version of outlook which has a known bug with live tiles. It does work for a short period of time but not permanently.
Ok, I will try the uninstall first.

As for the issue you wrote about, I have heard about it but I can not confirm it. I have two phones and both of them have the live tiles working for months without single problem, regardless of regular updates.

The issue I am trying to resolve is completely different than that one, believe me :) After hard reset on Redstone 1 build, both Mail and Calendar live tiles stops working immediately and remains dead forever.

The issue is always reproducible no random or temporary behavior: New phone -> First Redstone update (tiles always works) -> another update of Windows or apps to recent version (tiles always works) -> Hard reset (tiles are broken) -> WDRT recovery to a pre-Redstone 1 build (tiles always works again) -> another update of Windows or apps to recent Redstone 1 version (tiles still always works) -> Hard reset (tiles are broken again) -> WDRT ... and so on. 100% reproducible issue.
 
Last edited:

ic3man81

Senior Member
Dec 19, 2016
64
8
near Warsaw
Ok, I will try the uninstall first.

As for the issue you wrote about, I have heard about it but I can not confirm it. I have two phones and both of them have the live tiles working for months without single problem, regardless of regular updates.

The issue I am trying to resolve is completely different than that one, believe me :) After hard reset on Redstone 1 build, both Mail and Calendar live tiles stops working immediately and remains dead forever.

The issue is always reproducible no random or temporary behavior: New phone -> First Redstone update (tiles always works) -> another update of Windows or apps to recent version (tiles always works) -> Hard reset (tiles are broken) -> WDRT recovery to a pre-Redstone 1 build (tiles always works again) -> another update of Windows or apps to recent Redstone 1 version (tiles still always works) -> Hard reset (tiles are broken again) -> WDRT ... and so on. 100% reproducible issue.

It really a shame tah such a minor bug is still here. I hade it multiple times and have it now.
I've tried to clean app data to revert it to post installation state but it didn't worked.
---------------------------------------------------------------------------------------------
As @gus33000 advised i removed calendar and outlook with Interop app manager. After that i rebooted the phone and installed it again from store.
For now it is working OK.
I will report here after some more testing.
 
Last edited:
  • Like
Reactions: Puppy2016

ic3man81

Senior Member
Dec 19, 2016
64
8
near Warsaw
On today morning the date on calendar tile has switched normally (finally it didn't stuck like it was earlier after passing midnight)
 

ic3man81

Senior Member
Dec 19, 2016
64
8
near Warsaw
What must be deleted through the Interop app a manager? There is no calendar and outlook app!!!

I've attached you a screenshot but its in polish so there are 3 entries (near the end of the list) literally "Outlook program mail and calendar accounts".
I've removed one of tchem and the other two dissapeared.
 

Attachments

  • wp_ss_20161226_0001.png
    wp_ss_20161226_0001.png
    137.3 KB · Views: 1,638
  • Like
Reactions: Andrew082

Luxon

Senior Member
Feb 19, 2011
107
4
St. Petersburg
Gentlemen, I am experiencing the same issue with Outlook Mail live tile, it stopped updating suddenly.

However, the case is quite different: this happens on a brand new Lumia 650. This phone had never been reset.

I have Interop Tools RC 1.9.390.0, but I don't see the Application Manager tool there. Is it because Lumias X50 are not supported?

Any solution to reinstall Microsoft Outlook on Lumia 550/650/950? Thanks.

Thanks.
 

ic3man81

Senior Member
Dec 19, 2016
64
8
near Warsaw
Unpin from start, repin.
This is not he solution.

Gentlemen, I am experiencing the same issue with Outlook Mail live tile, it stopped updating suddenly.

However, the case is quite different: this happens on a brand new Lumia 650. This phone had never been reset.

I have Interop Tools RC 1.9.390.0, but I don't see the Application Manager tool there. Is it because Lumias X50 are not supported?

Any solution to reinstall Microsoft Outlook on Lumia 550/650/950? Thanks.

Thanks.

I think that fo x5x series you would have to wait until Redstone 2 comes out which as reported has the ability to remove stock apps.
 

marianodelfino

Senior Member
Apr 30, 2015
270
70
Hi,

there is a reproducible bug confirmed by many users (I can not post link yet) on release (no Insider Preview) Redstone 1 build. After hard reset, live tiles of Outlook Mail and Calendar apps no longer updates. No new versions of the app helps, no unpin/pin of tiles, no regular monthly update to a new Windows build. The only known fix is to use the WDRT tool and load any pre-Redstone 1 build (while available) and then update to recent Windows version. In case of older Lumia phone it means to restore Windows 8.1 and go through the whole Windows 10 upgrade process. Just because of a minor bug in Outlook Mail and Calendar app after hard reset procedure :(

Since there is no effective way to report bug to Microsoft (nobody reads Technet posts nor Feedback app reports) I am trying to fix it myself. Some users indicates the bug persists in Insider builds as well.

I belive the issue is just a missing/wrong registry entry that can be fixed manually or better if there was a way to completely remove the Outlook Mail and Calendar app and reinstall it again. I think I can get some tips here :)

Thanks.

There is a tool in rs2 for this, you can enter the desire app and reset it.

Source

If you don't want to update to Rs2, the other solution could be using interop tools to uninstall the apps and install them again from the store, in case the apps are not in the store then ask for appxs on the forum and sideload them
 
Last edited:

[email protected]

New member
Nov 26, 2017
1
0
which windows update carry "Mail and Calendar" app. Because at beginning it was not there but after some update installation it appear on my windows but then it start crashing. never start about two month ago.
i uninstalled it from windows but when i tried to reinstall it from "Windows App Store" its says can't not download, we will try again shortly. but came back with same results.


any suggestion will be highly appreciated.
 

james.h.huddle

New member
Dec 4, 2017
1
0
Hard Reset isn't an option for someone like me, who has the device in a hard-core day to day extreme production business environment. Anyone have another solution to the Outlook Mail and Calendar issue? I am having the exact same identical download issue. Much appreciated in advance. [email protected]
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hi,

    there is a reproducible bug confirmed by many users (I can not post link yet) on release (no Insider Preview) Redstone 1 build. After hard reset, live tiles of Outlook Mail and Calendar apps no longer updates. No new versions of the app helps, no unpin/pin of tiles, no regular monthly update to a new Windows build. The only known fix is to use the WDRT tool and load any pre-Redstone 1 build (while available) and then update to recent Windows version. In case of older Lumia phone it means to restore Windows 8.1 and go through the whole Windows 10 upgrade process. Just because of a minor bug in Outlook Mail and Calendar app after hard reset procedure :(

    Since there is no effective way to report bug to Microsoft (nobody reads Technet posts nor Feedback app reports) I am trying to fix it myself. Some users indicates the bug persists in Insider builds as well.

    I belive the issue is just a missing/wrong registry entry that can be fixed manually or better if there was a way to completely remove the Outlook Mail and Calendar app and reinstall it again. I think I can get some tips here :)

    Thanks.
    2
    Please read my post carefully. It works without any problem until first hard reset, the issue started in Redstone 1 regardless of the Mail and Calendar app version. I just want to revert it back to the same state before the hard reset that always breaks it somehow, to prevent the complicated WDRT procedure currently known as the only fix.

    I am .NET developer of PC apps but I have no knowledge of mobile OS, that's why I am asking here:

    • My idea is to export registry when it works (repaired system by the WDRT procedure) and then after the hard reset when it breaks and compare it.
    • Is there something similar to Event Log in PC Windows ? It might have some error events related to the broken live tiles update.
    • Or is there anything else I can do to diagnose it ?
    It seems as the live tile notification channel setup is corrupted after the hard reset because the tile content updates when resized manually only.

    Again, there is no live tile update issue until the hard reset has been performed on the device.

    Thanks.

    I read your post carefully, that's why I also added how you can uninstall the app if needed, but that issue won't get solved easily. It's due to a new version of outlook which has a known bug with live tiles. It does work for a short period of time but not permanently. The registry doesn't contain any data related to live tiles, what you're looking for is ESED databases. Which are actually files stored on disk. To clean them, you need to uninstall the concerned app.
    1
    Ok, I will try the uninstall first.

    As for the issue you wrote about, I have heard about it but I can not confirm it. I have two phones and both of them have the live tiles working for months without single problem, regardless of regular updates.

    The issue I am trying to resolve is completely different than that one, believe me :) After hard reset on Redstone 1 build, both Mail and Calendar live tiles stops working immediately and remains dead forever.

    The issue is always reproducible no random or temporary behavior: New phone -> First Redstone update (tiles always works) -> another update of Windows or apps to recent version (tiles always works) -> Hard reset (tiles are broken) -> WDRT recovery to a pre-Redstone 1 build (tiles always works again) -> another update of Windows or apps to recent Redstone 1 version (tiles still always works) -> Hard reset (tiles are broken again) -> WDRT ... and so on. 100% reproducible issue.

    It really a shame tah such a minor bug is still here. I hade it multiple times and have it now.
    I've tried to clean app data to revert it to post installation state but it didn't worked.
    ---------------------------------------------------------------------------------------------
    As @gus33000 advised i removed calendar and outlook with Interop app manager. After that i rebooted the phone and installed it again from store.
    For now it is working OK.
    I will report here after some more testing.
    1
    What must be deleted through the Interop app a manager? There is no calendar and outlook app!!!

    I've attached you a screenshot but its in polish so there are 3 entries (near the end of the list) literally "Outlook program mail and calendar accounts".
    I've removed one of tchem and the other two dissapeared.
    1
    Unpin from start, repin.