• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question Is there a way to use VoLTE and VoWIFI with swiss providers?

Search This thread

skyzonemc

New member
Mar 14, 2020
4
0
My Nord 2 isnt using VOLTE or VOWIFI with Sunrise. Is there a way to enable it like with older models?
 

LittleW0lf

Member
Aug 25, 2017
17
1
My Nord 2 isnt using VOLTE or VOWIFI with Sunrise. Is there a way to enable it like with older models?

Hey,
If you go on the digitec website and search for your phone, you get a disclairmer about 5G and Sunrise. This isn't strictly related to your issue, but I was wondering if you were able to use the Swiss 5G network with your phone. Maybe you can try calling sunrise directly ?
 

cerfaaa

New member
Apr 9, 2020
3
3
VoLTE activation procedure on OnePlus Nord 2 5G:

If NoRoot:
1. Get ready to use the adb command
2. adb reboot recovery And reboot to recovery
3. When the language selection screen appears, you will be able to connect to adb, so wait until the driver setup is completed.
* If ⚠ is displayed in the device manager, the driver cannot be loaded, so right-click and see Update Driver → Computer. Search for the driver → Available on your computer ~ → Android Device → Load the Android Composite ADB Interface.
If that doesn't work, try plugging and unplugging the cable or using the USB 2.0 port.
4. Execute the following command line by line
adb root
adb shell setprop persist.dbg.ims_volte_enable 1
adb shell setprop persist.dbg.volte_avail_ovr 1
adb shell setprop persist.dbg.vt_avail_ovr 1
adb shell setprop persist.radio.VT_ENABLE 1
adb reboot

After restarting, "VoLTE call" will appear in the SIM settings, so turn it on.

If Rooted:
1. Install Termux from GP
2. Enter "su"
3.
setprop persist.dbg.ims_volte_enable 1
setprop persist.dbg.volte_avail_ovr 1
setprop persist.dbg.vt_avail_ovr 1
setprop persist.radio.VT_ENABLE 1
setprop persist.dbg.wfc_avail_ovr 1
reboot
 
  • Like
Reactions: skyzonemc

skyzonemc

New member
Mar 14, 2020
4
0
VoLTE activation procedure on OnePlus Nord 2 5G:

If NoRoot:
1. Get ready to use the adb command
2. adb reboot recovery And reboot to recovery
3. When the language selection screen appears, you will be able to connect to adb, so wait until the driver setup is completed.
* If ⚠ is displayed in the device manager, the driver cannot be loaded, so right-click and see Update Driver → Computer. Search for the driver → Available on your computer ~ → Android Device → Load the Android Composite ADB Interface.
If that doesn't work, try plugging and unplugging the cable or using the USB 2.0 port.
4. Execute the following command line by line
adb root
adb shell setprop persist.dbg.ims_volte_enable 1
adb shell setprop persist.dbg.volte_avail_ovr 1
adb shell setprop persist.dbg.vt_avail_ovr 1
adb shell setprop persist.radio.VT_ENABLE 1
adb reboot

After restarting, "VoLTE call" will appear in the SIM settings, so turn it on.

If Rooted:
1. Install Termux from GP
2. Enter "su"
3.
setprop persist.dbg.ims_volte_enable 1
setprop persist.dbg.volte_avail_ovr 1
setprop persist.dbg.vt_avail_ovr 1
setprop persist.radio.VT_ENABLE 1
setprop persist.dbg.wfc_avail_ovr 1
reboot
Worked! Thank you
 

aathi1

New member
Feb 4, 2012
3
0
VoLTE activation procedure on OnePlus Nord 2 5G:

If NoRoot:
1. Get ready to use the adb command
2. adb reboot recovery And reboot to recovery
3. When the language selection screen appears, you will be able to connect to adb, so wait until the driver setup is completed.
* If ⚠ is displayed in the device manager, the driver cannot be loaded, so right-click and see Update Driver → Computer. Search for the driver → Available on your computer ~ → Android Device → Load the Android Composite ADB Interface.
If that doesn't work, try plugging and unplugging the cable or using the USB 2.0 port.
4. Execute the following command line by line
adb root
adb shell setprop persist.dbg.ims_volte_enable 1
adb shell setprop persist.dbg.volte_avail_ovr 1
adb shell setprop persist.dbg.vt_avail_ovr 1
adb shell setprop persist.radio.VT_ENABLE 1
adb reboot

After restarting, "VoLTE call" will appear in the SIM settings, so turn it on.

If Rooted:
1. Install Termux from GP
2. Enter "su"
3.
setprop persist.dbg.ims_volte_enable 1
setprop persist.dbg.volte_avail_ovr 1
setprop persist.dbg.vt_avail_ovr 1
setprop persist.radio.VT_ENABLE 1
setprop persist.dbg.wfc_avail_ovr 1
reboot
Do you know how to enable 5g? my phone doesn't seem to connect to any 5g network. 5g is not shown as an option in sim settings.
 

jlwood92

Senior Member
Feb 13, 2015
52
10
OnePlus Nord 2 5G
VoLTE activation procedure on OnePlus Nord 2 5G:

If NoRoot:
1. Get ready to use the adb command
2. adb reboot recovery And reboot to recovery
3. When the language selection screen appears, you will be able to connect to adb, so wait until the driver setup is completed.
* If ⚠ is displayed in the device manager, the driver cannot be loaded, so right-click and see Update Driver → Computer. Search for the driver → Available on your computer ~ → Android Device → Load the Android Composite ADB Interface.
If that doesn't work, try plugging and unplugging the cable or using the USB 2.0 port.
4. Execute the following command line by line
adb root
adb shell setprop persist.dbg.ims_volte_enable 1
adb shell setprop persist.dbg.volte_avail_ovr 1
adb shell setprop persist.dbg.vt_avail_ovr 1
adb shell setprop persist.radio.VT_ENABLE 1
adb reboot

After restarting, "VoLTE call" will appear in the SIM settings, so turn it on.

If Rooted:
1. Install Termux from GP
2. Enter "su"
3.
setprop persist.dbg.ims_volte_enable 1
setprop persist.dbg.volte_avail_ovr 1
setprop persist.dbg.vt_avail_ovr 1
setprop persist.radio.VT_ENABLE 1
setprop persist.dbg.wfc_avail_ovr 1
reboot
Thanks for the info. Do you know how to enable voWifi (WiFi Calling) for Vodafone UK?
 

DerSandmann

Senior Member
Aug 15, 2010
70
4
Lausanne
Do you know how to enable 5g? my phone doesn't seem to connect to any 5g network. 5g is not shown as an option in sim settings.
Hi, I had the same problem. Usually you can do this with *#*#4636#*#* to access the phone info but those codes don't work on this phone.

I installed an app called "5G switch" (not sponsored by any means), then you can access the menu, and selected NR/LTE/TDSCDMA/GSM/WCDMA, which makes 5G appear in the settings, and works with Yallo (Sunrise) as a carrier. Hope it helps!
 

aathi1

New member
Feb 4, 2012
3
0
Hi, I had the same problem. Usually you can do this with *#*#4636#*#* to access the phone info but those codes don't work on this phone.

I installed an app called "5G switch" (not sponsored by any means), then you can access the menu, and selected NR/LTE/TDSCDMA/GSM/WCDMA, which makes 5G appear in the settings, and works with Yallo (Sunrise) as a carrier. Hope it helps!
I have tried that but it does not work for me. Even though I selected the NR/LTE.. it still hooks onto 4g. are you aware of any methods to modify the radio files.. Thnx.
 

Kublyker

Member
Jul 17, 2018
5
0
VoLTE activation procedure on OnePlus Nord 2 5G:

If NoRoot:
1. Get ready to use the adb command
2. adb reboot recovery And reboot to recovery
3. When the language selection screen appears, you will be able to connect to adb, so wait until the driver setup is completed.
* If ⚠ is displayed in the device manager, the driver cannot be loaded, so right-click and see Update Driver → Computer. Search for the driver → Available on your computer ~ → Android Device → Load the Android Composite ADB Interface.
If that doesn't work, try plugging and unplugging the cable or using the USB 2.0 port.
4. Execute the following command line by line
adb root
adb shell setprop persist.dbg.ims_volte_enable 1
adb shell setprop persist.dbg.volte_avail_ovr 1
adb shell setprop persist.dbg.vt_avail_ovr 1
adb shell setprop persist.radio.VT_ENABLE 1
adb reboot

After restarting, "VoLTE call" will appear in the SIM settings, so turn it on.

If Rooted:
1. Install Termux from GP
2. Enter "su"
3.
setprop persist.dbg.ims_volte_enable 1
setprop persist.dbg.volte_avail_ovr 1
setprop persist.dbg.vt_avail_ovr 1
setprop persist.radio.VT_ENABLE 1
setprop persist.dbg.wfc_avail_ovr 1
reboot
Hi,

This method didn't work for me (although I have to mention that the VoLTE toggle was present in the SIM settings since first use).
I'm currently on a Dutch provider called hollandsenieuwe which operates on Vodafone NL network.
The strange thing is that VoWiFi just works fine since first use.
I checked all the settings for VoLTE (even the one for the icon to appear in the top bar which is disabled by default but nothing).
Asked support to the provider but they just say that the issue is with the device.
I tested with the previous model Oneplus Nord 5G and VoLTE and VoWIFI both work fine, with Oneplus Nord 2 only VoWiFI is working.

Any suggestion?
 

Pouic

Senior Member
Aug 9, 2010
242
197
No solution for now, we need to wait for oneplus to add the missing 5g/volte profiles in a next OTA... it could take a while or simply never arrive .
 

dacuk

New member
Nov 5, 2007
4
0
What commands should be entered instead of these to
setprop persist.dbg.ims_volte_enable 1
setprop persist.dbg.volte_avail_ovr 1
setprop persist.dbg.vt_avail_ovr 1
setprop persist.radio.VT_ENABLE 1
setprop persist.dbg.wfc_avail_ovr 1
everything as it was? I think the reason they lost wifi and bluetooth. They don't turn on at all...
 

Pouic

Senior Member
Aug 9, 2010
242
197
A.15 update finally did it, since this morning I have 5G and VolTE working on my phone on swiss networks!
 

PabloAndresB

New member
Dec 29, 2021
1
0
VoLTE activation procedure on OnePlus Nord 2 5G:

If NoRoot:
1. Get ready to use the adb command
2. adb reboot recovery And reboot to recovery
3. When the language selection screen appears, you will be able to connect to adb, so wait until the driver setup is completed.
* If ⚠ is displayed in the device manager, the driver cannot be loaded, so right-click and see Update Driver → Computer. Search for the driver → Available on your computer ~ → Android Device → Load the Android Composite ADB Interface.
If that doesn't work, try plugging and unplugging the cable or using the USB 2.0 port.
4. Execute the following command line by line
adb root
adb shell setprop persist.dbg.ims_volte_enable 1
adb shell setprop persist.dbg.volte_avail_ovr 1
adb shell setprop persist.dbg.vt_avail_ovr 1
adb shell setprop persist.radio.VT_ENABLE 1
adb reboot

After restarting, "VoLTE call" will appear in the SIM settings, so turn it on.

If Rooted:
1. Install Termux from GP
2. Enter "su"
3.
setprop persist.dbg.ims_volte_enable 1
setprop persist.dbg.volte_avail_ovr 1
setprop persist.dbg.vt_avail_ovr 1
setprop persist.radio.VT_ENABLE 1
setprop persist.dbg.wfc_avail_ovr 1
reboot
Hi master, greetings from Chile. Sorry for my ignorance. I don't understand step 2. Would you please explain to me. I'm a dumb. Sorry🥲
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    VoLTE activation procedure on OnePlus Nord 2 5G:

    If NoRoot:
    1. Get ready to use the adb command
    2. adb reboot recovery And reboot to recovery
    3. When the language selection screen appears, you will be able to connect to adb, so wait until the driver setup is completed.
    * If ⚠ is displayed in the device manager, the driver cannot be loaded, so right-click and see Update Driver → Computer. Search for the driver → Available on your computer ~ → Android Device → Load the Android Composite ADB Interface.
    If that doesn't work, try plugging and unplugging the cable or using the USB 2.0 port.
    4. Execute the following command line by line
    adb root
    adb shell setprop persist.dbg.ims_volte_enable 1
    adb shell setprop persist.dbg.volte_avail_ovr 1
    adb shell setprop persist.dbg.vt_avail_ovr 1
    adb shell setprop persist.radio.VT_ENABLE 1
    adb reboot

    After restarting, "VoLTE call" will appear in the SIM settings, so turn it on.

    If Rooted:
    1. Install Termux from GP
    2. Enter "su"
    3.
    setprop persist.dbg.ims_volte_enable 1
    setprop persist.dbg.volte_avail_ovr 1
    setprop persist.dbg.vt_avail_ovr 1
    setprop persist.radio.VT_ENABLE 1
    setprop persist.dbg.wfc_avail_ovr 1
    reboot
    1
    Sorry, I don’t know.