• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ISSUE][SOLVED] “Free” Wifi Tether forbidden since Android 4.1.2

Search This thread

furius

Senior Member
Sep 6, 2009
380
56
R: [ISSUE] “Free” Wifi Tether forbidden since Android 4.1.2

Hahahaha, yeah!

But....I think we can locate that patch and make a custom kernel (I think the patch is there) or recompile our favorite rom. BTW we have to find where is that piece of code! :D

... Do you have an idea on how to do it? Maybe a logcat can help? I can't reproduce the issue because I also disabled the web.omnitel.it APN with Vodafone...

We probably need a kernel developer... Should we ask Franco?

Sent from my Galaxy Nexus using Tapatalk 2
 

stinky73

Senior Member
Aug 28, 2010
374
116
Courchevel
Re: [ISSUE] “Free” Wifi Tether forbidden since Android 4.1.2

OK ...
It seems that we ( Italian Vodafone users) are the only "sfigati" affected by this issue! Really sad ...

Sent from my Galaxy Nexus using Tapatalk 2

Orange France also now uses the "flag" to block tethering. Like others with the same problem I can tether with 4.1.1 but 4.1.2 and 4.2 put up the flag. I just rang orange France and they asked for 29€ a month to enable use of tethering. The tech was surprised that I could tether under 4.1.1 but then told me that if it didn't flag the use of tethering then the best thing would be to go back to it. I didn't tell him I already had.

Shame cos I use it a lot for work but prefer the features and battery life of 4.2 - plus, we all want the latest and most up to date firmware for our lovely Gnex... but unless somebody cleverer than me can work out how this flag is added to the data request we are stuck with old software if we want to use tethering!

Ciao my transalpine neighbours :)

Sent from Galaxy 10.1 I/O running AOKP 4.1.2 Still going stronger and faster than yer average tab!
 
Last edited:

furius

Senior Member
Sep 6, 2009
380
56
R: [ISSUE] “Free” Wifi Tether forbidden since Android 4.1.2

Excellent news for those getting this issue!

Type this command from terminal emulator (root required):

su -c "iptables -tnat -A natctrl_nat_POSTROUTING -s 192.168.0.0/16 -o rmnet0 -j MASQUERADE"

Found solution here:
http://code.google.com/p/android/issues/detail?id=38563

Worked for me on Xylon ROM
;)

Sent from my Galaxy Nexus using Tapatalk 2
 

Mrc527

Senior Member
Mar 28, 2011
171
94
Milan
www.kernel-xp.net
Excellent news for those getting this issue!

Type this command from terminal emulator (root required):

su -c "iptables -tnat -A natctrl_nat_POSTROUTING -s 192.168.0.0/16 -o rmnet0 -j MASQUERADE"

Found solution here:
http://code.google.com/p/android/issues/detail?id=38563

Worked for me on Xylon ROM
;)

Sent from my Galaxy Nexus using Tapatalk 2

Great! But.....does not work, for me. :(

What procedure do you follow? First enable tethering, then this command and then connect all the clients? (My pc in this case)
 

furius

Senior Member
Sep 6, 2009
380
56
R: [ISSUE] “Free” Wifi Tether forbidden since Android 4.1.2

Great! But.....does not work, for me. :(

What procedure do you follow? First enable tethering, then this command and then connect all the clients? (My pc in this case)

I typed reported command on terminal emulator, then I activated the built in hotspot and finally I was able to connect my tablet! It seems that the command must be excuted at every reboot, but it shouldn't be difficult to setup a script that runs at phone startup ...
Wich ROM are you running?

Sent from my GT-P6810 using Tapatalk HD
 

furius

Senior Member
Sep 6, 2009
380
56
R: [ISSUE] “Free” Wifi Tether forbidden since Android 4.1.2

From the Google thread linked previously:

How to have it working : Stop the Wifi, go on internet and look at your IP. In adb, do netcfg. It will show you a line like that : vsnet0 UP 10.95.95.175/32 0x000010d1 00:00:00:

So, here, vsnet0 is the interface.

Just after, do su -c "iptables -tnat -A natctrl_nat_POSTROUTING -s 192.168.0.0/16 -o [INTERFACE] -j MASQUERADE"

it seems that the interface may change ... For me was OK the value rmnet0 , check your and try again ...

Sent from my Galaxy Nexus using Tapatalk 2
 

furius

Senior Member
Sep 6, 2009
380
56
R: [ISSUE] “Free” Wifi Tether forbidden since Android 4.1.2

Excellent news for those getting this issue!

Type this command from terminal emulator (root required):

su -c "iptables -tnat -A natctrl_nat_POSTROUTING -s 192.168.0.0/16 -o rmnet0 -j MASQUERADE"

Found solution here:
http://code.google.com/p/android/issues/detail?id=38563

Worked for me on Xylon ROM
;)

Sent from my Galaxy Nexus using Tapatalk 2

I can confirm that this method is working perfectly also on last 4.2.2 build :cool:


Sent from my GT-P6810 using Tapatalk HD
 

gibbsrob

Senior Member
Dec 26, 2010
87
33
Lakewood, OH
I don't pay for tethering on my T-mobile US plan but tethering never stopped working since 4.0 versions all the way now to 4.2.1 takju.
I have a pre-pay plan, so the carrier is not able to charge me anything extra, all they could do is shut off my data plan or tethering, which they never did.

Edit: I'm not rooted in version 4.2.1. I was rooted in some of the previous versions, but can't remember which ones.

T-Mobile allow FREE tethering on all of their plans except Unlimited Plan. If you have the Unlimited plan you have to pay for the feature or use an APN blocker of Browser odd on to block T-Mo from detecting it.
 

furius

Senior Member
Sep 6, 2009
380
56
So did anybody ever make a script?
What us everybody doing for tethering?

I'm using "Script Manager - SManager" app:
- Create a txt file with any text editor (I used Jota, my favorite txt editor), enter the correct script and save the file on your sdcard.
- Then open SManager, long tap on your script file and select "open as" --> "script/executable".
- Now add "Su" and "Boot" options, save and you are ok. Your script will run with SU permission at every reboot.

Enjoy your tethering!
 

Attachments

  • Screenshot_2013-03-13-08-02-27.jpg
    Screenshot_2013-03-13-08-02-27.jpg
    21.9 KB · Views: 2,355
  • Screenshot_2013-03-13-08-04-46.jpg
    Screenshot_2013-03-13-08-04-46.jpg
    27.6 KB · Views: 2,007

networktoday

New member
Mar 17, 2013
1
0
This issue probably requires Developer actions to be solved … anyway I’m posting on General section cause it’s not a properly developer thread …

Since Android 4.1.2 there’s a problem in tethering for all people that has a carrier plan that doesn’t include Tethering. I’m on Vodafone Italy with “mobile internet” plan (2GB/month). I have never had problem with tethering my data connection from my phone to a laptop or tablet but starting from Android 4.1.2 upgrade I noticed that when I activate built in wifi hotspot the APN is automatically and secretly changed from the default one (mobile.vodafone.it) to a new one (web.omnitel.it) that charges my bill with additional costs … It happened to me in the past using branded phone with branded firmware, but after rooting and switching to CyanogeMod firmware the problem was solved … now I’m on an unlocked Galaxy Nexus with CM or others custom ROM …

On 4.1.2 I bypassed this problem using dedicated app “Wifi Tether for Root”, but now on 4.2.1 also this app doesn’t work anymore (ok this is another issue, here you can find more details).

Well … rather bad … I did a lot of research on the web, and here is the most interesting thing I found:

A person working for Roger carrier stated this (see original thread and full post here ):



So, can someone confirm this behavior? Is there some Developer that can intercept the section of Android OS code that apply this flag to the data download and find the way to avoid this annoying issue??
I want to tether again without pay additional money! I’m paying for 2GB/month! What do you care, Vodafone, how I use it??

Thanks in advance!

EDIT: SOLVED!
After some time someone found a solution, at least for all users with ROOT:
Here is the solution script
Here is a method to setup the script on boot

.

Hi Furius,
i'm on vodafone Italy, also. I'm using a single APN, with mobile.vodafone.it and APN's Type: default, supl
Is that correct? Are you using still this settings?Let me know. Thx in advance for your help.
 

furius

Senior Member
Sep 6, 2009
380
56
R: [ISSUE][SOLVED] “Free” Wifi Tether forbidden since Android 4.1.2

Hi Furius,
i'm on vodafone Italy, also. I'm using a single APN, with mobile.vodafone.it and APN's Type: default, supl
Is that correct? Are you using still this settings?Let me know. Thx in advance for your help.

Same settings here. If you have root, you shouldn't have problems!

Sent from my Galaxy Nexus using Tapatalk 2
 

Automate

New member
Jun 25, 2009
1
0
I'm using "Script Manager - SManager" app:
- Create a txt file with any text editor (I used Jota, my favorite txt editor), enter the correct script and save the file on your sdcard.
- Then open SManager, long tap on your script file and select "open as" --> "script/executable".
- Now add "Su" and "Boot" options, save and you are ok. Your script will run with SU permission at every reboot.

Enjoy your tethering!
Does this work with Droid Razr?
 

ZapBeeb

Member
Mar 29, 2012
5
0
Hello everyone.
I am trying to determine if my problem is the same all you addressed here.

I have a Gnex 4.2.2, it's quite new, so i didn't try to use the wi-fi hotspot on earlier versions of the software.

I am on Vodafone Italy (f--- yeah! :D) and if i activate the native hotspot, my laptop simply does not connect to it.
It says that the network password is not correct, which of course isn't true, and even if i leave the network unprotected, it does not manage to connect to it.

I did not try with other devices (i.e. another phone) a thing that i now realize i should have done.

I was wondering if this happens because on my data plan (i am a business user) they may have chosen to block all the tethering traffic rather than send it through the infamous pay-to-tether APN.
 

furius

Senior Member
Sep 6, 2009
380
56
R: [ISSUE][SOLVED] “Free” Wifi Tether forbidden since Android 4.1.2

Hello everyone.
I am trying to determine if my problem is the same all you addressed here.

I have a Gnex 4.2.2, it's quite new, so i didn't try to use the wi-fi hotspot on earlier versions of the software.

I am on Vodafone Italy (f--- yeah! :D) and if i activate the native hotspot, my laptop simply does not connect to it.
It says that the network password is not correct, which of course isn't true, and even if i leave the network unprotected, it does not manage to connect to it.

I did not try with other devices (i.e. another phone) a thing that i now realize i should have done.

I was wondering if this happens because on my data plan (i am a business user) they may have chosen to block all the tethering traffic rather than send it through the infamous pay-to-tether APN.

It seems that tether is locked and not included on your carrier plan. Maybe ask confirmation to Vodafone.

If you have root, above procedure let you tether using default APN...

Sent from my Galaxy Nexus using Tapatalk 2
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    This issue probably requires Developer actions to be solved … anyway I’m posting on General section cause it’s not a properly developer thread …

    Since Android 4.1.2 there’s a problem in tethering for all people that has a carrier plan that doesn’t include Tethering. I’m on Vodafone Italy with “mobile internet” plan (2GB/month). I have never had problem with tethering my data connection from my phone to a laptop or tablet but starting from Android 4.1.2 upgrade I noticed that when I activate built in wifi hotspot the APN is automatically and secretly changed from the default one (mobile.vodafone.it) to a new one (web.omnitel.it) that charges my bill with additional costs … It happened to me in the past using branded phone with branded firmware, but after rooting and switching to CyanogeMod firmware the problem was solved … now I’m on an unlocked Galaxy Nexus with CM or others custom ROM …

    On 4.1.2 I bypassed this problem using dedicated app “Wifi Tether for Root”, but now on 4.2.1 also this app doesn’t work anymore (ok this is another issue, here you can find more details).

    Well … rather bad … I did a lot of research on the web, and here is the most interesting thing I found:

    A person working for Roger carrier stated this (see original thread and full post here ):
    Android 4.1.2 introduced that ability (and requirement) for Android devices to properly flag when data is for tethering purposes. This is the first time this has been used in a vanilla release of Android.
    ...
    For everyone frustrated by this update to Android: Android respecting a carrier's request to know if data is for a tethered device IS NOT A BUG. IT IS A FEATURE. It's not a feature for users like you and me, it's a feature for manufacturers like Samsung and HTC, so they can in turn build devices that carriers can have more control over.

    So, to be clear, THIS IS NOT A BUG. Google INTENDED to respect carrier tethering rules.


    So, can someone confirm this behavior? Is there some Developer that can intercept the section of Android OS code that apply this flag to the data download and find the way to avoid this annoying issue??
    I want to tether again without pay additional money! I’m paying for 2GB/month! What do you care, Vodafone, how I use it??

    Thanks in advance!

    EDIT: SOLVED!
    After some time someone found a solution, at least for all users with ROOT:
    Here is the solution script
    Here is a method to setup the script on boot

    .
    5
    So did anybody ever make a script?
    What us everybody doing for tethering?

    I'm using "Script Manager - SManager" app:
    - Create a txt file with any text editor (I used Jota, my favorite txt editor), enter the correct script and save the file on your sdcard.
    - Then open SManager, long tap on your script file and select "open as" --> "script/executable".
    - Now add "Su" and "Boot" options, save and you are ok. Your script will run with SU permission at every reboot.

    Enjoy your tethering!
    5
    R: [ISSUE] “Free” Wifi Tether forbidden since Android 4.1.2

    Excellent news for those getting this issue!

    Type this command from terminal emulator (root required):

    su -c "iptables -tnat -A natctrl_nat_POSTROUTING -s 192.168.0.0/16 -o rmnet0 -j MASQUERADE"

    Found solution here:
    http://code.google.com/p/android/issues/detail?id=38563

    Worked for me on Xylon ROM
    ;)

    Sent from my Galaxy Nexus using Tapatalk 2
    2
    Ciao Furius!
    I think I'm in the same situation as you with Vodafone Italy :silly:

    I'm running CyanogenMod 10.1 (so Android 4.1.2) with a Samsung Galaxy S2 and can't get the wi-fi thetering work: all seems ok, other devices can see and connect to the hot-spot, but can't get any data from it...

    I thought it was some problems with the nightly builds of CM, but other people are reporting that wi-fi tethering is correctly working.

    Now I read your message while searching some information about the Galaxy Nexus (my Galaxy S2 developed a faulty loudspeaker, and I'm considering to get it repaired under warranty then sell it and buy a Galaxy Nexus, I've found it at 269€) and maybe we have the same problem, but I've got Vodafone to lock the web.omnitel.it APN, to prevent costly surprises...

    I think problems arise with operators that make distinctions between different kinds of APN (like Vodafone Italy with web.omnitel.it and mobile.vodafone.it) and not with the ones that don't care about the APN you use (to my knowledge, TIM Italy doesn't care about the APN you use)

    I'll keep an eye on this topic and let you know if I find some news!

    With Vodafone Italy, even if you force the "mobile.vodafone.it" APN, the one for the mobile phone navigation, you will be charged for tethering, using the 4.2.1 native tethering.

    See this post for more detail.

    BTW, we have to find where google added the "flagging" feature, in the native tethering application.

    Do someone have any idea where to find it?
    1
    Please read forum rules before posting
    Questions go in Q&A
    Thread moved
    Thank you for your cooperation
    Friendly Neighborhood Moderator