Question Issue updating Oxygen OS, please advise

Search This thread

DavidXanatos

Senior Member
Mar 22, 2013
299
155
Vienna
Hello,
I have recently updated my Oneplus 9 Pro to version LE2123_11_C.47, so far so good
but than it wont go further, trying to update to LE2123_11_C.61 fails,
presumably because that one is incremental and I am rooted,
I don't watt c.61 anyways but C.62 as its the newest.
Unfortunately the new UI in C.47 does not offer local upgrade with a zip file anymore.
And anyways where can I get the C.62 zip for me EU model, the download on OPs page does not have a recognizable version scheme so I'm not sure what they are offering there to me.

An other issue I stumbled upon is that when i now try to boot into twrp-3.6.0_11-0-lemonadep.img using fastboot boot ... if freezes and crashes to a qualcom dumper, WTF... is there a more twrp recent version for LE2123_11_C.47 ?

Please advise how to proceed, i would like to update to the newest C.62 lafter perhaps to the Android 13 beta, but lets leave that for later, keep my root and have a working twrp.

so whats the trick with the new versions?
 

DavidXanatos

Senior Member
Mar 22, 2013
299
155
Vienna
password works on normal boot does not work with twrp, also when i google i find a lot of reports about twrp decrypt issues with android 12.
So is there a fix for that?
 

DavidXanatos

Senior Member
Mar 22, 2013
299
155
Vienna
haha success... i have disabled password entierly and in this state twrp could mount /data successfully

PS: fix for the updating issue was to use this "Oxygenos updater" app from the appstore to download and install a custom updater app OPLocalUpdate_For_Android12.apk form oneplus to be able to sellect the downloaded file.

The strange thing is that the current build of android again shows the regular manual update option so no idea why c47 was so messed up :/

but now all is good only question if i should try the beta 13 or if then i have to expect even worse trouble with twrp lol
 

DavidXanatos

Senior Member
Mar 22, 2013
299
155
Vienna
final success... delting /data/fonts solved the backup issue to find what to delete i only needed to review the recovery.log from twrp and look for where it failed