Jabra BT8010 - solution to display caller ID

Search This thread

dtread1

Member
Jul 30, 2004
36
1
0
Portugal
Waiting that WM 6 resolve the problem, with the help of JETware we found a reasonable solution.
1 - Install Jetware v 1.30;
2 – From Settings – Connections – Bluetooth – Devices, delet the paring with Jabra BT8010
3 – Softreset your Advantage;
4 – On your Jabra BT8010 select Settings and Factory Reset;
5 – From your Advantage (connected to ActiveSync or GPRS) go to this link www.jetwaremobile.com/bthfx/Device/Nokia_HS-12W.jcf.
6 - When you download that file from your phone, you should get a prompt asking which paired Bluetooth device the settings should apply to: Choose Jabra BT8010 and Done;
7 – Turn your Jabra BT8010 on, and pair him again with the Advantage, and that’s all.
If you go thru this steps as I sayd, you shold see your Jabra display caller ID (of course if the caller is in your constact list in the Adavantage).

With this solution we have, at least, 2 problems:
1 - In the call list (on Jabra) it stores the name, not the number, so you can't dial using the calll ist;
2 - If you have another bluetoth device (ex: Parrot CK3100) in your car the caller ID in that device may not display.
Dtread1
 
Last edited:

dtread1

Member
Jul 30, 2004
36
1
0
Portugal
Can't get this to work. Any one.......?

After step 7, don't forget:
- In Jabra BT8010 activate the show caller ID option (Settings - Display - Caller ID - ON).
- In JETware settings you should activate the Caller ID (Programs - Bluetooth Options - Hands-Free Config - Menu - Advanced Options).
I forget to mention: I have updated the Jabra software to V 1.33 (I'm not sure if this makes diference...)
 
Last edited:

beginner

Senior Member
Nov 18, 2005
790
9
0
After step 7, don't forget:
- In Jabra BT8010 activate the show caller ID option (Settings - Display - Caller ID - ON).
- In JETware settings you should activate the Caller ID (Programs - Bluetooth Options - Hands-Free Config - Menu - Advanced Options).
I forget to mention: I have updated the Jabra software to V 1.33 (I'm not sure if this makes diference...)

finally I have it working. The fact is when you receive a call you need to push the button of the menu in the jabra and will appear the caller id.

thanks dtread1 for this solution, is great.
 

victoradjei

Senior Member
Nov 8, 2004
1,017
4
58
Can you explain under what circumstance this fix is required? My Jabra BT8010 and Ameo worked perfectly straight out-of-the-box, caller ID and all.


We are looking at displaying of caller names (from your Ameo contacts) when a call comes, and not just the +1234..... thing :cool:
 

spoonter

Senior Member
Jan 6, 2006
59
0
0
London
OK, I see. That would be cool. Good luck!

In the mean time I have used the Jabra Software to set up a phonebook on my earpiece. One thing I noticed though was that I had to omit the +xx part of the phone number otherwise the callerid would not find a match.
 

cayotte

Senior Member
Dec 22, 2004
300
0
0
Pekanbaru
Thanks for giving this long awaited solution to my Jabra BT8010. So far showing contacts on bluetooth headset only working with i.Tech Clip D. Good work, Bro!
 

dtread1

Member
Jul 30, 2004
36
1
0
Portugal
finally I have it working. The fact is when you receive a call you need to push the button of the menu in the jabra and will appear the caller id.

thanks dtread1 for this solution, is great.

Hi beginner:
By default, the Jabra BT8010 doesn't show caller ID.
If you don't want to push the button every time you have an incoming call you must configure the Jabra like this:
(Settings - Display - Caller ID - ON).
 

beginner

Senior Member
Nov 18, 2005
790
9
0
Hi beginner:
By default, the Jabra BT8010 doesn't show caller ID.
If you don't want to push the button every time you have an incoming call you must configure the Jabra like this:
(Settings - Display - Caller ID - ON).

I know, the manual says that but the device doesn't want...
 

faisal.husain

Senior Member
Dec 22, 2004
139
9
0
Hi beginner:
By default, the Jabra BT8010 doesn't show caller ID.
If you don't want to push the button every time you have an incoming call you must configure the Jabra like this:
(Settings - Display - Caller ID - ON).

Hey thanks dtread1 cool it works for me just great! Just wondering though i still have this weird problem that even though i have not selected the stereo option on after a while the bt8010 reverts to this; and all sound is routed through the ear piece. I check the BT settings on the phone and stereo is unchecked but appears to be over ridden by the bt8010. Dont suppose you have a solution for this?
 

dtread1

Member
Jul 30, 2004
36
1
0
Portugal
Hey thanks dtread1 cool it works for me just great! Just wondering though i still have this weird problem that even though i have not selected the stereo option on after a while the bt8010 reverts to this; and all sound is routed through the ear piece. I check the BT settings on the phone and stereo is unchecked but appears to be over ridden by the bt8010. Dont suppose you have a solution for this?

In my case, when I do not wish all sounds (including TomTom voices) to be routed to the Jabra, I just go to
Settings
Connections
Bluetooth
Devices
select Jabra BT8010 and unpick the option “Wireless Stereo”.
After + - 5 seconds, all sounds came thru Advantage speakers except the phone and stays like that until I revert this configuration.
Regards
 

cornelius

Senior Member
Jun 6, 2005
241
1
0
37
Semarang
In my case, every morning i turn on the jabara and athena they will auto connect but even the wireless option didn't ticked, all sound will routed to jabara. What i do just open the option and choose wireless stereo ok, then unthick again and work normally.

Actually is that any ways to repair that?
 

cayotte

Senior Member
Dec 22, 2004
300
0
0
Pekanbaru
In my case, when I do not wish all sounds (including TomTom voices) to be routed to the Jabra, I just go to
Settings
Connections
Bluetooth
Devices
select Jabra BT8010 and unpick the option “Wireless Stereo”.
After + - 5 seconds, all sounds came thru Advantage speakers except the phone and stays like that until I revert this configuration.
Regards

The keyword here is "after + - 5 seconds". Thanks for this effective tip.
 
Last edited:

cayotte

Senior Member
Dec 22, 2004
300
0
0
Pekanbaru
Combination of Jetware, Jabra BT8010 and Dopod U1000 give me the best performance. Thanks to this forum for bringing solution to my bulk Dopod.
 
Last edited: