• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question Joying Zlink (CarPlay) and an inability for anyone to hear me over voice calls

Search This thread

cmay119

Member
Apr 6, 2012
11
2
Hey all,

Anyone have a solution for callers not being able to hear you when the call is taken through CarPlay over Zlink on a Joying head unit? My head unit is: JY-VO133N4. When I unplug my phone I'm able to have phone calls work great over blue tooth, so this appears to just be a Zlink/CarPlay issue. I can hear the caller perfectly, they just can't hear me.

Edit, they actually can hear me, but I come through with very low volume and with static, I'm undiscernable on their end.
 
  • Like
Reactions: Naikara

looxonline

Senior Member
Jun 5, 2018
207
54
Johannesburg
Possible that it's trying to use the mic on your phone and not on the HU. I've done tests and this is what mine does. Where is your phone when driving?
 

Naikara

Member
Feb 9, 2021
10
2
I have the same problem, try to rec an whatsapp audio and listen after, It sound same when you make the calls and I think and the sound is too looow and pooor. My bluetooth calls are great!!! what could be the problem?
 

skous

New member
Aug 23, 2008
1
1
Same problem here, which got worse after updating to IOS 14.8.

I can hear all people very clear, BUT they hear me very far and distant (so it is of no use).
It is NOT a hw mic issue, nor a headunit issue, because when I kill Zlink and use the audio unit's bluetooth, all works perfectly.
 
  • Like
Reactions: Naikara

Naikara

Member
Feb 9, 2021
10
2
My bluetooth audio works fine, It is a pity that the calls do not work, it is the only thing need for work perfectly :cry:
 

cnsheets

New member
Jul 11, 2008
1
1
I know this thread has some age to it, but I recently started having the same problem that while using CarPlay through zlink, any phones calls, no one could hear me, but mics worked when connected to android BT. Also worked connecting a Samsung phone through android auto. Only occurred using iPhone and CarPlay. Been going on for a few months and couldn’t for the life of me figure it out.

Even updated to iOS 15 and same problem.

Today I finally got it working!!

This is what I did. Hope it helps others.

Connect to the unit and let zlink connect and go into CarPlay.

From within CarPlay, open google maps.

Press the microphone button in the bottom corner of google maps. You should get a pop-up saying that you have to allow google access to the microphone.

Immediately look at your phone, you should have a request on the iPhone to allow google access to the microphone.

ALLOW IT!

Then press the microphone button again in google maps. It should now allow you to use voice for searching.

Now go place a phone call!

This solved the problem for me. Hope it helps others.
 
  • Like
Reactions: Naikara

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hey all,

    Anyone have a solution for callers not being able to hear you when the call is taken through CarPlay over Zlink on a Joying head unit? My head unit is: JY-VO133N4. When I unplug my phone I'm able to have phone calls work great over blue tooth, so this appears to just be a Zlink/CarPlay issue. I can hear the caller perfectly, they just can't hear me.

    Edit, they actually can hear me, but I come through with very low volume and with static, I'm undiscernable on their end.
    1
    Same problem here, which got worse after updating to IOS 14.8.

    I can hear all people very clear, BUT they hear me very far and distant (so it is of no use).
    It is NOT a hw mic issue, nor a headunit issue, because when I kill Zlink and use the audio unit's bluetooth, all works perfectly.
    1
    I know this thread has some age to it, but I recently started having the same problem that while using CarPlay through zlink, any phones calls, no one could hear me, but mics worked when connected to android BT. Also worked connecting a Samsung phone through android auto. Only occurred using iPhone and CarPlay. Been going on for a few months and couldn’t for the life of me figure it out.

    Even updated to iOS 15 and same problem.

    Today I finally got it working!!

    This is what I did. Hope it helps others.

    Connect to the unit and let zlink connect and go into CarPlay.

    From within CarPlay, open google maps.

    Press the microphone button in the bottom corner of google maps. You should get a pop-up saying that you have to allow google access to the microphone.

    Immediately look at your phone, you should have a request on the iPhone to allow google access to the microphone.

    ALLOW IT!

    Then press the microphone button again in google maps. It should now allow you to use voice for searching.

    Now go place a phone call!

    This solved the problem for me. Hope it helps others.