Junsun V1 Pro MTK8259 4GB + 64GB Android 10 headunit

Search This thread

rov3rrepo

New member
Jan 8, 2022
3
0
Anyone know how to update AutoLink separately? Or do I have to update the entire head unit. I think this is why I get no audio during phone calls. Others with carplay dongles experienced the same thing but resolved it by updating their adapter.
 

jarrogames

New member
May 27, 2022
1
0
Hi.
I have a new JUNSUN V1 PRO 4GB/64GB.
Everything is OK, only there is a big problem with the FM radio memory and settings after turning the ignition off and on, or after reboot.
I read a lot about this problem on the XDA forum and tried everything possible. Nothing helped. I don't know what to do. I need help.
I have last update 2022 04 22.
Thank you very much.
Jaro from Slovakia.
 
Last edited:

TorstenH

Senior Member
Feb 20, 2021
565
115

MagnifyShay

Member
Mar 14, 2022
32
3
Hey, i don’t know if someone know what I can do, I’ve buy a Junsun V1 Pro 8/128 From Junsun France Store, but they don’t always have the latest software update (for example they sent me the January update while the may one was released). I’ve asked to Junsun Global Store if they can send me the updates but they told me to ask to Junsun France Store if i don’t have a Junsun Global Store Order number. I was thinking if someone here could give me his order number (in private message) for a Junsun V1 Pro 8/128 From Jsunsun Global Sotre so that I can ask them software updates…

I hope someone understands

🙏
 

hackras

Member
Mar 12, 2014
22
7
46
Slovakia
Hi.
I have a new JUNSUN V1 PRO 4GB/64GB.
Everything is OK, only there is a big problem with the FM radio memory and settings after turning the ignition off and on, or after reboot.
I read a lot about this problem on the XDA forum and tried everything possible. Nothing helped. I don't know what to do. I need help.
I have last update 2022 04 22.
Thank you very much.
Jaro from Slovakia.
Hi from Rado from Slovakia :)

I suppose you did connect the power and ACC wires correctly ? The radio needs to be powered even when the key is in OFF position. If you connected it correctly, your radio starts immediately after turnig the key, it does not go through boot process.

You could try this: go to Settings - Car Infotainment - About device - click cog wheel - code 8878 - Radio - and change FM sort from SD level to Freq.

Remember, if you leave the eingeneering menu by pressing Save and Reboot, all your settings (radio, equalizer, etc.) will be lost and you will have to start over. The only time to do Save - Reboot is after changing CAN module type, in all other cases you just go back with the back arrow and setting changes will be applied !!!

Hope I could help.

R.
 
  • Like
Reactions: jarrogames

MagnifyShay

Member
Mar 14, 2022
32
3
Hey, do you know if there is an audio boost somewhere une the 8878 / 8888 special settings menu ? Something different than the loudness option in the DSP
 

hackras

Member
Mar 12, 2014
22
7
46
Slovakia
Hey, do you know if there is an audio boost somewhere une the 8878 / 8888 special settings menu ? Something different than the loudness option in the DSP
Try the 8877 menu, there are lots of settings applying to camera and sound, you can take a look, jus make photos how everything was, once you screw up, you will have a way back....
 

hackras

Member
Mar 12, 2014
22
7
46
Slovakia
Are there any other codes except 8888,8878,8877 to try?
Use at your own risk !!!!

8888 - restricted settings menu
8878 - full settings menu. Mostly what you're looking for.
Additional info can be found here: https://forum.xda-developers.com/t/junsun-v1-factory-settings.4282295/
1111 - load monitoring
0 - update (mcuupdate_num)
1 - some menu (csudy_num)
2 - barcode
3 - another barcode 8938003992756585897
4 - reboot
5 - color setting
6 - set a new random Bluetooth name
7 -
8 - gis whitelist reset
9 - system notification: device activated (in Chinese)
0129 - CAN DATA
5555 - save settings
1912 - factory setup
1812 - shop setup
12345678 - update_apk update MainUI
3699 - update_apk2
5699 - update_apk3
7788 - atc_log (engineering menu of the 4G modem)
8877 - atc_factory
Menu for changing the cutoff (filter) frequencies for the sub and line outputs (relevant for those who use external amplification):
Code 8877 ---> Audio ---> Scroll to Sound Effect ---> Bass (or Alto (Middle), Treble).
And also there is a setting and the ability to completely disable Loudness.
USB mode can be changed here if required, too.
7758258 - obligatory mode !! do not enter !!! Complete crap going on
5678 - changing the menu code logo
3234 - apk_install_pwd
Alternatively (untested!) restore the engineering menu settings to the factory settings.
2134 - appinfo_id_num
6666 - install_id_num
7777 - install2_id_num
1616 - display_id_num brightness
2064 - testmode_id_num
1414 - reboot_id_num
9191 - destroy_id_root_num
9090 - destroy_id_num
1313 - radio_reset_num
1101 - screenshot_num
4321 - filedelete_num
1234 - filecopy_num
 

TorstenH

Senior Member
Feb 20, 2021
565
115
Are there any other codes except 8888,8878,8877 to try?
Don't let us repeat every answer several times . Use the forum search before asking:
 

stefanos21

Senior Member
Jun 20, 2016
58
5
Don't let us repeat every answer several times . Use the forum search before asking:
Hackras answered before and now you repeat same answer.not needed
 

Y9D

New member
May 5, 2022
4
1
Coastal South Carolina
OEM backup camera on 2014 Hyundai Santa Fe Sport "no signal" error when auto in reverse.

Any suggestions on how to proceed from here is appreciated. I am about ready to give up and just buy the Junsun-branded camera instead of continuing to troubleshoot this. (Also, my OEM backup camera image is cloudy and has a halo effect. But it is better than nothing.)

Here is what was stated by a Junsun radio purchased on an AMZ review for a Santa Fe one year newer than my vehicle. But as I inspect my wiring, I am unclear with they mean by this statement:

"Although it is plug and play, there are some wiring you’ll need to do to get the factory camera to work. Had to cut brown trigger wire for the backup camera closer to the can bus module.
Then tapped the brown wire ( pin 14) to the white wire (its near the backup camera video input wire) of the main harness that connects to the vehicles harness (2 in 1 connector).
Once i did this the camera worked flawlessly."

I would be very thankful if someone could point me in the right direction.
 

TorstenH

Senior Member
Feb 20, 2021
565
115
OEM backup camera on 2014 Hyundai Santa Fe Sport "no signal" error when auto in reverse.

Any suggestions on how to proceed from here is appreciated. I am about ready to give up and just buy the Junsun-branded camera instead of continuing to troubleshoot this. (Also, my OEM backup camera image is cloudy and has a halo effect. But it is better than nothing.)

Here is what was stated by a Junsun radio purchased on an AMZ review for a Santa Fe one year newer than my vehicle. But as I inspect my wiring, I am unclear with they mean by this statement:

"Although it is plug and play, there are some wiring you’ll need to do to get the factory camera to work. Had to cut brown trigger wire for the backup camera closer to the can bus module.
Then tapped the brown wire ( pin 14) to the white wire (its near the backup camera video input wire) of the main harness that connects to the vehicles harness (2 in 1 connector).
Once i did this the camera worked flawlessly."

I would be very thankful if someone could point me in the right direction.
Maybe the are not too much differences between Hyundai and Kia...

I don't think Junsun supports any OEM camera. In my car the OEM camera even has a separate socket and the head unit provides no plug for it.

Post in thread 'Junsun V1 MTK8259 - the adapter battle (Kia Ceed Jd)' https://forum.xda-developers.com/t/...pter-battle-kia-ceed-jd.4236281/post-84569537

Please note:
- never ever connect the OEM camera directly with 12V. This may destroy your camera. In opposite to the aftermarket cams OEM cameras has to be powered only with 6V.
- Try to find the pinout diagram of your OEM head unit/radio. This will help to identify the correct pins. If you need further help for that please post a picture of the original radio (front and model number(s)).
 

Y9D

New member
May 5, 2022
4
1
Coastal South Carolina
Maybe the are not too much differences between Hyundai and Kia...

I don't think Junsun supports any OEM camera. In my car the OEM camera even has a separate socket and the head unit provides no plug for it.

Post in thread 'Junsun V1 MTK8259 - the adapter battle (Kia Ceed Jd)' https://forum.xda-developers.com/t/...pter-battle-kia-ceed-jd.4236281/post-84569537

Please note:
- never ever connect the OEM camera directly with 12V. This may destroy your camera. In opposite to the aftermarket cams OEM cameras has to be powered only with 6V.
- Try to find the pinout diagram of your OEM head unit/radio. This will help to identify the correct pins. If you need further help for that please post a picture of the original radio (front and model number(s)).
Thanks, TorstenH. I will continue working on this and update as needed.
 

cstalex

Member
Jun 3, 2022
6
0
Hey guys, I just received a brand new Junsun V1 Pro 4GB/64GB.

I did factory reset the Junsun. I can't find anymore PhoneLink app to use CarPlay.

How can I get back PhoneLink ?
Thx
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Are there any other codes except 8888,8878,8877 to try?
    Use at your own risk !!!!

    8888 - restricted settings menu
    8878 - full settings menu. Mostly what you're looking for.
    Additional info can be found here: https://forum.xda-developers.com/t/junsun-v1-factory-settings.4282295/
    1111 - load monitoring
    0 - update (mcuupdate_num)
    1 - some menu (csudy_num)
    2 - barcode
    3 - another barcode 8938003992756585897
    4 - reboot
    5 - color setting
    6 - set a new random Bluetooth name
    7 -
    8 - gis whitelist reset
    9 - system notification: device activated (in Chinese)
    0129 - CAN DATA
    5555 - save settings
    1912 - factory setup
    1812 - shop setup
    12345678 - update_apk update MainUI
    3699 - update_apk2
    5699 - update_apk3
    7788 - atc_log (engineering menu of the 4G modem)
    8877 - atc_factory
    Menu for changing the cutoff (filter) frequencies for the sub and line outputs (relevant for those who use external amplification):
    Code 8877 ---> Audio ---> Scroll to Sound Effect ---> Bass (or Alto (Middle), Treble).
    And also there is a setting and the ability to completely disable Loudness.
    USB mode can be changed here if required, too.
    7758258 - obligatory mode !! do not enter !!! Complete crap going on
    5678 - changing the menu code logo
    3234 - apk_install_pwd
    Alternatively (untested!) restore the engineering menu settings to the factory settings.
    2134 - appinfo_id_num
    6666 - install_id_num
    7777 - install2_id_num
    1616 - display_id_num brightness
    2064 - testmode_id_num
    1414 - reboot_id_num
    9191 - destroy_id_root_num
    9090 - destroy_id_num
    1313 - radio_reset_num
    1101 - screenshot_num
    4321 - filedelete_num
    1234 - filecopy_num
  • 2
    Are there any other codes except 8888,8878,8877 to try?
    Use at your own risk !!!!

    8888 - restricted settings menu
    8878 - full settings menu. Mostly what you're looking for.
    Additional info can be found here: https://forum.xda-developers.com/t/junsun-v1-factory-settings.4282295/
    1111 - load monitoring
    0 - update (mcuupdate_num)
    1 - some menu (csudy_num)
    2 - barcode
    3 - another barcode 8938003992756585897
    4 - reboot
    5 - color setting
    6 - set a new random Bluetooth name
    7 -
    8 - gis whitelist reset
    9 - system notification: device activated (in Chinese)
    0129 - CAN DATA
    5555 - save settings
    1912 - factory setup
    1812 - shop setup
    12345678 - update_apk update MainUI
    3699 - update_apk2
    5699 - update_apk3
    7788 - atc_log (engineering menu of the 4G modem)
    8877 - atc_factory
    Menu for changing the cutoff (filter) frequencies for the sub and line outputs (relevant for those who use external amplification):
    Code 8877 ---> Audio ---> Scroll to Sound Effect ---> Bass (or Alto (Middle), Treble).
    And also there is a setting and the ability to completely disable Loudness.
    USB mode can be changed here if required, too.
    7758258 - obligatory mode !! do not enter !!! Complete crap going on
    5678 - changing the menu code logo
    3234 - apk_install_pwd
    Alternatively (untested!) restore the engineering menu settings to the factory settings.
    2134 - appinfo_id_num
    6666 - install_id_num
    7777 - install2_id_num
    1616 - display_id_num brightness
    2064 - testmode_id_num
    1414 - reboot_id_num
    9191 - destroy_id_root_num
    9090 - destroy_id_num
    1313 - radio_reset_num
    1101 - screenshot_num
    4321 - filedelete_num
    1234 - filecopy_num
    2
    Firmware installed in meantime?
    Today I applied the Firmware Stock update procedure. The procedure was successful and the tablet works ok. It remains to put it back in the car and see how it behaves in tests. This was possible for the two users who thank them once again: djborsi and TorstenH. I removed the tablet from the car and made the connections to be able to work with a + 12V DC / 220v power supply. For those who want to power it separately from the car, I put some pictures after the procedure and a wiring diagram. I made a video with the FW update procedure. Because I noticed that the tablet heats up a lot, I mounted a 12V / DC fan, It has the size 70X70mm. and thickness 15 mm. It was from an old CPU cooler. It is fastened at the back with 4 screws as seen in the photo. I put a 40 Ohm series resistor. to reduce speed and noise. I hope that what I posted here will bring a little help to those interested.
    2
    But maybe you're interested in my new free app:
    1
    @Balti Lopez: I am returning mine, but I checked the settings. Go to Car Settings (you should have it too), then go to Common and there should be a Sleep option set to ON. You should turn that option to OFF.
    1
    Hi, I have this same radio. I tried to connect it to the computer as I read here and I could not do it. What I would like to do is to root it and if I can put the TWRP RECOVERY. I have not been able to extract the boot.img from the firmware.bin. On the other hand, the "back" button has been deconfigured and now the action it does when I press it, is that I turn off the screen. Do you know how to fix it? I have used the "BUTTONS REMAPPER" application but I have not achieved anything.

    Best Regards
    Did you try connect with Flash Tool after MTK driver installed? How did you understand that no connection? About buttons remap - consider should be enough to uninstall buttons remapper.
    What car do you have?