Junsun V1 Pro MTK8259 4GB + 64GB Android 10 headunit

Search This thread

Luckytwo

New member
Aug 2, 2022
1
0
Hai qualche consiglio/aspetto per scegliere il particolare microfono esterno? O forse un link per quel particolare argomento che hai menzionato?
Spero ancora che l'ultimo aggiornamento FW risolva i miei problemi GPS. Altrimenti lo aprirò e darò un'occhiata alle saldature. Grazie per il suggerimento.
Sei riuscito a risolvere un problema GPS?
 

Smart_Andi

Member
Jul 19, 2022
5
0
Can someone tell me how to change the icons on the front menue ?
Right now I have Radio, running car (Speed) etc.
Also : How can I tell the system to startautomaticially to a app (i.e DAB+ or Navigation) ?
 

Attachments

  • 6.jpg
    6.jpg
    64.1 KB · Views: 62

TorstenH

Senior Member
Feb 20, 2021
779
176
Can someone tell me how to change the icons on the front menue ?
Right now I have Radio, running car (Speed) etc.
Also : How can I tell the system to startautomaticially to a app (i.e DAB+ or Navigation) ?
The stock launcher is garbage and you can't change that things. Regarding autostart launchers like Agama can do that. Please have a look on...
 
  • Like
Reactions: Neopaleo

Smart_Andi

Member
Jul 19, 2022
5
0
The stock launcher is garbage and you can't change that things. Regarding autostart launchers like Agama can do that. Please have a look on...
Thanks for the information.

I`m new here and I have some questions.
I have a Android 8227I bought and build it in in a Smart EQ.
How can I update the system (Android) ? (Instructions)
Where can I find the right download for the Update ?
Below some pictures.
Thanks
Andi
 

Attachments

  • 3.jpg
    3.jpg
    57.6 KB · Views: 62
  • 4.jpg
    4.jpg
    62.7 KB · Views: 62
  • 5.jpg
    5.jpg
    55.6 KB · Views: 62

TorstenH

Senior Member
Feb 20, 2021
779
176
Thanks for the information.

I`m new here and I have some questions.
I have a Android 8227I bought and build it in in a Smart EQ.
How can I update the system (Android) ? (Instructions)
Where can I find the right download for the Update ?
Below some pictures.
Thanks
Andi
This thread is for Junsun V1 Pro with MTK8259 CPU.
b62c5c237f9ca85d23279aaefee13b303f7291cc_original.jpeg
 

jexux

Member
May 31, 2022
5
0
Hello everyone, in principle, apologize for the English is the result of the translator.
I have Junsun V1 Pro 4G+64G, I can't see videos on the radio, I connect the cable with the BRAKE label to the negative and I still get the message impossible to see videos. Do I have to do any other configuration on the radio?
 

TorstenH

Senior Member
Feb 20, 2021
779
176
Hello everyone, in principle, apologize for the English is the result of the translator.
I have Junsun V1 Pro 4G+64G, I can't see videos on the radio, I connect the cable with the BRAKE label to the negative and I still get the message impossible to see videos. Do I have to do any other configuration on the radio?
BREAK needs a positive signal as soon as you enter reverse gear. Usually your car should provide such wire.

For testing purposes you could connect B+ (from car) to REVERSE (of head unit).
The result should be at least a black screen (if video signal not present).
 

JhOLmeS86

New member
Mar 23, 2021
2
0
hi, has anyone managed to share the phone connection with bluetooth tethering? is there a way?
 

DennisH89

Member
Aug 11, 2022
6
1
Hello everyone,
recently i installed a Junsun Head Unit in my Audi TT MK2 (2012) with the bose system.
I had a xtrons PX5 before that worked like a dream with just the quadlock, no decoder or anything... until the touchscreen died.

The JunsunHead Unit works fine, but there is a strange behaviour i can't figure out.
Everything is connected through the quadlock and a canbus adapter from the seller, also there is a aux harness connected. pretty much standard stuff.

My problem:
The integrated radio app has sound. Music via Bluetooth works also just fine.
Every third party app like youtube, spotify, waze, maps, ... has absolutely no sound. nothing.
Googling my problem wasn't really helpful. Connecting the AMP CTRL Wire to ACC oder every other 12V wire to activate the bose amp in the trunk doesn't do anything, still no sound. And yes, the amp is working just fine, when i connect the amp ctrl wire to the powered antenna while using the radio app you can hear the difference in the sound quality because of the amp working, but like i said you also have sound without the connected amp so there should be sound in any other app also, right? I don't want to listen to radio stations all day - i want spotify ;)

In the hidden menues every setting looks just fine, everything works except the sound in apps.


So my guess is the firmware, i already contacted the seller but he didn't responded yet.
Is there a newer firmware available? Or do any of you guys have any idea how to fix my problem?

One more thing: how to do a factory reset on this unit? Is there a code or a special way to press the touchbuttons...? Is it the "erase all content" in the factory settings?


Thank you so much in advance!
 

Attachments

  • 20220811_113914.jpg
    20220811_113914.jpg
    530.8 KB · Views: 32
  • 20220811_113859.jpg
    20220811_113859.jpg
    144.7 KB · Views: 32
  • 20220811_113842.jpg
    20220811_113842.jpg
    438.5 KB · Views: 31

javi2246

Member
Jul 22, 2022
23
4
hi, has anyone managed to share the phone connection with bluetooth tethering? is there a way?
My headunit is a kapud mtk8257, but it is very similar to Junsun V1 Pro.

In 90% of the cases, if before connecting the bluetooth on the mobile I am already allowing tethering (phone) automatically the headunit picks up the internet from the mobile.
But other times I have to force it: the button is "hidden", once connected to the phone, go into settings, click on the magnifying glass/search engine, look for "previously connected devices", click on your phone, and you will see that one of the buttons is "allow internet connection" or something similar.
PS: I have the radio in Spanish language, but the name of the menus should be like this, or similar.

Hello everyone,
recently i installed a Junsun Head Unit in my Audi TT MK2 (2012) with the bose system.
I had a xtrons PX5 before that worked like a dream with just the quadlock, no decoder or anything... until the touchscreen died.

The JunsunHead Unit works fine, but there is a strange behaviour i can't figure out.
Everything is connected through the quadlock and a canbus adapter from the seller, also there is a aux harness connected. pretty much standard stuff.

My problem:
The integrated radio app has sound. Music via Bluetooth works also just fine.
Every third party app like youtube, spotify, waze, maps, ... has absolutely no sound. nothing.
Googling my problem wasn't really helpful. Connecting the AMP CTRL Wire to ACC oder every other 12V wire to activate the bose amp in the trunk doesn't do anything, still no sound. And yes, the amp is working just fine, when i connect the amp ctrl wire to the powered antenna while using the radio app you can hear the difference in the sound quality because of the amp working, but like i said you also have sound without the connected amp so there should be sound in any other app also, right? I don't want to listen to radio stations all day - i want spotify ;)

In the hidden menues every setting looks just fine, everything works except the sound in apps.


So my guess is the firmware, i already contacted the seller but he didn't responded yet.
Is there a newer firmware available? Or do any of you guys have any idea how to fix my problem?

One more thing: how to do a factory reset on this unit? Is there a code or a special way to press the touchbuttons...? Is it the "erase all content" in the factory settings?


Thank you so much in advance!
Certainly if in some applications you hear the amplifier and in others you don't, it seems a firmware problem.
I have an a3 8p with BOSE, and with the harness the amplifier could be heard, but not as well as with the standard equipment. I solved it by putting a high to low converter, now I hear the sound perfectly clear, as with the standard music equipment.

Hab025fdf2a034525a41fb2fa4614d0b8y.jpg
 

jexux

Member
May 31, 2022
5
0
BREAK necesita una señal positiva tan pronto como ingrese la marcha atrás. Por lo general, su automóvil debe proporcionar dicho cable.

Para fines de prueba, puede conectar B+ (del automóvil) a REVERSE (de la unidad principal).
El resultado debería ser al menos una pantalla negra (si no hay señal de video).
Hola. Gracias por responder TorstenH.
Cuando me refiero al cable Brake o “Parking Brake” o “Warning”, este cable es el que
se encarga de activar o desactivar la posibilidad de ver vídeos. Este cable lo conecto al negativo del carro y aun no puedo ver videos por eso pregunto si hay que hacer alguna otra configuracion.
Queria hacer otra pregunta si es posible en el Junsun v1 pro configurar la opcion de "ubicacion" o si por norma siempre esta activada.
 

TorstenH

Senior Member
Feb 20, 2021
779
176
Hola. Gracias por responder TorstenH.
Cuando me refiero al cable Brake o “Parking Brake” o “Warning”, este cable es el que
se encarga de activar o desactivar la posibilidad de ver vídeos. Este cable lo conecto al negativo del carro y aun no puedo ver videos por eso pregunto si hay que hacer alguna otra configuracion.
Queria hacer otra pregunta si es posible en el Junsun v1 pro configurar la opcion de "ubicacion" o si por norma siempre esta activada.
I don't understand and according to the forum rules you have to write in English, please.
 

jexux

Member
May 31, 2022
5
0
I don't understand and according to the forum rules you have to write in English, please.
Hello. Thanks for replying TorstenH.
When I refer to the Brake or “Parking Brake” or “Warning” cable, this cable is the one that
It is responsible for activating or deactivating the possibility of watching videos. I connect this cable to the negative of the car and I still cannot see videos, so I ask if there is any other configuration to be done.
I wanted to ask another question if it is possible in the Junsun v1 pro to configure the "location" option or if it is always activated as a rule.
 

TorstenH

Senior Member
Feb 20, 2021
779
176
Hello. Thanks for replying TorstenH.
When I refer to the Brake or “Parking Brake” or “Warning” cable, this cable is the one that
It is responsible for activating or deactivating the possibility of watching videos. I connect this cable to the negative of the car and I still cannot see videos, so I ask if there is any other configuration to be done.
I wanted to ask another question if it is possible in the Junsun v1 pro to configure the "location" option or if it is always activated as a rule.
BREAK needs a positive(!) signal so it makes no sense to connect it to GROUND of your car.
If your car doesn't provide a BREAK wire or you want your kids watching videos while driving, you can split ACC and connect ACC (from car) additionally to BREAK of your head unit. Your head unit will get power on BREAK as soon as you turn on ignition.
 

TorstenH

Senior Member
Feb 20, 2021
779
176
And don't forget to try out AppSwitcher which has a new setting to show Android status bar on top of all(!) apps.
 

nowaq111

Member
Feb 27, 2013
17
2
Hi,
Does anybody know what is the package name of bluetooth music?
It is actually part of the bluetooh app itself, but on homeoage (stock launcher) i am able to start bt music directly (there is a shortcut).
Want to do the same with tasker, but bt music not listed as individual app in tasker list of apps, just bluetooth is there.
Thanks
 

TorstenH

Senior Member
Feb 20, 2021
779
176
Hi,
Does anybody know what is the package name of bluetooth music?
It is actually part of the bluetooh app itself, but on homeoage (stock launcher) i am able to start bt music directly (there is a shortcut).
Want to do the same with tasker, but bt music not listed as individual app in tasker list of apps, just bluetooth is there.
Thanks
 
  • Like
Reactions: nowaq111

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Scroll trought this thread and you will find all you need:

    @jarrogames The for_launchers.zip file was already uploaded several times and many people are too lazy to use the search functionality. 🤣
    1
    I just received a reply from JunSun support that it's not possible to connect Internet through Bluetooth in the unit. The only option is mobile hotspot after all
    They told me the same thing and it's not true, I can do tethering by bt. I copy and paste from a post that I put pages back, I hope it helps you.

    My headunit is a kapud mtk8257, but it is very similar to Junsun V1 Pro.

    In 90% of the cases, if before connecting the bluetooth on the mobile I am already allowing tethering (phone) automatically the headunit picks up the internet from the mobile.
    But other times I have to force it: the button is "hidden", once connected to the phone, go into settings, click on the magnifying glass/search engine, look for "previously connected devices", click on your phone, and you will see that one of the buttons is "allow internet connection" or something similar.
    PS: I have the radio in Spanish language, but the name of the menus should be like this, or similar.
  • 2
    Are there any other codes except 8888,8878,8877 to try?
    Use at your own risk !!!!

    8888 - restricted settings menu
    8878 - full settings menu. Mostly what you're looking for.
    Additional info can be found here: https://forum.xda-developers.com/t/junsun-v1-factory-settings.4282295/
    1111 - load monitoring
    0 - update (mcuupdate_num)
    1 - some menu (csudy_num)
    2 - barcode
    3 - another barcode 8938003992756585897
    4 - reboot
    5 - color setting
    6 - set a new random Bluetooth name
    7 -
    8 - gis whitelist reset
    9 - system notification: device activated (in Chinese)
    0129 - CAN DATA
    5555 - save settings
    1912 - factory setup
    1812 - shop setup
    12345678 - update_apk update MainUI
    3699 - update_apk2
    5699 - update_apk3
    7788 - atc_log (engineering menu of the 4G modem)
    8877 - atc_factory
    Menu for changing the cutoff (filter) frequencies for the sub and line outputs (relevant for those who use external amplification):
    Code 8877 ---> Audio ---> Scroll to Sound Effect ---> Bass (or Alto (Middle), Treble).
    And also there is a setting and the ability to completely disable Loudness.
    USB mode can be changed here if required, too.
    7758258 - obligatory mode !! do not enter !!! Complete crap going on
    5678 - changing the menu code logo
    3234 - apk_install_pwd
    Alternatively (untested!) restore the engineering menu settings to the factory settings.
    2134 - appinfo_id_num
    6666 - install_id_num
    7777 - install2_id_num
    1616 - display_id_num brightness
    2064 - testmode_id_num
    1414 - reboot_id_num
    9191 - destroy_id_root_num
    9090 - destroy_id_num
    1313 - radio_reset_num
    1101 - screenshot_num
    4321 - filedelete_num
    1234 - filecopy_num
    2
    Firmware installed in meantime?
    Today I applied the Firmware Stock update procedure. The procedure was successful and the tablet works ok. It remains to put it back in the car and see how it behaves in tests. This was possible for the two users who thank them once again: djborsi and TorstenH. I removed the tablet from the car and made the connections to be able to work with a + 12V DC / 220v power supply. For those who want to power it separately from the car, I put some pictures after the procedure and a wiring diagram. I made a video with the FW update procedure. Because I noticed that the tablet heats up a lot, I mounted a 12V / DC fan, It has the size 70X70mm. and thickness 15 mm. It was from an old CPU cooler. It is fastened at the back with 4 screws as seen in the photo. I put a 40 Ohm series resistor. to reduce speed and noise. I hope that what I posted here will bring a little help to those interested.
    2
    But maybe you're interested in my new free app:
    1
    I just received a reply from JunSun support that it's not possible to connect Internet through Bluetooth in the unit. The only option is mobile hotspot after all
    They told me the same thing and it's not true, I can do tethering by bt. I copy and paste from a post that I put pages back, I hope it helps you.

    My headunit is a kapud mtk8257, but it is very similar to Junsun V1 Pro.

    In 90% of the cases, if before connecting the bluetooth on the mobile I am already allowing tethering (phone) automatically the headunit picks up the internet from the mobile.
    But other times I have to force it: the button is "hidden", once connected to the phone, go into settings, click on the magnifying glass/search engine, look for "previously connected devices", click on your phone, and you will see that one of the buttons is "allow internet connection" or something similar.
    PS: I have the radio in Spanish language, but the name of the menus should be like this, or similar.
    1
    Hi, I have this same radio. I tried to connect it to the computer as I read here and I could not do it. What I would like to do is to root it and if I can put the TWRP RECOVERY. I have not been able to extract the boot.img from the firmware.bin. On the other hand, the "back" button has been deconfigured and now the action it does when I press it, is that I turn off the screen. Do you know how to fix it? I have used the "BUTTONS REMAPPER" application but I have not achieved anything.

    Best Regards
    Did you try connect with Flash Tool after MTK driver installed? How did you understand that no connection? About buttons remap - consider should be enough to uninstall buttons remapper.
    What car do you have?