Junsun V1 Pro MTK8259 4GB + 64GB Android 10 headunit

Search This thread

nowaq111

Member
Feb 27, 2013
17
2
Thank you so much!
I will try this today.

Does anybody know how to set media volume to max and save it permanently ?
After reboot it always comes back to value of 20 (out of 30).
Is there anything in 8878 menu that can configure this?

I tried using tasker, but "media volume" task (Also tried "system volume") in tasker does not increase media volume on HU.
 

TorstenH

Senior Member
Feb 20, 2021
839
202
Realme GT 2 Pro
Thank you so much!
I will try this today.

Does anybody know how to set media volume to max and save it permanently ?
After reboot it always comes back to value of 20 (out of 30).
Is there anything in 8878 menu that can configure this?

I tried using tasker, but "media volume" task (Also tried "system volume") in tasker does not increase media volume on HU.
Yes, there are volume settings in 8878 and maybe in setting with code 8877, too.
 
  • Like
Reactions: nowaq111

nowaq111

Member
Feb 27, 2013
17
2
Your help is highly appreciated, thank you so much! You have helped me with both challenges.

I can confirm in the 8878 menu, under audio there is media volume that sets and stores default value user wants.

Also, if anybody wants to start bluetooth music via tasker, in app launch package should be set as com.ts.MainUI/com.ts.bt.BtMusicActivity


One more question: Is there possibility to change boot animation (splash screen)?

I know there is option for ksw units like this
but i did not manage to do it for junsun.
 
  • Like
Reactions: TorstenH

Y9D

Member
May 5, 2022
12
2
Coastal South Carolina
Radio doesn't mute when CarPlay is operating.

Junsun Support says the "machine" radio and CarPlay are totally separate and there is no way to mute the audio of the radio when CarPlay is issuing audio notifications or other tasks.

Is there a fix for this?
 

apikanto

Member
Feb 20, 2022
27
8
68
witam mam radio z androidem FF_866X, 8X128 giga wgrałem najnowszą aktualizację i teraz mam tylko jeden port USB a przed aktualizacją były aktywne dwa porty USB to ta usterka oprogramowania dzięki
IMG_20220816_120553.jpg
 

Attachments

  • IMG_20220816_121226.jpg
    IMG_20220816_121226.jpg
    722.9 KB · Views: 78

uberNoobZA

Senior Member
Oct 10, 2008
581
342
Oxford
Anyone got the latest maps for this? I asked seller and they sent me a link to a 7GB file on mega.nz. I can't download this as I don't have a paid account with mega.nz, so download stops after 5GB.
 
  • Like
Reactions: mamaeca

mamaeca

Senior Member
Mar 26, 2011
70
18
burgas
Anyone got the latest maps for this? I asked seller and they sent me a link to a 7GB file on mega.nz. I can't download this as I don't have a paid account with mega.nz, so download stops after 5GB.
hi friend send me a link for the maps. ask me to download it then i can help you send it to you. there are many ways you sim thank you very much
 

uberNoobZA

Senior Member
Oct 10, 2008
581
342
Oxford
MEGA Desktop App install it on your computer and log in regardless of whether you have 5 GB of accounts, download it freely
I can't install mega desktop app on my PC, as the browser gives a security error when accessing mega.nz. The is no option to ignore the security error. I tried to download on my phone using mega app for android and when it got to 5 GB, it stopped
 

uberNoobZA

Senior Member
Oct 10, 2008
581
342
Oxford
MEGA Desktop App install it on your computer and log in regardless of whether you have 5 GB of accounts, download it freely
I got app working on another device, but that still says 5GB exceeded. It seems that the 5GB limit is on the IP address (which would be the external IP on our router), and not the machine itself / account being used. I would still need to purchase a plan with mega.nz to allow more transfer. I can try every 5 hours to download again, but as transfer cap is 5GB, I will never be able to get the file downloaded (unless it resumes after the 5 hour wait is up)

Looking at the name of the file for "the latest maps" from supplier, it seems to be dated Q4 2020, so it's not very up to date anyway. More trouble than it's worth. Thanks anyway
 
Last edited:

uberNoobZA

Senior Member
Oct 10, 2008
581
342
Oxford
Assuming you have the 4G version of this head unit. My unit had AutoLink hidden but I was able to enable it in the "engineering" settings (accessible by 8878). The problem then became that AutoLink requires an activation license for Wireless CarPlay. I was able to purchase the license by changing my region to France and adding a fake address in France. Nothing is shipped, it is all digital, so address does not matter. Try purchasing a license and putting that into AutoLink and see if it activates wireless CarPlay/Android Auto. Make sure you get the CarPlay license if that is what you need. Android Auto does not work if CarPlay license is activated. Vice versa.

I find this funny. Nothing is shipped, but they still want to charge me £7 for shipping to UK, on top of the cost of the activation code. Am I correct that if I am happy to use phone plugged into USB, I do not need activation code for Android Auto on AutoLink app?
 

arilu6

New member
Aug 17, 2022
2
0
Buenas tardes, escribo con traductor asi que perdon por el vocabulario, hoy me llego una unidad de 8gb x 128gb, el montaje fue facil, saben si tiene conector bluethot para microfono, donde? Luego tengo una cámara de reversa instalada en el portón trasero de VW no original, en el otro equipo que tenía (que era Aseware 4gb x 64 gb) se veía perfecto, en este equipo funciona pero salta y se ve en blanco y negro, si alguien me puede ayudar, gracias, pero como me da muchos problemas de configuracion...
Gracias
 

arilu6

New member
Aug 17, 2022
2
0
He probado a conectar usb para ver si funciona y resulta que no lo encuentra, me parece que he fallado a la hora de comprar este equipo, lo veo muy complicado.
 

alfredomp10

New member
Aug 18, 2022
3
0
Hello, does anybody know how to activate the speedometer in the homescreen in the last firmware update? it was working the first day i updated the firmware but the very next day stopped working.
i tried to look in the 8878 menu and 8877 too but nothing, gps enabled and wifi connected too
MCU: TS-G5.210511(H)
Firmware: 8259P_军灿UI02v1280x720-国外11_v3_20220422
 

Attachments

  • Screenshot 2022-08-18 145510.png
    Screenshot 2022-08-18 145510.png
    203.4 KB · Views: 53

alfredomp10

New member
Aug 18, 2022
3
0
I have received my unit and installed it to my Clio IV 2 days ago. I did not buy from Junsun but it is the same as I can see. In the stock launcher there is a display of a car that i cannot delete . it only displays the speed in mph (we use km/h) . is it supposed to display an open door or hood?
If so I used a general Renault can type (117)
There was one that included clio but the steering wheel controls did not work.
Please advise
Do you know how to make the speedometer work? you can change units by long presssing the mph letters it will automatically change to km/h and viceversa
 

cd993

Senior Member
May 8, 2009
3,538
1,296
London
Samsung Galaxy S21 Ultra
Do you know how to make the speedometer work? you can change units by long presssing the mph letters it will automatically change to km/h and viceversa

My dad has this issue too whereby the car defaults to KPH and has to manually change to MPH each time, as it resets back to KPH upon each boot. All other settings persist but this one doesn't.

Does anyone know of any fix for this?
 

alfredomp10

New member
Aug 18, 2022
3
0
My dad has this issue too whereby the car defaults to KPH and has to manually change to MPH each time, as it resets back to KPH upon each boot. All other settings persist but this one doesn't.

Does anyone know of any fix for this?
I managed to solve the speedometer problem, in my case the gps antenna was not receiving enough signal, I changed its position and now everything works correctly, the problem of the reset still happens every time I reboot the headunit, I use it with sleep mode on so I avoid that problem.
 

mamaeca

Senior Member
Mar 26, 2011
70
18
burgas
My dad has this issue too whereby the car defaults to KPH and has to manually change to MPH each time, as it resets back to KPH upon each boot. All other settings persist but this one doesn't.

Does anyone know of any fix for this?
hello, it got better for me after the launcher theme crash
 

cd993

Senior Member
May 8, 2009
3,538
1,296
London
Samsung Galaxy S21 Ultra
I managed to solve the speedometer problem, in my case the gps antenna was not receiving enough signal, I changed its position and now everything works correctly, the problem of the reset still happens every time I reboot the headunit, I use it with sleep mode on so I avoid that problem.
Sorry just to confirm, I meant to specify that this is the MPH on his actual car tripometer, not via the android head unit. He changes it to MPH via the Android setting, which then changes that mini display behind his steering wheel, but after turning off the electrics, removing his key, re-entering the key and the car starts up again, that mini display MPH goes back to KPH. He says it's a European model which just defaults to that.

So, given this Android head unit has the ability to change that little display, the setting just isn't sticking. When you go back into the setting, it itself is still set to MPH, so he has to then toggle it to KPH to then MPH to force it back.

If there's a fix for this, he'll be a happy man! We updated to the latest firmware today but it didn't help. Was wondering if using Automate in someway could help?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hello. I have Junsun V1 Pro 4gb ram and I have a question which navigation do you use on the screen on? Waze or another ?
    I use waze and sygic with offline maps
    1
    Tell us how,the steps we must do
    Download image you want with good resolution. Use online pictures editor to make it 1280x720pixel and bmp type. Upload to Usb drive and put USB in the media. Then enter boot logo menu, tap search and will see it.
    1
    What do you mean by "put it in the media"?
    Put the usb stick in the usb port of the JunSun unit
    1
    It only works if i upload in usb?
    If upload in internal memory of the media does not work?

    It only works if i upload in usb?
    If upload in internal memory of the media does not work?
    I don't make it other way. Only success with usb. If you succeed other way let me know.
    1
    When upload your logo it is change car's logo
    Android logo cant change
  • 2
    Are there any other codes except 8888,8878,8877 to try?
    Use at your own risk !!!!

    8888 - restricted settings menu
    8878 - full settings menu. Mostly what you're looking for.
    Additional info can be found here: https://forum.xda-developers.com/t/junsun-v1-factory-settings.4282295/
    1111 - load monitoring
    0 - update (mcuupdate_num)
    1 - some menu (csudy_num)
    2 - barcode
    3 - another barcode 8938003992756585897
    4 - reboot
    5 - color setting
    6 - set a new random Bluetooth name
    7 -
    8 - gis whitelist reset
    9 - system notification: device activated (in Chinese)
    0129 - CAN DATA
    5555 - save settings
    1912 - factory setup
    1812 - shop setup
    12345678 - update_apk update MainUI
    3699 - update_apk2
    5699 - update_apk3
    7788 - atc_log (engineering menu of the 4G modem)
    8877 - atc_factory
    Menu for changing the cutoff (filter) frequencies for the sub and line outputs (relevant for those who use external amplification):
    Code 8877 ---> Audio ---> Scroll to Sound Effect ---> Bass (or Alto (Middle), Treble).
    And also there is a setting and the ability to completely disable Loudness.
    USB mode can be changed here if required, too.
    7758258 - obligatory mode !! do not enter !!! Complete crap going on
    5678 - changing the menu code logo
    3234 - apk_install_pwd
    Alternatively (untested!) restore the engineering menu settings to the factory settings.
    2134 - appinfo_id_num
    6666 - install_id_num
    7777 - install2_id_num
    1616 - display_id_num brightness
    2064 - testmode_id_num
    1414 - reboot_id_num
    9191 - destroy_id_root_num
    9090 - destroy_id_num
    1313 - radio_reset_num
    1101 - screenshot_num
    4321 - filedelete_num
    1234 - filecopy_num
    2
    Hi
    in the firmware update file there are 2 files 8259.bin and 8259.upd
    We must put in usb stick both of them?
    yes.
    2
    But maybe you're interested in my new free app:
    2
    Firmware installed in meantime?
    Today I applied the Firmware Stock update procedure. The procedure was successful and the tablet works ok. It remains to put it back in the car and see how it behaves in tests. This was possible for the two users who thank them once again: djborsi and TorstenH. I removed the tablet from the car and made the connections to be able to work with a + 12V DC / 220v power supply. For those who want to power it separately from the car, I put some pictures after the procedure and a wiring diagram. I made a video with the FW update procedure. Because I noticed that the tablet heats up a lot, I mounted a 12V / DC fan, It has the size 70X70mm. and thickness 15 mm. It was from an old CPU cooler. It is fastened at the back with 4 screws as seen in the photo. I put a 40 Ohm series resistor. to reduce speed and noise. I hope that what I posted here will bring a little help to those interested.
    1
    Hi,

    here my experience with Junsun V1 Pro with MTK 8259 (detailed spec. of device in below screenshots).

    1611240722227.png
    1611240746293.png


    My car is:
    Mazda 3, produced 2010 (type BL).

    1. The radio station memory is cleared after rebooting the device (i.e. after setting differen CAN Type), so I must always to set the radio channels from beginnig on.
    >> this I can handle since I don't have to play with CAN Type setting all the time.

    2. I cannot pin any widget, or any shortcut of an app the to any of the home screens! The system hangs up when I trying to pin something.
    >> this is to solve by different launcher. I have tried with Nova launcher and took radio, bleutooth etc. app from “for_launchers” zip file. Was working fine.

    3. During using a navigation app the music from radio and sounds from navi are not mixed. Radio is playing and when navi sound comes, then radio is reduced and overplayed, I couldn't find option to change it.
    >> in the end nothing special, it is a matter of expectation and taste.

    4. The reverse camera (gift from Junsun) is not working afer installation according to diagrams.
    >> this stays unsolved...

    5. After switching car gear to reverse any backview as Warning Line or as Assistance Line are not working, not appearing!
    >> is unsolved,
    maybe connected with issue no 4. (system doesn't detect camera, so also deosn't activate any backview).

    6. After switching car gear to reverse the sound level reduction deosn't work!
    >> is unsolved,
    maybe also connected with issue no 4. (system doesn't detect camera, also deosn't activate any backview, so in the end no sound level change).

    7. I did Reset to Factory Settings (through android interface) to correct the problem no.2 (see description above). It helped for a moment, so after some time (~15 minutes) the issue came back, so still I cannot pin any widget or shortcut to any home screen.

    8. I cannot find any option to make Screen-Lock.
    >> probably dedicated app would help, but I haven't tried.

    9. The CAN info are not working with my car, so I cannot see any info about open doors, etc.
    >> I was using CAN Type 145, as adviced by seller, but still was not working.


    All of above issue I was trying to solve with seller via messages (my english is not perfect, but their ... terrible).
    After upgrading the device to a new FW (provided by seller), after few days of discussion, I have decided to return the radio back. I did all according to agreement with seller and via aliexpress system and it worked fine. I got money back (211€) , all good.

    The device, beside above described issues, worked really really well, fast and smoothly.
    The GPS was catch fast and 4G with sim card slot extension worked really amazing (direct internet access as well as direct phone calls possible!).
    The radio reception and the sound quality, also very good!

    It is a pity, because the device looks like has a big potential, but the current FW is not perfect, so causing small, but many annoying problems.
    Not sure about camera issue (no.: 4+5+6), if it is connected with FW or rather with CAN decoder...

    I would consider to buy it again, but first I will wait for a better FW/OS/ROM, so I am looking forward for any news about it!

    I hope the info will help some of you.
    Greetings!