Junsun V1 Pro MTK8259 4GB + 64GB Android 10 headunit

Search This thread

TorstenH

Senior Member
Feb 20, 2021
1,794
469
t.me
Realme GT 2 Pro
To reboot the head unit without factory menu code 4 you can install Reboot.apk from here:




Don't miss to install:
 

miroslavpena

Member
Jan 2, 2012
46
2
Is anyone experiencing guidelines for reverse camera to be imprecise ? I had guidelines with reverse camera in my original radio and they were telling me exactly where the car was going from start..this new one i think is wrong at radius and there is no setup for that, i can just adjust size and position of lines..
any suggestions?
Btw im using original camera
 

juderon

Member
Mar 2, 2023
16
3
Oki
#1 note that changing a 8878/8888 setting will reset radio, equalizer, navigation app, ...
#2 in the 8878 settings menu (section Others) is this mysterious memory remember/unrememer setting. Give it a try but consider #1 if you change a setting
#3 remove USB drives because they may be configured to be Androids storage for app data. And maybe the app/setting is required before the USB drive is detected during boot process.
#4 re-flash current or newer firmware
#5 install logcat reader and check for errors and fatal messages while changing a setting or directly after boot.
Hello friends, I don't understand the English language well, I'll use a translator. My problem since I bought the Junsun V1PRO is that I don't have USB, they are not detected even if I have the cables well connected, in the Others hidden menu I see this that I attached in the image, someone Would you know how to help me? I can't update the radio if I don't have a USB option. Please help
 

Attachments

  • IMG20230301195816.jpg
    IMG20230301195816.jpg
    5.4 MB · Views: 81
  • IMG20230320172223.jpg
    IMG20230320172223.jpg
    4.6 MB · Views: 70

TorstenH

Senior Member
Feb 20, 2021
1,794
469
t.me
Realme GT 2 Pro
Oki

Hello friends, I don't understand the English language well, I'll use a translator. My problem since I bought the Junsun V1PRO is that I don't have USB, they are not detected even if I have the cables well connected, in the Others hidden menu I see this that I attached in the image, someone Would you know how to help me? I can't update the radio if I don't have a USB option. Please help
Just want to mention that USB drive should get detected automatically and you should see a notification in the status bar. Try not only one and especially older, FAT32 formatted USB sticks.
 

juderon

Member
Mar 2, 2023
16
3
Just want to mention that USB drive should get detected automatically and you should see a notification in the status bar. Try not only one and especially older, FAT32 formatted USB sticks.
ok I'll do it, but it's very strange that in the hidden menu I don't have the USB1 USB2 option? I have seen screenshots of other Junsun V1 PRO, and it is there automatically, without doing anything, if of course a notification should appear when inserting a USB stick in fat 32 but it doesn't. I think it's a Firmware issue, my problem is that without USB, I can't change the firmware
 

TorstenH

Senior Member
Feb 20, 2021
1,794
469
t.me
Realme GT 2 Pro
ok I'll do it, but it's very strange that in the hidden menu I don't have the USB1 USB2 option? I have seen screenshots of other Junsun V1 PRO, and it is there automatically, without doing anything, if of course a notification should appear when inserting a USB stick in fat 32 but it doesn't. I think it's a Firmware issue, my problem is that without USB, I can't change the firmware
If there are differences in settings menu:
- have you used code 8878 to enter settings menu?
- do you have a V1 Pro (4G variant) with Mtk825X CPU? Junsun sells the V1 Pro in different variants with different CPUs based on different platforms. App CPU-Z may help.

A Junsun V1 Pro is not a Junsun V1 Pro is not a Junsun V1 Pro is not...
 

juderon

Member
Mar 2, 2023
16
3
If there are differences in settings menu:
- have you used code 8878 to enter settings menu?
- do you have a V1 Pro (4G variant) with Mtk825X CPU? Junsun sells the V1 Pro in different variants with different CPUs based on different platforms. App CPU-Z may help.

A Junsun V1 Pro is not a Junsun V1 Pro is not a Junsun V1 Pro is not...
It is Junsun V1pro 4G 8G RAM 256G ROM
 

Attachments

  • IMG20230320210429.jpg
    IMG20230320210429.jpg
    7.3 MB · Views: 73
  • IMG20230320211059.jpg
    IMG20230320211059.jpg
    8.1 MB · Views: 74

TorstenH

Senior Member
Feb 20, 2021
1,794
469
t.me
Realme GT 2 Pro
It is Junsun V1pro 4G 8G RAM 256G ROM
You're in the wrong thread. This is for MTK8257 aka MTK8259 aka MTK825X.

Flashing a firmware for Mtk825X may lead to a bootloop.

I'm sure you will find other threads in this thread chaos but this may be a starting point:



And keep in mind: A Junsun V1 Pro is not a Junsun V1 Pro is not a Junsun V1 Pro is not...
 

juderon

Member
Mar 2, 2023
16
3
You're in the wrong thread. This is for MTK8257 aka MTK8259 aka MTK825X.

Flashing a firmware for Mtk825X may lead to a bootloop.

I'm sure you will find other threads in this thread chaos but this may be a starting point:



And keep in mind: A Junsun V1 Pro is not a Junsun V1 Pro is not a Junsun V1 Pro is not...
ok sorry, I'm new to the forum, and I didn't know how or where to start. Thank you anyway, you are very kind, thank you.
 
  • Like
Reactions: TorstenH

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi could some one help me, so when I use the factory fitted backup camera to display correctly. All I see is this..
    It's a nissan Qashqai J10.
    You could try to change video format in factory settings (code 8878, section Others). There should be the possibly to switch from/to PAL, NTSC and maybe more.
    1
    Hi!
    I would like to turn on the radio without putting it in the car yet and configure it like this. If I connect the red cable from the quadlock and the black one to a 12v and 2A transformer, will I be able to use it normally or do I also need to connect some other cable? Thank you
    You just need to connect B+ and ACC to the positive output, GND to the negative output of your 12V power supply.
    1
    Junsun V1 pro won't save settings
    So far i've tried:
    Adding USB drive as Android space, also as travel media for music
    Reset
    Update to v61
    Manual save to USB drive via 5555 code
    Manual save to SD does not work
    After restart head unit loses radio stations, equalizer settings

    Car is Peugeot 207, Junsun V1 Pro with 64GB of storage and 4GB of RAM
    Any tips are welcome
    1
    Thanks!,
    So it's the red, and yellow that go to the positive and the black to the negative. That red comes to the input connector to the radio from the cambus while the other two come directly from the quadlock.
    So I have to connect the positive of the transformer to that red just before the input connector, right?

    Connect pin 8 and pin 15 to the positive (+) output and pin 16 to the negative (-) output of your power supply (transformator).

    CAN box connection is not needed to start the head unit.


    IMG_20230523_143234.jpg

    I don't like to talk about wire colors because they may be not identical for different harnesses.
    1
    You could try to change video format in factory settings (code 8878, section Others). There should be the possibly to switch from/to PAL, NTSC and maybe more.
    Thanks it worked!
  • 2
    But maybe you're interested in my new free app:
    2
    Are there any other codes except 8888,8878,8877 to try?
    Use at your own risk !!!!

    8888 - restricted settings menu
    8878 - full settings menu. Mostly what you're looking for.
    Additional info can be found here: https://forum.xda-developers.com/t/junsun-v1-factory-settings.4282295/
    1111 - load monitoring
    0 - update (mcuupdate_num)
    1 - some menu (csudy_num)
    2 - barcode
    3 - another barcode 8938003992756585897
    4 - reboot
    5 - color setting
    6 - set a new random Bluetooth name
    7 -
    8 - gis whitelist reset
    9 - system notification: device activated (in Chinese)
    0129 - CAN DATA
    5555 - save settings
    1912 - factory setup
    1812 - shop setup
    12345678 - update_apk update MainUI
    3699 - update_apk2
    5699 - update_apk3
    7788 - atc_log (engineering menu of the 4G modem)
    8877 - atc_factory
    Menu for changing the cutoff (filter) frequencies for the sub and line outputs (relevant for those who use external amplification):
    Code 8877 ---> Audio ---> Scroll to Sound Effect ---> Bass (or Alto (Middle), Treble).
    And also there is a setting and the ability to completely disable Loudness.
    USB mode can be changed here if required, too.
    7758258 - obligatory mode !! do not enter !!! Complete crap going on
    5678 - changing the menu code logo
    3234 - apk_install_pwd
    Alternatively (untested!) restore the engineering menu settings to the factory settings.
    2134 - appinfo_id_num
    6666 - install_id_num
    7777 - install2_id_num
    1616 - display_id_num brightness
    2064 - testmode_id_num
    1414 - reboot_id_num
    9191 - destroy_id_root_num
    9090 - destroy_id_num
    1313 - radio_reset_num
    1101 - screenshot_num
    4321 - filedelete_num
    1234 - filecopy_num
    2

    Hi thanks to all for your useful posts , i have a junsun radio 2gb+32gb whit 4g , i think is v1pro but many things are different to the other user posted here,​

    this device is the device i purchased :​


    View attachment 5439269

    I have one problem with reverse camera when I put on reverse the car ( toyota rav4 2010 ) nothing happens, the reverse cable gets 12v but the reverse camera app not launching . when i put reverse and the video wire of the camera is connected to aux video in I can get image from camera, but i need to launch the aux video app every time i put reverse.​

    I have something like this:​


    View attachment 5439271

    So my question are:​

    1) Is this a v1pro radio?​

    2) Someone has the same problem with the camera or knows what is happening?​

    3) There is any update for this radio?​

    Sorry my bad English, here are some pics from the device:​


    View attachment 5439299


    View attachment 5439301
    View attachment 5439303

    Thanks for your help​

    As soon as there are +12 V on the reverse wire your should see the rear view camera app with a black screen (if rear view camera signal is not connected).

    I think you have this device:

    Not a V1 pro with an old android version.
    2
    I just received a reply from JunSun support that it's not possible to connect Internet through Bluetooth in the unit. The only option is mobile hotspot after all
    They told me the same thing and it's not true, I can do tethering by bt. I copy and paste from a post that I put pages back, I hope it helps you.

    My headunit is a kapud mtk8257, but it is very similar to Junsun V1 Pro.

    In 90% of the cases, if before connecting the bluetooth on the mobile I am already allowing tethering (phone) automatically the headunit picks up the internet from the mobile.
    But other times I have to force it: the button is "hidden", once connected to the phone, go into settings, click on the magnifying glass/search engine, look for "previously connected devices", click on your phone, and you will see that one of the buttons is "allow internet connection" or something similar.
    PS: I have the radio in Spanish language, but the name of the menus should be like this, or similar.
    2
    Firmware installed in meantime?
    Today I applied the Firmware Stock update procedure. The procedure was successful and the tablet works ok. It remains to put it back in the car and see how it behaves in tests. This was possible for the two users who thank them once again: djborsi and TorstenH. I removed the tablet from the car and made the connections to be able to work with a + 12V DC / 220v power supply. For those who want to power it separately from the car, I put some pictures after the procedure and a wiring diagram. I made a video with the FW update procedure. Because I noticed that the tablet heats up a lot, I mounted a 12V / DC fan, It has the size 70X70mm. and thickness 15 mm. It was from an old CPU cooler. It is fastened at the back with 4 screws as seen in the photo. I put a 40 Ohm series resistor. to reduce speed and noise. I hope that what I posted here will bring a little help to those interested.