Junsun V1 Pro (MTK8259/MTK8257) - firmware

Search This thread

rigattoni

Senior Member
Apr 27, 2010
1,966
634
Fuerth
I have to say this is the worst forum I've ever seen.

I've already written a post 5 times and get no replies at all. Nothing at all.

My questions aren't that difficult, are they?

I would love to send this **** Junsun part back, but unfortunately I can't anymore.

I was hoping to find support here but no one responds no matter what I write.
Sorry, but it always depends on your question and if there is someone who is able to answer unspecified questions.
I haven´t seen any of your questions, but make sure that they all show the needed information in your posting.
1. Android version
2. MCU version
3. Firmware version
4. clear statement what issue you are running into,
5. what did you already try to fix it yourself.

This is the standard what is needed to answer any posting, if you want to fix something.
Just updating with another firmware, does mostly not fix any issues itself.
 

didko84

Member
Nov 11, 2022
26
10
Buy v1pro this days
They told me is with last updates. Is it try ?
Attach pics
 

Attachments

  • IMG_20221114_152609.jpg
    IMG_20221114_152609.jpg
    2 MB · Views: 247
  • IMG_20221114_120524.jpg
    IMG_20221114_120524.jpg
    1.9 MB · Views: 248
  • 16684388282292362464910767108349.jpg
    16684388282292362464910767108349.jpg
    1.8 MB · Views: 252

siwan2605

New member
Nov 19, 2022
2
0
Cześć.
Jak ustawić autostart aplikacji aplikacji Nigdzie nie mogę znaleźć mechanizmu autostartu.
Hello.
How to set the autostart of the selected application I can't find the autostart settings anywhere.
 
Last edited:

siwan2605

New member
Nov 19, 2022
2
0
Cześć.
Jak ustawić autostart aplikacji aplikacji Nigdzie nie mogę znaleźć mechanizmu autostartu.
Hello.
How to set the autostart of the selected application I can't find the autostart settings anywhere.
I solved my own query. Firstly, the installation of the "autostart" application, but also the sleep mode had to be turned off because after the sleep mode it closes all other applications except for the originally loaded ones. And now I'm waiting longer for the start, but everything turns on as it should.
 

Ariasloa

New member
Nov 24, 2022
1
0
Bonjour,

Je souhaite obtenir de l'aide SVP, j'ai acheté un autoradio Android junsun, pour peugeot 208. Lorsque je l'ai recu je n'avais pas les commande au voloant ni la radio ni la 4G. Le vendeur ne m'a pas répondu pendanr 1 seamine j'ai ouvert un litige et mais il refuse de m'aider. J'ai reinitaliser l'autoradio mais j'ai perdu toutes les applications qui étaient préinstallée comme junsun sécurity, l'application pour avoir carplay sans fil et plein d'autres. Je souhaites les avoirs pourriez vous me dire comment faire ? Est ce qu'il y a un logiciel à installer ou il faut les installer une par une et où je peux les retourver ?
Ma radion c'est une V1 pro 4go de ram 64GO SVP aidez moi j'ai vraiment besoin d'aide.



mod translated please post in english everyone.

I would like some help please, I bought a Junsun Android car radio, for the Peugeot 208. When I received it, I didn't have the steering wheel controls, the radio or the 4G. The seller did not answer me for 1 week I opened a dispute and he refuses to help me. I reset the car radio but I lost all the applications that were preinstalled such as junsun security, the application for wireless carplay and many others. I want to have them could you tell me how to do it? Is there software to install or do I have to install them one by one and where can I return them?
 
Last edited by a moderator:

krajczar

Member
Apr 12, 2022
7
1
Bonjour,

Je souhaite obtenir de l'aide SVP, j'ai acheté un autoradio Android junsun, pour peugeot 208. Lorsque je l'ai recu je n'avais pas les commande au voloant ni la radio ni la 4G. Le vendeur ne m'a pas répondu pendanr 1 seamine j'ai ouvert un litige et mais il refuse de m'aider. J'ai reinitaliser l'autoradio mais j'ai perdu toutes les applications qui étaient préinstallée comme junsun sécurity, l'application pour avoir carplay sans fil et plein d'autres. Je souhaites les avoirs pourriez vous me dire comment faire ? Est ce qu'il y a un logiciel à installer ou il faut les installer une par une et où je peux les retourver ?
Ma radion c'est une V1 pro 4go de ram 64GO SVP aidez moi j'ai vraiment besoin d'aide.



mod translated please post in english everyone.

I would like some help please, I bought a Junsun Android car radio, for the Peugeot 208. When I received it, I didn't have the steering wheel controls, the radio or the 4G. The seller did not answer me for 1 week I opened a dispute and he refuses to help me. I reset the car radio but I lost all the applications that were preinstalled such as junsun security, the application for wireless carplay and many others. I want to have them could you tell me how to do it? Is there software to install or do I have to install them one by one and where can I return them?
Hi, this is also a text with a translator. You can find official firmware here in this forum. It contains your favourite applications. You write it to a fat32 formatted flash drive and just plug it into the head unit. It will then install automatically.
 

Terragama

Senior Member
Aug 21, 2021
50
0
Guys i have a question, what version of Autolink app do you have? Is there any chance to update it or its just one version forever? :D
 

NXXXR

Member
Feb 12, 2016
11
0
Guys i have a question, what version of Autolink app do you have? Is there any chance to update it or its just one version forever? :D
with the latest september firmware mine is version 2. something, from junsun they don't give me this firmware and it has 1.9 something, I've used wireless carplay in both and noticed a considerable difference between turning on the radio to have wireless carplay working! :)
 

Terragama

Senior Member
Aug 21, 2021
50
0
with the latest september firmware mine is version 2. something, from junsun they don't give me this firmware and it has 1.9 something, I've used wireless carplay in both and noticed a considerable difference between turning on the radio to have wireless carplay working! :)
Yes indeed i need to open AA app on phone and theny connect it throught Autolink to make it work, otherwise the Autolink app get stuck on black screen
 
Mar 26, 2015
13
1
Hi everyone!
I wanted to know if there's any firmware compatible with my HU. It's not Junsun but from what I've seen it's almost identical to the V1 Pro. Mine is an Ossuret 8X.
I also wanted to know if there's a way to enable wireless Carplay (I have wired Carplay with the Phonelink app) and if I can change Carplay's screen resolution.
Thanks in advance!
 

Attachments

  • IMG_2581.jpeg
    IMG_2581.jpeg
    1.1 MB · Views: 140
  • IMG_2580.jpeg
    IMG_2580.jpeg
    762.3 KB · Views: 143

Terragama

Senior Member
Aug 21, 2021
50
0
Hi everyone!
I wanted to know if there's any firmware compatible with my HU. It's not Junsun but from what I've seen it's almost identical to the V1 Pro. Mine is an Ossuret 8X.
I also wanted to know if there's a way to enable wireless Carplay (I have wired Carplay with the Phonelink app) and if I can change Carplay's screen resolution.
Thanks in advance!
Yes cause its 825x so you can install last update for junsun and it will be good
 

itzelma

Member
Dec 5, 2022
13
0
Hi. I have the mtk8259 running android 11. I have a few issues but the main issue here is that when i change settings for example the volume, it all resets when i reboot the device. does anyone know how to fix this?
 

BitMaskBob

New member
Aug 26, 2018
4
2
After many hours searching threads for information about my HU and issues I was having, I find myself here with those issues resolved and wanting to thank @TorstenH @hackras and of course the community in general for the efforts to make these capable but buggy devices more capable and understandable. With all the searching, I didn't see many other users with my exact MCU nor these specific issues so I also feel compelled to share the experience before and after updating to v44. The device is working better than ever, and too often there is no update on successes. I also found myself wanting more information about MCU versions, CPU, etc so I'm posting as much as I can in case it helps others.

The HU worked "okay" for the first 8 months but then started getting stuck in some kind of boot loop for the first 5-15 minutes. When you started the car, it would load the boot logo, then start flashing a washed out white screen for some variable time then eventually start working. The reverse camera would not even work during this time so as I carried on the journey of searching this forum for answers, I even started looking into MCU firmware. In the end, I didn't do anything for the MCU, just updated to v44.

The Aliexpress seller was somewhat responsive when I asked them for support but not actually helpful. Their ultimate answer was that the motherboard must be bad and to buy another radio, then file a "free" return on that new one, swapping the bad one then it would be "free" for me. No thanks. They were non-responsive when I asked for firmware. Also, this seller's firmware seemed to do something to prevent apps like CPU Z, and Device Info HW from working. AIDA64 would work, but almost any other app that is used to detect fake OS or hardware would simply crash when you ran them. The apps that did work showed that hardware matched what I expected and of course the usual Android 9 faked as 11 which is mostly to be expected.

I am happy to report that v44 has resolved both of these issues and saved me the headache of this crappy seller "LPYFRG Store". The device itself works well, and it came with all the accessories I needed including everything to use my OEM camera but the firmware was complete garbage. I understand that comes mostly from the factory but I know the seller puts their "touch" on it and not giving updated firmware ensures that it stays in piss poor condition. My device is again functional, in fact better than original.

I'm attaching system details before and after. Yes, the firmware does show as Android 12 after but it's still 9. What is even trickier is that CPU-Z actually shows version 12, API version 31 but when you use Device Info HW you can see that it is clearly still version 9, API 28. I am more than suspicious of the seller's firmware even thinking that this "flashing boot loop" could be intentional but either way, I'm thankful for the community to take matters into our own hands. Again, thank you @TorstenH @hackras I followed your breadcrumbs to success.
 

Attachments

  • about-device-before.jpg
    about-device-before.jpg
    2.7 MB · Views: 126
  • about-car-before.jpg
    about-car-before.jpg
    3.3 MB · Views: 107
  • about-car-after.jpg
    about-car-after.jpg
    2.9 MB · Views: 95
  • about-device-after.jpg
    about-device-after.jpg
    4.2 MB · Views: 105
  • CPUZ.jpg
    CPUZ.jpg
    3.9 MB · Views: 101
  • deviceinfohw-soc.jpg
    deviceinfohw-soc.jpg
    2.1 MB · Views: 101
  • deviceinfohw-system.jpg
    deviceinfohw-system.jpg
    1.7 MB · Views: 142
  • Like
Reactions: hackras

itzelma

Member
Dec 5, 2022
13
0
After many hours searching threads for information about my HU and issues I was having, I find myself here with those issues resolved and wanting to thank @TorstenH @hackras and of course the community in general for the efforts to make these capable but buggy devices more capable and understandable. With all the searching, I didn't see many other users with my exact MCU nor these specific issues so I also feel compelled to share the experience before and after updating to v44. The device is working better than ever, and too often there is no update on successes. I also found myself wanting more information about MCU versions, CPU, etc so I'm posting as much as I can in case it helps others.

The HU worked "okay" for the first 8 months but then started getting stuck in some kind of boot loop for the first 5-15 minutes. When you started the car, it would load the boot logo, then start flashing a washed out white screen for some variable time then eventually start working. The reverse camera would not even work during this time so as I carried on the journey of searching this forum for answers, I even started looking into MCU firmware. In the end, I didn't do anything for the MCU, just updated to v44.

The Aliexpress seller was somewhat responsive when I asked them for support but not actually helpful. Their ultimate answer was that the motherboard must be bad and to buy another radio, then file a "free" return on that new one, swapping the bad one then it would be "free" for me. No thanks. They were non-responsive when I asked for firmware. Also, this seller's firmware seemed to do something to prevent apps like CPU Z, and Device Info HW from working. AIDA64 would work, but almost any other app that is used to detect fake OS or hardware would simply crash when you ran them. The apps that did work showed that hardware matched what I expected and of course the usual Android 9 faked as 11 which is mostly to be expected.

I am happy to report that v44 has resolved both of these issues and saved me the headache of this crappy seller "LPYFRG Store". The device itself works well, and it came with all the accessories I needed including everything to use my OEM camera but the firmware was complete garbage. I understand that comes mostly from the factory but I know the seller puts their "touch" on it and not giving updated firmware ensures that it stays in piss poor condition. My device is again functional, in fact better than original.

I'm attaching system details before and after. Yes, the firmware does show as Android 12 after but it's still 9. What is even trickier is that CPU-Z actually shows version 12, API version 31 but when you use Device Info HW you can see that it is clearly still version 9, API 28. I am more than suspicious of the seller's firmware even thinking that this "flashing boot loop" could be intentional but either way, I'm thankful for the community to take matters into our own hands. Again, thank you @TorstenH @hackras I followed your breadcrumbs to success.
Can you provide us with the new v44 update? Is that the latest update? And how to you go about doing that? Just copy it to a usb drive then plug it in then where do I go to update the head units thanks in advance.
 

Top Liked Posts

  • 2
    I have no idea because that's a secret of the Chinese manufacturers. I'm sure even the sellers don't know.
    But don't flash MCU if you don't have an issue with it.

    That's part of faking the displayed Android version. The Chinese want you to think you have Android 9. There are apps available which can tell you the truth (CPU-Z) and fake check tools.


    You can flash it and because we're taking about full updates there is no need to flash previous versions first.
    But please note: You will loose all apps installed by yourself and you will loose the pirated navi app installed by the Chinese, the voice recognition app with this white roboter.


    You can create a backup but I don't see a need if you only flash v50. Don't use the newest USB stick - and maybe you have to try several USB pen drives to get the update running.

    One additional note: don't store sensitive information (credit card) on the head unit. And use a separate Google account - not the main one you use on your phone.
    i ran the update it was successful andriod auto works wreless etc these are the changes it changed the HMI,MEDIA,BTV but not the MCU and the build went to core 9 and ends with test-keys vs before the update it was core 10 userdebug(whatever that means)
  • 3
    With the new firmware I was able to connect Android Auto wirelessly via the AutoLink app...with previous versions it was impossible
    2
    I have no idea because that's a secret of the Chinese manufacturers. I'm sure even the sellers don't know.
    But don't flash MCU if you don't have an issue with it.

    That's part of faking the displayed Android version. The Chinese want you to think you have Android 9. There are apps available which can tell you the truth (CPU-Z) and fake check tools.


    You can flash it and because we're taking about full updates there is no need to flash previous versions first.
    But please note: You will loose all apps installed by yourself and you will loose the pirated navi app installed by the Chinese, the voice recognition app with this white roboter.


    You can create a backup but I don't see a need if you only flash v50. Don't use the newest USB stick - and maybe you have to try several USB pen drives to get the update running.

    One additional note: don't store sensitive information (credit card) on the head unit. And use a separate Google account - not the main one you use on your phone.
    i ran the update it was successful andriod auto works wreless etc these are the changes it changed the HMI,MEDIA,BTV but not the MCU and the build went to core 9 and ends with test-keys vs before the update it was core 10 userdebug(whatever that means)
    2
    Where are the change logs available?
    Junsun France shared this Google Drive link containing the ZIP and Word document for the V50 Junsun V1 Pro (MTK8259)

    2
    How did you install all of your apps please?.
    I use an USB drive with all my Apps., I plugged it on the "HU" and I open "Es Explorer" on the "HU" to look for the USB drive . And when I select the app (with my finger) , the "HU" offers to use "Apk installer" or similar to install it. I just click on the the screen with my finger on the good choice and and the installation is done automatically. I repeat that with each App.
    2
    first of all thanks to all that have added to this thread espeacilly

    TorstenH seems to me that you are the expert on these units​


    i bought a NVGOTEV head unit about 1.5 years ago its a px6 4gb ram 64 rom worked great unitll recently i have been looking for a fix for a while now and came accross this thread

    my destails are
    HMI: ZHYC.G5.D.Q.F.xll.2021.09.29.17.30
    MCU: is TS-G5.201021(VHD) i have seen some pictures with only a (H) how does that differ from my (VHD)?
    I have no idea because that's a secret of the Chinese manufacturers. I'm sure even the sellers don't know.
    But don't flash MCU if you don't have an issue with it.
    About Car the build is
    full_825x_pro-octa 10 PP1.180610.011 eng.root.20200426.093427 userdebug
    Custom build version
    andrios-trunk-p0.825X_PRO

    Question: if i run (device info app info) it shows the build number as full_825X_PRO-Octa "9" PP1.180610.011 eng.root.20200426.093427 test-keys
    why is it showing it different then under about car?
    That's part of faking the displayed Android version. The Chinese want you to think you have Android 9. There are apps available which can tell you the truth (CPU-Z) and fake check tools.

    last but most important
    this update 'Junsun V1 Pro v50 is it for my device?
    if it is do i need to just update the latest version or do i need to go thru all of them up till v50
    You can flash it and because we're taking about full updates there is no need to flash previous versions first.
    But please note: You will loose all apps installed by yourself and you will loose the pirated navi app installed by the Chinese, the voice recognition app with this white roboter.

    and would i need to back up the whole system first like i have seen some videos with spflash etc before i run the firmware update?
    You can create a backup but I don't see a need if you only flash v50. Don't use the newest USB stick - and maybe you have to try several USB pen drives to get the update running.

    One additional note: don't store sensitive information (credit card) on the head unit. And use a separate Google account - not the main one you use on your phone.
  • 4
    Latest firmware for Junsun V1 Pro with Mtk8257 CPU:

    8259P_军灿UI02v1280x720-国外_v50_20221226.zip


    Alternative download link:

    Don't forget to install AppSwitcher after update:
    3
    With the new firmware I was able to connect Android Auto wirelessly via the AutoLink app...with previous versions it was impossible
    2
    Hi. I have the mtk8259 running android 11. I have a few issues but the main issue here is that when i change settings for example the volume, it all resets when i reboot the device. does anyone know how to fix this?
    Use the 8878 menu and set the volume in there. It should hold the setting after reboot.
    2
    I have no idea because that's a secret of the Chinese manufacturers. I'm sure even the sellers don't know.
    But don't flash MCU if you don't have an issue with it.

    That's part of faking the displayed Android version. The Chinese want you to think you have Android 9. There are apps available which can tell you the truth (CPU-Z) and fake check tools.


    You can flash it and because we're taking about full updates there is no need to flash previous versions first.
    But please note: You will loose all apps installed by yourself and you will loose the pirated navi app installed by the Chinese, the voice recognition app with this white roboter.


    You can create a backup but I don't see a need if you only flash v50. Don't use the newest USB stick - and maybe you have to try several USB pen drives to get the update running.

    One additional note: don't store sensitive information (credit card) on the head unit. And use a separate Google account - not the main one you use on your phone.
    i ran the update it was successful andriod auto works wreless etc these are the changes it changed the HMI,MEDIA,BTV but not the MCU and the build went to core 9 and ends with test-keys vs before the update it was core 10 userdebug(whatever that means)
    2
    Hi,
    Have you the improvement list?
    And if you can could you share photos of some new themes?

    Thanks in advance
    I updated the original post with photos....