Junsun V1 Pro (MTK8259/MTK8257) - firmware

Search This thread

rigattoni

Senior Member
Apr 27, 2010
1,966
634
Fuerth
I have to say this is the worst forum I've ever seen.

I've already written a post 5 times and get no replies at all. Nothing at all.

My questions aren't that difficult, are they?

I would love to send this **** Junsun part back, but unfortunately I can't anymore.

I was hoping to find support here but no one responds no matter what I write.
Sorry, but it always depends on your question and if there is someone who is able to answer unspecified questions.
I haven´t seen any of your questions, but make sure that they all show the needed information in your posting.
1. Android version
2. MCU version
3. Firmware version
4. clear statement what issue you are running into,
5. what did you already try to fix it yourself.

This is the standard what is needed to answer any posting, if you want to fix something.
Just updating with another firmware, does mostly not fix any issues itself.
 

didko84

Member
Nov 11, 2022
26
10
Buy v1pro this days
They told me is with last updates. Is it try ?
Attach pics
 

Attachments

  • IMG_20221114_152609.jpg
    IMG_20221114_152609.jpg
    2 MB · Views: 245
  • IMG_20221114_120524.jpg
    IMG_20221114_120524.jpg
    1.9 MB · Views: 246
  • 16684388282292362464910767108349.jpg
    16684388282292362464910767108349.jpg
    1.8 MB · Views: 250

siwan2605

New member
Nov 19, 2022
2
0
Cześć.
Jak ustawić autostart aplikacji aplikacji Nigdzie nie mogę znaleźć mechanizmu autostartu.
Hello.
How to set the autostart of the selected application I can't find the autostart settings anywhere.
 
Last edited:

siwan2605

New member
Nov 19, 2022
2
0
Cześć.
Jak ustawić autostart aplikacji aplikacji Nigdzie nie mogę znaleźć mechanizmu autostartu.
Hello.
How to set the autostart of the selected application I can't find the autostart settings anywhere.
I solved my own query. Firstly, the installation of the "autostart" application, but also the sleep mode had to be turned off because after the sleep mode it closes all other applications except for the originally loaded ones. And now I'm waiting longer for the start, but everything turns on as it should.
 

Ariasloa

New member
Nov 24, 2022
1
0
Bonjour,

Je souhaite obtenir de l'aide SVP, j'ai acheté un autoradio Android junsun, pour peugeot 208. Lorsque je l'ai recu je n'avais pas les commande au voloant ni la radio ni la 4G. Le vendeur ne m'a pas répondu pendanr 1 seamine j'ai ouvert un litige et mais il refuse de m'aider. J'ai reinitaliser l'autoradio mais j'ai perdu toutes les applications qui étaient préinstallée comme junsun sécurity, l'application pour avoir carplay sans fil et plein d'autres. Je souhaites les avoirs pourriez vous me dire comment faire ? Est ce qu'il y a un logiciel à installer ou il faut les installer une par une et où je peux les retourver ?
Ma radion c'est une V1 pro 4go de ram 64GO SVP aidez moi j'ai vraiment besoin d'aide.



mod translated please post in english everyone.

I would like some help please, I bought a Junsun Android car radio, for the Peugeot 208. When I received it, I didn't have the steering wheel controls, the radio or the 4G. The seller did not answer me for 1 week I opened a dispute and he refuses to help me. I reset the car radio but I lost all the applications that were preinstalled such as junsun security, the application for wireless carplay and many others. I want to have them could you tell me how to do it? Is there software to install or do I have to install them one by one and where can I return them?
 
Last edited by a moderator:

krajczar

Member
Apr 12, 2022
7
1
Bonjour,

Je souhaite obtenir de l'aide SVP, j'ai acheté un autoradio Android junsun, pour peugeot 208. Lorsque je l'ai recu je n'avais pas les commande au voloant ni la radio ni la 4G. Le vendeur ne m'a pas répondu pendanr 1 seamine j'ai ouvert un litige et mais il refuse de m'aider. J'ai reinitaliser l'autoradio mais j'ai perdu toutes les applications qui étaient préinstallée comme junsun sécurity, l'application pour avoir carplay sans fil et plein d'autres. Je souhaites les avoirs pourriez vous me dire comment faire ? Est ce qu'il y a un logiciel à installer ou il faut les installer une par une et où je peux les retourver ?
Ma radion c'est une V1 pro 4go de ram 64GO SVP aidez moi j'ai vraiment besoin d'aide.



mod translated please post in english everyone.

I would like some help please, I bought a Junsun Android car radio, for the Peugeot 208. When I received it, I didn't have the steering wheel controls, the radio or the 4G. The seller did not answer me for 1 week I opened a dispute and he refuses to help me. I reset the car radio but I lost all the applications that were preinstalled such as junsun security, the application for wireless carplay and many others. I want to have them could you tell me how to do it? Is there software to install or do I have to install them one by one and where can I return them?
Hi, this is also a text with a translator. You can find official firmware here in this forum. It contains your favourite applications. You write it to a fat32 formatted flash drive and just plug it into the head unit. It will then install automatically.
 

Terragama

Senior Member
Aug 21, 2021
50
0
Guys i have a question, what version of Autolink app do you have? Is there any chance to update it or its just one version forever? :D
 

NXXXR

Member
Feb 12, 2016
11
0
Guys i have a question, what version of Autolink app do you have? Is there any chance to update it or its just one version forever? :D
with the latest september firmware mine is version 2. something, from junsun they don't give me this firmware and it has 1.9 something, I've used wireless carplay in both and noticed a considerable difference between turning on the radio to have wireless carplay working! :)
 

Terragama

Senior Member
Aug 21, 2021
50
0
with the latest september firmware mine is version 2. something, from junsun they don't give me this firmware and it has 1.9 something, I've used wireless carplay in both and noticed a considerable difference between turning on the radio to have wireless carplay working! :)
Yes indeed i need to open AA app on phone and theny connect it throught Autolink to make it work, otherwise the Autolink app get stuck on black screen
 
Mar 26, 2015
13
1
Hi everyone!
I wanted to know if there's any firmware compatible with my HU. It's not Junsun but from what I've seen it's almost identical to the V1 Pro. Mine is an Ossuret 8X.
I also wanted to know if there's a way to enable wireless Carplay (I have wired Carplay with the Phonelink app) and if I can change Carplay's screen resolution.
Thanks in advance!
 

Attachments

  • IMG_2581.jpeg
    IMG_2581.jpeg
    1.1 MB · Views: 139
  • IMG_2580.jpeg
    IMG_2580.jpeg
    762.3 KB · Views: 142

Terragama

Senior Member
Aug 21, 2021
50
0
Hi everyone!
I wanted to know if there's any firmware compatible with my HU. It's not Junsun but from what I've seen it's almost identical to the V1 Pro. Mine is an Ossuret 8X.
I also wanted to know if there's a way to enable wireless Carplay (I have wired Carplay with the Phonelink app) and if I can change Carplay's screen resolution.
Thanks in advance!
Yes cause its 825x so you can install last update for junsun and it will be good
 

itzelma

Member
Dec 5, 2022
13
0
Hi. I have the mtk8259 running android 11. I have a few issues but the main issue here is that when i change settings for example the volume, it all resets when i reboot the device. does anyone know how to fix this?
 

BitMaskBob

New member
Aug 26, 2018
4
2
After many hours searching threads for information about my HU and issues I was having, I find myself here with those issues resolved and wanting to thank @TorstenH @hackras and of course the community in general for the efforts to make these capable but buggy devices more capable and understandable. With all the searching, I didn't see many other users with my exact MCU nor these specific issues so I also feel compelled to share the experience before and after updating to v44. The device is working better than ever, and too often there is no update on successes. I also found myself wanting more information about MCU versions, CPU, etc so I'm posting as much as I can in case it helps others.

The HU worked "okay" for the first 8 months but then started getting stuck in some kind of boot loop for the first 5-15 minutes. When you started the car, it would load the boot logo, then start flashing a washed out white screen for some variable time then eventually start working. The reverse camera would not even work during this time so as I carried on the journey of searching this forum for answers, I even started looking into MCU firmware. In the end, I didn't do anything for the MCU, just updated to v44.

The Aliexpress seller was somewhat responsive when I asked them for support but not actually helpful. Their ultimate answer was that the motherboard must be bad and to buy another radio, then file a "free" return on that new one, swapping the bad one then it would be "free" for me. No thanks. They were non-responsive when I asked for firmware. Also, this seller's firmware seemed to do something to prevent apps like CPU Z, and Device Info HW from working. AIDA64 would work, but almost any other app that is used to detect fake OS or hardware would simply crash when you ran them. The apps that did work showed that hardware matched what I expected and of course the usual Android 9 faked as 11 which is mostly to be expected.

I am happy to report that v44 has resolved both of these issues and saved me the headache of this crappy seller "LPYFRG Store". The device itself works well, and it came with all the accessories I needed including everything to use my OEM camera but the firmware was complete garbage. I understand that comes mostly from the factory but I know the seller puts their "touch" on it and not giving updated firmware ensures that it stays in piss poor condition. My device is again functional, in fact better than original.

I'm attaching system details before and after. Yes, the firmware does show as Android 12 after but it's still 9. What is even trickier is that CPU-Z actually shows version 12, API version 31 but when you use Device Info HW you can see that it is clearly still version 9, API 28. I am more than suspicious of the seller's firmware even thinking that this "flashing boot loop" could be intentional but either way, I'm thankful for the community to take matters into our own hands. Again, thank you @TorstenH @hackras I followed your breadcrumbs to success.
 

Attachments

  • about-device-before.jpg
    about-device-before.jpg
    2.7 MB · Views: 124
  • about-car-before.jpg
    about-car-before.jpg
    3.3 MB · Views: 105
  • about-car-after.jpg
    about-car-after.jpg
    2.9 MB · Views: 94
  • about-device-after.jpg
    about-device-after.jpg
    4.2 MB · Views: 104
  • CPUZ.jpg
    CPUZ.jpg
    3.9 MB · Views: 100
  • deviceinfohw-soc.jpg
    deviceinfohw-soc.jpg
    2.1 MB · Views: 100
  • deviceinfohw-system.jpg
    deviceinfohw-system.jpg
    1.7 MB · Views: 140
  • Like
Reactions: hackras

itzelma

Member
Dec 5, 2022
13
0
After many hours searching threads for information about my HU and issues I was having, I find myself here with those issues resolved and wanting to thank @TorstenH @hackras and of course the community in general for the efforts to make these capable but buggy devices more capable and understandable. With all the searching, I didn't see many other users with my exact MCU nor these specific issues so I also feel compelled to share the experience before and after updating to v44. The device is working better than ever, and too often there is no update on successes. I also found myself wanting more information about MCU versions, CPU, etc so I'm posting as much as I can in case it helps others.

The HU worked "okay" for the first 8 months but then started getting stuck in some kind of boot loop for the first 5-15 minutes. When you started the car, it would load the boot logo, then start flashing a washed out white screen for some variable time then eventually start working. The reverse camera would not even work during this time so as I carried on the journey of searching this forum for answers, I even started looking into MCU firmware. In the end, I didn't do anything for the MCU, just updated to v44.

The Aliexpress seller was somewhat responsive when I asked them for support but not actually helpful. Their ultimate answer was that the motherboard must be bad and to buy another radio, then file a "free" return on that new one, swapping the bad one then it would be "free" for me. No thanks. They were non-responsive when I asked for firmware. Also, this seller's firmware seemed to do something to prevent apps like CPU Z, and Device Info HW from working. AIDA64 would work, but almost any other app that is used to detect fake OS or hardware would simply crash when you ran them. The apps that did work showed that hardware matched what I expected and of course the usual Android 9 faked as 11 which is mostly to be expected.

I am happy to report that v44 has resolved both of these issues and saved me the headache of this crappy seller "LPYFRG Store". The device itself works well, and it came with all the accessories I needed including everything to use my OEM camera but the firmware was complete garbage. I understand that comes mostly from the factory but I know the seller puts their "touch" on it and not giving updated firmware ensures that it stays in piss poor condition. My device is again functional, in fact better than original.

I'm attaching system details before and after. Yes, the firmware does show as Android 12 after but it's still 9. What is even trickier is that CPU-Z actually shows version 12, API version 31 but when you use Device Info HW you can see that it is clearly still version 9, API 28. I am more than suspicious of the seller's firmware even thinking that this "flashing boot loop" could be intentional but either way, I'm thankful for the community to take matters into our own hands. Again, thank you @TorstenH @hackras I followed your breadcrumbs to success.
Can you provide us with the new v44 update? Is that the latest update? And how to you go about doing that? Just copy it to a usb drive then plug it in then where do I go to update the head units thanks in advance.
 

Top Liked Posts