[Junsun V1] Unable to use CarPlay over USB

Search This thread

theomi_

New member
May 4, 2022
1
0
Hi all,

First, thank you for all the job everyone does here. I'm new to this forum, so I hope I am posting in the right category and I respect the post format.

I am posting here because I recently bought a Junsun V1 (non pro) for my Mazda 2 on Aliexpress, but after one week of back and fourth with their support chat, I am unable to use Carplay over USB (not even talking about wireless).

First, I wasn't even seeing their "phonelink" app icon, which is needed to use Carplay over USB. After some exchanges with the support, they suggested me to "show" the icon using the secret menu 8888 beucase it was apparently hidden by default. And indeed, it was. So I was able to get the icon to show on the home screen, but every time I tried to open it, it would show "loading..." for ~15 seconds then close itself without saying anything.

I am using the original 4-pin USB cable, and also tried with the 6-pin one, without success. I also tried several lightning cables, and even with another iPhone (but my actual phone can use carplay in another car which had built in) but I can't manage to get it working. I have tried messing with the advanced USB settings, enabling carplay in the "engineer menu" (code 8877) enabling debug, but nothing works. I have also tried doing a factory reset, and the Junsun support sent me a firmware update, which didn't solve the problem.

I have found this post on XDA Developers of somebody mentioning the same kind of issue, but they seem to have fixed it by doing a factory reset, but in my case that didn't change anything.

I'm a little desperate to find a solution to this problem and even wonder if my unit doesn't have the necessary hardware to run CarPlay as apparently, the non-pro Junsun V1 didn't support it previously.

that's why I came to see if anyone has already had or seen this problem and would have a possible solution to give me. Otherwise I will turn to buying an external CarPlay dongle.

Thanks in advance and best regards !
 

marchnz

Senior Member
Nov 26, 2012
5,143
1,098
NZ
Is it an MTCD type device, post Android system info with MCU version.

Don't hope, have a read through the forums.