Just rooted my remix mini

Search This thread


Jan 25, 2012
Probably for rooted apps but I thought maybe Jide is now approving ROOT. Just thought I would ask.

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    I tried to install SuperSU v265, but it wouldn't install. :( Then I tried to install SuperSU v246 and it did something, but now Remix isn't booting any more! :crying: I can still communicate with Remix Mini via CoolTerm, but my thumb drive isn't available any more. (I guess you call it not mounted??)

    Can you post a link to a working UPDATE-SuperSU-xxx.zip ? (I mean one that would work here on Remix Mini)

    This is the same SuperSU v2.46, what broke my Remix Mini in the first place...

    experiencing the same thing as you. Thought I missed something but haven't had time to play around with it.

    I don't think it's dependent on the os version.
    I ran into similar issues originally as well, but I managed to work around them with some modifications. When I have some time (hopefully either tonight or tomorrow) I'll try to pull the files off and double check exactly what I had done to make it work.

    I believe I used a system mode version (not the newer hybrid systemless/system format) of 2.65. I had to do a little tweaking in the update-binary script. One change I recall I needed to make was commenting out a section that checked for "/sbin/unzip" and bailed out if it didn't find it, saying something along the lines of "BAD RECOVERY DETECTED". Since the update-binary is being manually run from the shell while the device is not in recovery (AFAICT in the [stock] recovery, accessing a shell over UART doesn't work but I didn't spend much time on it.), the fact the script bails out is erroneous.
    Pretty sure I also had the BIN and COM variables pointing to /data/local/tmp instead of /tmp.
    Also, after it installed and rebooted, I seem to remember having to move the SuperSU.apk from /system/app/SuperSU/SuperSU.apk to /system/app/SuperSU.apk and using "chmod 644" on it.

    @Guerol, I also had issues with the USB randomly not mounting. It actually didn't even see my drive as being attached if I used the upper port. So, make sure you plug it into the bottom port on the Mini.
    Since the USB gets recognized as a block device, and the internal storage isn't, the USB will *likely* be at /dev/sda. I'll need to double check the device naming because I can't say for sure this will work verbatim, you should be able to use
    mount /dev/sda1 /mnt/usbhost/Storage01
    to manually mount the drive.

    I'll get a more clear/detailed list of instructions, and pull the files back off my Mini, once I get a chance to.

    here is a link to a chinese site the guy said he installed busybox first
    FWIW, I did not install busybox beforehand. There's already a system version in /system/bin/busybox-smp that can be used for the process.
    Once I had SuperSU installed, I just downloaded BusyBox on the Play Store and used that (reasoning: the pro version was already in my account and it lets you configure symlinks/applets, which I prefer to do instead of a whole-sale install possibly overwriting links in the system image by default).

    One suggestion I have for anyone doing this though, once you have access to the root shell over UART, make a backup of at least the system partition. You can use "dd" to save an image to the internal storage card and then pull it off with a USB or something. It wouldn't hurt to back up other partitions either.
    adaway, task managing, xposed, apps/games from unknown sources with copying data to local storage, using usb drives as storage for apps...etc
    It is the cable I am using
    "Eruner PL2303HX USB To TTL To UART RS232 COM Cable Module Converter" : Amazon ($6.99)

    White -> TX
    Green -> RX
    Black -> GND

    1. Download UPDATE-SuperSU.zip
    2. Unzip the UPDATE-SuperSU.zip
    3. Copy superSU and META-INF/com/google/android/update-binary(from #2) onto USB drive

    on putty
    mount -o rw,remount /
    mount -o rw,remount /system
    cd /system/bin
    ln -s busybox-smp unzip
    cd /data/local/tmp
    cp /mnt/usbhost/Storage01/UPDATE-SuperSU-xxx.zip /data/local/tmp
    cp /mnt/usbhost/Storage01/update-binary /data/local/tmp
    sh update-binary 0 1 /data/local/tmp/UPDATE-SuperSU-xxx.zip
    For those who would like to root Remix Mini:

    Jide will not offer root access and do not encourage our users to root their devices as it voids the warranty of Remix Mini.

    i was 1 of the original backers of this kickstarter project and was looking forward with excitement to receiving my mini told some of my friends and relatives who were also enthusiastic, so i received my mini played with it and patiently waited for a method to become available to root it people asked me about my mini but in all honesty could not recommend it because of the lack of root access.
    i believe most of the people who backed the project are like myself enthusiasts and have at least 1 or more rooted devices have become dismayed by JIDE`S intransigence by refusing to offer any form of root access they are now playing catchup as remix os gets ported to other devices with better specs . i know were ill be looking for my next version of remix os and it sadly wont be with JIDE.