• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Kernel] [2.6.34/2.6.35] OCed - UVed: -1.113Ghz

Search This thread

persiansown

Retired Recognized Developer
Jan 12, 2007
878
716
If you haven't noticed, Pershoot has taken over this thread a LOOONNGGG time ago. We just keep it here because it's easier than opening a new thread.

Here is a kernel for the Nexus One running at 1.113 Ghz. Its been perfectly stable for me. Enjoy.

Remember, I hold NO responsibility for anything that goes wrong. I'm simply providing the kernel, whatever happens with it is on your shoulders not mine.

Pershoot just compiled the .32 kernel that is both undervolted and OCed. Big props to him.

Instructions:

1. Root your Nexus and install the latest Cyanogen rom (5.0.2 as of 2/15/2010)
2. Download SetCPU from either XDA for free, or support the developer as I did and buy it on the market
3. Reboot into fastboot and type "fastboot flash zimage zImage"
4. Push the .ko file to /system/lib/modules
5. Once your phone boots, open SetCPU and tell it to autodetect your CPU (Don't choose Nexus from the list!)
6. Set the max clock to the highest and tell it to set on boot.
7. Enjoy :)

Keep in mind that this kernel is both undervolted and overclocked. So you're getting less power consumption as well as faster speeds.


This also fixes the issue that many had that prevented them from flashing it.

Direct Pershoot link

How to revert:
take the boot.img out of the cyanogen zip and fastboot flash boot boot.img

If you are using enom's, use a similar process (as well as pushing the proper .ko file back as well)

You could also just reflash the rom you were using before. That will get rid of the addon, and you won't have to wipe.

EDIT: You may have issues with the phone getting warmer while it is charging. If that is the case, simply set up charging profiles in setcpu.

This kernel is now undervolted for everything but 1.113ghz. So you should probably see about the same battery usage as a stock kernel :)
 
Last edited:

amwayorlando

Senior Member
Feb 4, 2010
66
2
I've got an error: can't load "zImagekmobs". Do I need to change the file extension to img? I tried with both the bat and img file extension. Got the same error. I did copy the zImagekmobs file to the fastboot folder.
 

Top Liked Posts