[KERNEL] [blu_spark r87 OP8/Pro/T] [A11 OOS/Custom ]

Imprezzion

Senior Member
Dec 12, 2011
578
200
63
Gorredijk
Hi 😊 first of all thanks for your work 🙂
One question. You say you don't give support to custom ROMs but can you say if it works on them or not. Because it's a little bit confuse to me when I open the "custom" link from OP page. It says "OOS 11, custom + OOS 10"😊
Thanks in advanced and keep strong and healthy 😉
Like I posted 2 posts above this one, I just decided to give it a try on custom A11 as obviously I have a backup .img of the stock rooted kernel anyway.

Yes, I can confirm it works without any problems on CrDroid 7.1 which is A11 custom. I imagine it will work fine on LOS 18.1 / PE as well.
 

Shooter7889

Member
Mar 24, 2019
17
5
3
FLORENCE
Like I posted 2 posts above this one, I just decided to give it a try on custom A11 as obviously I have a backup .img of the stock rooted kernel anyway.

Yes, I can confirm it works without any problems on CrDroid 7.1 which is A11 custom. I imagine it will work fine on LOS 18.1 / PE as well.
Custom/works on EvoX as well with all functionality/no issues. I've been running both together all wk perfectly
 
  • Like
Reactions: alex moymoy

Kollachi

Senior Member
Aug 24, 2013
2,164
983
193
Osnabrück
Hi @eng.stk I flashed the latest r78 on OnePlus 8T 11.0.6.9 EU (magisk v21.2 too) using EXKM and I got a bootloop into recovery. Didn't happen with the previous version.

EDIT: not sure why but somehow it worked in the end. Due to the bootloop I booted my patched stock OOS boot.img, and I direct install magisk after booting. After that it reboots successfully into blu_spark r78
I have used FKM to flash r78 on my 8T with 11.0.6.9 and didn't have any issues.
 

tidschi

Senior Member
Mar 5, 2008
322
90
48
Hi @eng.stk I flashed the latest r78 on OnePlus 8T 11.0.6.9 EU (magisk v21.2 too) using EXKM and I got a bootloop into recovery. Didn't happen with the previous version.

EDIT: not sure why but somehow it worked in the end. Due to the bootloop I booted my patched stock OOS boot.img, and I direct install magisk after booting. After that it reboots successfully into blu_spark r78
Here the same, went also into recovery because of bootlop. I only wiped cache, tried again and it boots again. Maybe luck?
 

Reddit3321

Member
Jan 19, 2017
22
10
3
Here the same, went also into recovery because of bootlop. I only wiped cache, tried again and it boots again. Maybe luck?
I also had the same experience, flashed with exkm and bootlooped to recovery eventually. I didn't have a saved copy of my stock boot img anywhere except for my phone so I screwed my self and ended up msm tool'ing.

After I got back up and running again, I tried this time flashing with fkm and I have not had any troubles since. I think it may have something to do with the AK3 changes and how exkm flashes.
 

tidschi

Senior Member
Mar 5, 2008
322
90
48
I also had the same experience, flashed with exkm and bootlooped to recovery eventually. I didn't have a saved copy of my stock boot img anywhere except for my phone so I screwed my self and ended up msm tool'ing.

After I got back up and running again, I tried this time flashing with fkm and I have not had any troubles since. I think it may have something to do with the AK3 changes and how exkm flashes.
Forgot to mention, that I flashed with FKM. xD
 

RMarques

Senior Member
Jan 28, 2013
948
155
73
@eng.stk

Sup bud, thanks for putting your project out there to all of us to enjoy!

I'm rolling with a rooted OP8, featuring A11 OB5 + xXx + Acc module. Using FKM to manage kernel options.

I'd like to ask if:

1. Does it have sound control? I'm looking forward to be able to improve my bluetooth earbuds mic input volume, so ppl can hear me better.

2. Does it have battery idle? Device starts to draw power directly from the power outlet, once Acc does reach a given battery level, allowing you to let it connected to the charger all night long, reducing battery heat and stress.
 
  • Like
Reactions: eng.stk

eng.stk

Senior Member
Mar 29, 2011
6,746
58,312
263
@eng.stk

Sup bud, thanks for putting your project out there to all of us to enjoy!

I'm rolling with a rooted OP8, featuring A11 OB5 + xXx + Acc module. Using FKM to manage kernel options.

I'd like to ask if:

1. Does it have sound control? I'm looking forward to be able to improve my bluetooth earbuds mic input volume, so ppl can hear me better.

2. Does it have battery idle? Device starts to draw power directly from the power outlet, once Acc does reach a given battery level, allowing you to let it connected to the charger all night long, reducing battery heat and stress.
Welcome :)

1. Nope, already discussed this for others devices.
2. Nope OP8 already has a complicated charging stack as it is and intwligent charging is already in place.
 
  • Like
Reactions: RMarques

Boing7898

Member
Aug 10, 2011
44
8
28
Hi @eng.stk
I've noticed in your OP7/Pro blu_spark kernels you added support for WiFi on ROMs that have built in wifi module (like LOS with the latest updates):

- Rework runtime backend to suport WLAN in all custom ROM variants (via AK3 kernel companion Magisk module)
- Misc. LOS patches for better device support (custom)

Do you have any plans in doing the same for this kernel for OP8/8T/Pro?

Thank you for your work!
 
  • Like
Reactions: eng.stk

eng.stk

Senior Member
Mar 29, 2011
6,746
58,312
263
Hi @eng.stk
I've noticed in your OP7/Pro blu_spark kernels you added support for WiFi on ROMs that have built in wifi module (like LOS with the latest updates):

- Rework runtime backend to suport WLAN in all custom ROM variants (via AK3 kernel companion Magisk module)
- Misc. LOS patches for better device support (custom)

Do you have any plans in doing the same for this kernel for OP8/8T/Pro?

Thank you for your work!
All my current Oneplus lineup have that in place (y)
 
  • Like
Reactions: Boing7898

Boing7898

Member
Aug 10, 2011
44
8
28
All my current Oneplus lineup have that in place (y)
Oh that's great!
Do you have any idea what could the problem be then? Magisk module is enabled, can't enable WiFi though.
Here's the logcat

Code:
01-13 22:41:06.467   957   957 E [email protected]: get_mac_from_nv: Get nv mac file failed: Permission denied
01-13 22:41:08.274   957   957 E [email protected]: get_mac_from_nv: Get nv mac file failed: Permission denied
01-13 22:41:10.486   957   957 E [email protected]: Failed to access driver state control param No such file or directory, 2: No such file or directory
01-13 22:41:10.486   957   957 E [email protected]: Failed to load WiFi driver
01-13 22:41:10.486   957   957 E [email protected]: Failed to initialize firmware mode controller
01-13 22:41:10.486   957   957 E [email protected]: Wifi HAL start failed
01-13 22:41:10.487  1492  1953 E HalDevMgr: Cannot start IWifi: 9 ()
01-13 22:41:10.487  1492  1953 E WifiVendorHal: Failed to start vendor HAL
01-13 22:41:10.487  1492  1953 E WifiNative: Failed to start vendor HAL
01-13 22:41:10.487  1492  1953 E WifiNative: Failed to start Hal
01-13 22:41:10.487  1492  1953 E WifiClientModeManager: Failed to create ClientInterface. Sit in Idle
Thank you!!
 

eng.stk

Senior Member
Mar 29, 2011
6,746
58,312
263
Oh that's great!
Do you have any idea what could the problem be then? Magisk module is enabled, can't enable WiFi though.
Here's the logcat

Code:
01-13 22:41:06.467   957   957 E [email protected]: get_mac_from_nv: Get nv mac file failed: Permission denied
01-13 22:41:08.274   957   957 E [email protected]: get_mac_from_nv: Get nv mac file failed: Permission denied
01-13 22:41:10.486   957   957 E [email protected]: Failed to access driver state control param No such file or directory, 2: No such file or directory
01-13 22:41:10.486   957   957 E [email protected]: Failed to load WiFi driver
01-13 22:41:10.486   957   957 E [email protected]: Failed to initialize firmware mode controller
01-13 22:41:10.486   957   957 E [email protected]: Wifi HAL start failed
01-13 22:41:10.487  1492  1953 E HalDevMgr: Cannot start IWifi: 9 ()
01-13 22:41:10.487  1492  1953 E WifiVendorHal: Failed to start vendor HAL
01-13 22:41:10.487  1492  1953 E WifiNative: Failed to start vendor HAL
01-13 22:41:10.487  1492  1953 E WifiNative: Failed to start Hal
01-13 22:41:10.487  1492  1953 E WifiClientModeManager: Failed to create ClientInterface. Sit in Idle
Thank you!!
You provided the answer.
So either the module is not loading correctly or the ROM you're using has a different CAF base that makes HAL/driver render imcompatible.
Try the magisk module solo in Magisk 21.2. What ROM is that in which device?
 
  • Like
Reactions: Boing7898

Boing7898

Member
Aug 10, 2011
44
8
28
You provided the answer.
So either the module is not loading correctly or the ROM you're using has a different CAF base that makes HAL/driver render imcompatible.
Try the magisk module solo in Magisk 21.2. What ROM is that in which device?
First of all thanks for your reply, I know you're not really interested in helping debugging with custom ROMs. Custom kernels are pretty important to me so if they won't work with this ROM I might be forced to switch.
I'm running Magisk 21.2, with no other modules than the AnyKernel3 helper module. ROM is LineageOS 18.1, latest update, on Oneplus 8T.
 

eng.stk

Senior Member
Mar 29, 2011
6,746
58,312
263
First of all thanks for your reply, I know you're not really interested in helping debugging with custom ROMs. Custom kernels are pretty important to me so if they won't work with this ROM I might be forced to switch.
I'm running Magisk 21.2, with no other modules than the AnyKernel3 helper module. ROM is LineageOS 18.1, latest update, on Oneplus 8T.

Using Bluspark on LOS 18.1 fine. Apart from WiFi everything seems to work perfectly :)
Try this one for me
 

Attachments

Boing7898

Member
Aug 10, 2011
44
8
28
Try this one for me
Sadly it still doesn't work :(
Restarted twice after flashing, waited some time after boot, checked the Magisk module was enabled.
Logs look the same, here they are:
Code:
01-16 09:54:19.749   955   955 E [email protected]: get_mac_from_nv: Get nv mac file failed: Permission denied
01-16 09:54:21.557   955   955 E [email protected]: get_mac_from_nv: Get nv mac file failed: Permission denied
01-16 09:54:23.354     0     0 E         : [20210116_09:54:23.353264]@0 [SWARPCHG][mp2650_float_voltage_write]vfloat_mv = 4435
01-16 09:54:23.454     0     0 E         : [20210116_09:54:23.353680]@0 [SWARPCHG][mp2650_float_voltage_write]set the same fv 0x72, return!
01-16 09:54:23.454     0     0 W healthd : battery l=72 v=4062 t=30.3 h=2 st=2 c=-153000 fc=2067 cc=5 chg=u
01-16 09:54:23.773   955   955 E [email protected]: Failed to access driver state control param No such file or directory, 2: No such file or directory
01-16 09:54:23.773   955   955 E [email protected]: Failed to load WiFi driver
01-16 09:54:23.773   955   955 E [email protected]: Failed to initialize firmware mode controller
01-16 09:54:23.773   955   955 E [email protected]: Wifi HAL start failed
01-16 09:54:23.775  1449  2159 E HalDevMgr: Cannot start IWifi: 9 ()
01-16 09:54:23.775  1449  2159 E WifiVendorHal: Failed to start vendor HAL
01-16 09:54:23.775  1449  2159 E WifiNative: Failed to start vendor HAL
01-16 09:54:23.776  1449  2159 E WifiNative: Failed to start Hal
01-16 09:54:23.776  1449  2159 E WifiClientModeManager: Failed to create ClientInterface. Sit in Idle
Thanks man!
 
  • Like
Reactions: eng.stk

ectoplasma22

Senior Member
Jun 8, 2013
1,017
1,946
153
France
Tried but WiFi and hotspot are still broken
But thank you so lucky for looking into it, it would be amazing to get it to work perfectly battery life on LOS is si much better with your kernel
 
  • Like
Reactions: Boing7898

eng.stk

Senior Member
Mar 29, 2011
6,746
58,312
263
Sadly it still doesn't work :(
Restarted twice after flashing, waited some time after boot, checked the Magisk module was enabled.
Logs look the same, here they are:
Code:
01-16 09:54:19.749   955   955 E [email protected]: get_mac_from_nv: Get nv mac file failed: Permission denied
01-16 09:54:21.557   955   955 E [email protected]: get_mac_from_nv: Get nv mac file failed: Permission denied
01-16 09:54:23.354     0     0 E         : [20210116_09:54:23.353264]@0 [SWARPCHG][mp2650_float_voltage_write]vfloat_mv = 4435
01-16 09:54:23.454     0     0 E         : [20210116_09:54:23.353680]@0 [SWARPCHG][mp2650_float_voltage_write]set the same fv 0x72, return!
01-16 09:54:23.454     0     0 W healthd : battery l=72 v=4062 t=30.3 h=2 st=2 c=-153000 fc=2067 cc=5 chg=u
01-16 09:54:23.773   955   955 E [email protected]: Failed to access driver state control param No such file or directory, 2: No such file or directory
01-16 09:54:23.773   955   955 E [email protected]: Failed to load WiFi driver
01-16 09:54:23.773   955   955 E [email protected]: Failed to initialize firmware mode controller
01-16 09:54:23.773   955   955 E [email protected]: Wifi HAL start failed
01-16 09:54:23.775  1449  2159 E HalDevMgr: Cannot start IWifi: 9 ()
01-16 09:54:23.775  1449  2159 E WifiVendorHal: Failed to start vendor HAL
01-16 09:54:23.775  1449  2159 E WifiNative: Failed to start vendor HAL
01-16 09:54:23.776  1449  2159 E WifiNative: Failed to start Hal
01-16 09:54:23.776  1449  2159 E WifiClientModeManager: Failed to create ClientInterface. Sit in Idle
Thanks man!
Tried but WiFi and hotspot are still broken
But thank you so lucky for looking into it, it would be amazing to get it to work perfectly battery life on LOS is si much better with your kernel
I can still try some stuff, let me know how it goes :)
 

Attachments