• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[KERNEL] Jugs 0.3 [11/06/11] [1.89ghz OC/UV/BFQ/BLN] [Team Kang]

Search This thread

juntjoo

Senior Member
Apr 23, 2007
479
10
Never mind. Found the setting in super user

Sent from my SGH-T989 using Tapatalk
 

mikeyinid

Senior Member
Sep 4, 2010
8,875
4,000
Boise
Hey Roman, maybe you and da-g can get together to get the gpu tweaks and 54mhz minimum implemented into jugs :)
Sent from my SGH-T989 using Tapatalk
 

Da_G

Inactive Senior RD / Moderator Emeritus
Aug 20, 2007
3,320
1,553
Riverside, CA
Depends on the test - most of them can't push stock settings - But the "Monjori Shader Benchmark" from market shows 43 fps @ stock 266MHz max GPU and 51 fps @ 300MHz OC :) Real world, you are probably right.. but the GPU also scales so provided the proper speed steppings it won't park up at the highest speed unless it needs to :)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 65

    Team Kang Presents

    Jugs!

    Standard Disclaimer - We are in no way responsible for what you do to your phone. If you destroy your $500 device and try and blame us we will laugh at you. Always read and ensure you know what you are doing before attempting anything***

    What the hell this is

    • OC up to 1.836 ghz
    • should boot into stock frequencies
    • added BFQ I/O scheduler and made default
    • patched drivers from newer Telus 989D source
    • BLN
    • added zram
    • working init.d support
    • insecure
    • and much much more. Check the latest additions in the change log!

    Change Log
    Code:
    [B][U]0.3 - Nov 6[/U][/B]
    - added BLN! (use neldar's BLN control app from the market)
    - tweaked ondemand gov
    - added 1.89ghz step
    - any weirdness going past 1.72 should be fixed
    - added snapdragon compiler flag optimizations
    
    [B][U]0.2 - Nov 4[/U][/B]
    - added zram (must enable through init script, more on it below) - ALSO LOL WE DONT NEED THIS WE HAVE 999999MB OF RAM
    - patched drivers from Telus 989D source (newer, less debugging)
    - increased voltages to more stock-like values (uv by yourself)
    - boots up into stock frequencies (384 - 1512) (oc by yourself)
    
    0.1 - Nov 3
    - initial release


    Bugs
    Right now, there doesn't seem to be any bugs. However, if you do get a random reboot, or are having boot loops please provide me with a log and follow the instructions.


    1. Flash kernel (make sure you've wiped cache & dalvik cache)
    2. After it bootloops/freezes, immediately boot into recovery (unplug usb, hold power, vol +/vol -, let go of power when you see Samsung logo)
    3. Code:
      adb pull /proc/last_kmsg
    4. upload that last_kmsg for me (please don't post it, it can get long!)


    Voltage Control
    You can control it via shell/init.d scripts as follows

    [ to over volt ALL frequencies by 25000 uv (microvolts) ]
    Code:
    echo "+25000" > /sys/devices/system/cpu/cpufreq/vdd_table/vdd_levels
    [ to under volt ALL frequencies by 25000 uv (microvolts) ]
    Code:
    echo "-25000" > /sys/devices/system/cpu/cpufreq/vdd_table/vdd_levels

    [ to set a specific frequency (ie 1.18 GHz) with a specific voltage (ie 1.0875 volts) ]
    Code:
    echo "1188000 1087500" > /sys/devices/system/cpu/cpufreq/vdd_table/vdd_levels


    Clock Control
    Just about any OC app will work just fine. By default, the kernel sets the max frequency to the highest frequency available. You can change this by adding a few lines to an init.d script (or run commands in a shell).

    For instance, setting stock freqs would look like this
    Code:
    (su if in shell)
    echo 384000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    echo 1512000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    
    echo 1 > /sys/devices/system/cpu/cpu1/cpufreq/online
    echo 384000 > /sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq
    echo 1512000 > /sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq

    zRam
    To enable zRam you must execute the following commands in shell as root
    Code:
    mkswap /dev/block/zram0
    swapon /dev/block/zram0

    This needs to be run on every reboot.

    You can check to see if it's enabled/actually being used:

    Code:
    $ free
                 total         used         free       shared      buffers
    Mem:        801980       664364       137616            0        50656
    -/+ buffers:             613708       188272
    Swap:        98300            0        98300

    free = 0? it's not being used. usually takes a while to build up (especially with the megashittons of RAM we have)

    Misc
    - Make sure you know how to get into recovery via HARDWARE KEY COMBO - I HAVE WARNED YOU
    - Please do not include this with any ROMs
    - Source available on my github (link in sig)
    - You can use the kernel with any ROM out currently.

    Download
    Jugs 0.3 - CWM Flashable - enables zRAM by default & adds BLN capability​
    You can use either SystemTuner or my OC app to control this kernel!
    7
    saved oneone one
    6
    its not a kernel issue, its the permissions that are set on the script that you dont edit or remove from your roms.

    its setting root:system on /sys/devices/system/cpu/mfreq and perm 220 on it. this makes the min freq adjustments not still with apps that are not in the group root:system

    there is quite a large bit of crap in that script that i've mentioned a few times should be edited out at the very least.

    Please STOP spewing crap and non-sense about kernels.

    mfreq is used to FORCE MAX FREQUENCY for CPU governors and has ABSOLUTELY NOTHING to do with min frequency adjustments. It is set to root write only as protection against accident overrides from user space binaries.

    here's the code snippet from cpufreq from the kernel:

    Code:
    static ssize_t store_mfreq(struct sysdev_class *class,
    			struct sysdev_class_attribute *attr,
    			const char *buf, size_t count)
    {
    	u64 val;
    
    	if (strict_strtoull(buf, 0, &val) < 0) {
    		pr_err("Invalid parameter to mfreq\n");
    		return 0;
    	}
    	if (val)
    		override_cpu = 1;
    	else
    		override_cpu = 0;
    	return count;
    }
    
    static int set_cpu_freq(struct cpufreq_policy *policy, unsigned int new_freq)
    {
    	int ret = 0;
    	struct cpufreq_freqs freqs;
    
    	freqs.old = policy->cur;
            if ([COLOR="Red"]override_cpu[/COLOR]) {
    		[COLOR="Red"]if (policy->cur == policy->max)[/COLOR]
    			return 0;
    		else
    			[COLOR="red"]freqs.new = policy->max;[/COLOR]
    6
    New version posted in OP
    6
    its not a kernel issue, its the permissions that are set on the script that you dont edit or remove from your roms.

    its setting root:system on /sys/devices/system/cpu/mfreq and perm 220 on it. this makes the min freq adjustments not still with apps that are not in the group root:system

    there is quite a large bit of crap in that script that i've mentioned a few times should be edited out at the very least.

    Can you please refrain from posting ****, atleast in my thread, that you can't backup with proof or actual knowledge.

    Thanks.

    Sent from my SGH-T989 using Tapatalk