• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[KERNEL][Jul 13] ImageBreaker Kernel for Galaxy S8 and S8+ (Exynos) v0.5

Search This thread

Devries

Senior Member
Mar 7, 2012
176
208
IF YOU FLASH CUSTOM KERNEL, YOU WILL LOSE YOUR WARRANTY, KNOX WILL TRIGGER TO 0x1, I AM NOT RESPONSIBLE FOR ANY DAMAGE DONE TO YOUR DEVICE.

FEATURES:
Based on G95XFXXU1AQF7 source
Compiled with Linaro GCC 6.3
Ofast and some GCC optimizations
Some architecture optimizations
Many kernel debug options debloated
Memory management improvement

NOTICE:
Make sure your DATA partition is not encrypted,
this kernel do not support F2FS,
and integrated SuperSU, do not support magisk.

DOWNLOAD:
https://drive.google.com/file/d/0BzF1xgn4nprrOWRVRkdYRWhlbXc/view?usp=sharing

SUPPORT:
If you like my work, feel free to click thanks button, reply this thread about your experience,
or give me a small donation: https://www.paypal.me/devriesl

Thanks/Credits:
jesec for his patch to fix fingerprint problem
Tkkg1994 for his flash script via TWRP

XDA:DevDB Information
ImageBreaker Kernel, Kernel for the Samsung Galaxy S8

Contributors
Devries, jesec, Tkkg1994
Source Code: https://github.com/DevriesL/SM-G950F_ImageBreaker

Version Information
Status: Stable
Current Stable Version: v0.5

Created 2017-07-05
Last Updated 2017-07-13
 
Last edited:

Devries

Senior Member
Mar 7, 2012
176
208
thanx & will wait for next version. Thank you.

Finally I found that integrated both SuperSU and magisk is impossible,
the only one way to support magisk is removing SuperSU support in ramdisk,
but I do not want to other flash script change my ramdisk especially fstab,
so I consider do not support magisk, sorry.
 

mrjoy

Senior Member
Aug 24, 2012
2,472
168
The Heaven Of Punjab
Finally I found that integrated both SuperSU and magisk is impossible,
the only one way to support magisk is removing SuperSU support in ramdisk,
but I do not want to other flash script change my ramdisk especially fstab,
so I consider do not support magisk, sorry.

but all of other kernels supported by both SuperSu & Magisk. Even you can take help from them.
Else you want to make it only with SuperSu then its ok. But thanx for your response. Good day.
 

Devries

Senior Member
Mar 7, 2012
176
208
but all of other kernels supported by both SuperSu & Magisk. Even you can take help from them.
Else you want to make it only with SuperSu then its ok. But thanx for your response. Good day.

They support both SuperSu & Magisk because they do not integrated anything in their kernel, you can flash SuperSu & Magisk manually,
But I integrated SuperSU because I do not want other flash script change fstab.
 

mrjoy

Senior Member
Aug 24, 2012
2,472
168
The Heaven Of Punjab
They support both SuperSu & Magisk because they do not integrated anything in their kernel, you can flash SuperSu & Magisk manually,
But I integrated SuperSU because I do not want other flash script change fstab.

you mean if i flash magisk manually then will it support with your kernel? Because last time i tried to install magisk manully after flashing your kernel but it was giving error in TWRP.
 

jasonce

Member
Jun 28, 2017
11
4
F2FS is not perform good as EXT4 on S8, Is this true? And does AQF7 kernel can flash with older version rom and boot loader? Thanks a lot!
 
Last edited:

Devries

Senior Member
Mar 7, 2012
176
208
F2FS is not perform good as EXT4 on S8, Is this true? And does AQF7 kernel can flash with older version rom and boot loader? Thanks a lot!

It's not the main reason that my kernel do not support F2FS. S8 TouchWiz HAL layer do not compatible with F2FS, enable it in userdata will introduce some stability issue.
It's no problem and I will update kernel to QG5.
 
  • Like
Reactions: jasonce

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    IF YOU FLASH CUSTOM KERNEL, YOU WILL LOSE YOUR WARRANTY, KNOX WILL TRIGGER TO 0x1, I AM NOT RESPONSIBLE FOR ANY DAMAGE DONE TO YOUR DEVICE.

    FEATURES:
    Based on G95XFXXU1AQF7 source
    Compiled with Linaro GCC 6.3
    Ofast and some GCC optimizations
    Some architecture optimizations
    Many kernel debug options debloated
    Memory management improvement

    NOTICE:
    Make sure your DATA partition is not encrypted,
    this kernel do not support F2FS,
    and integrated SuperSU, do not support magisk.

    DOWNLOAD:
    https://drive.google.com/file/d/0BzF1xgn4nprrOWRVRkdYRWhlbXc/view?usp=sharing

    SUPPORT:
    If you like my work, feel free to click thanks button, reply this thread about your experience,
    or give me a small donation: https://www.paypal.me/devriesl

    Thanks/Credits:
    jesec for his patch to fix fingerprint problem
    Tkkg1994 for his flash script via TWRP

    XDA:DevDB Information
    ImageBreaker Kernel, Kernel for the Samsung Galaxy S8

    Contributors
    Devries, jesec, Tkkg1994
    Source Code: https://github.com/DevriesL/SM-G950F_ImageBreaker

    Version Information
    Status: Stable
    Current Stable Version: v0.5

    Created 2017-07-05
    Last Updated 2017-07-13
    1
    微博观光团?

    Sent from my Sony Xperia Z3 using XDA Labs
    1
    F2FS is not perform good as EXT4 on S8, Is this true? And does AQF7 kernel can flash with older version rom and boot loader? Thanks a lot!

    It's not the main reason that my kernel do not support F2FS. S8 TouchWiz HAL layer do not compatible with F2FS, enable it in userdata will introduce some stability issue.
    It's no problem and I will update kernel to QG5.
    1
    Hi,

    I compiled the source using GCC-6.3 linaro.
    I got the following errors:
    ./build.sh: line 28: ./mkbootfs: No such file or directory
    usage: mkbootimg [-h] --kernel KERNEL [--ramdisk RAMDISK] [--second SECOND]
    [--cmdline CMDLINE] [--base BASE]
    [--kernel_offset KERNEL_OFFSET]
    [--ramdisk_offset RAMDISK_OFFSET]
    [--second_offset SECOND_OFFSET] [--os_version OS_VERSION]
    [--os_patch_level OS_PATCH_LEVEL] [--tags_offset TAGS_OFFSET]
    [--board BOARD] [--pagesize {2048,4096,8192,16384}] [--id] -o
    OUTPUT
    mkbootimg: error: unrecognized arguments: --dt dt.img

    Looks like the system/core/mkbootimg does not support --dt option.
    How can i build these mkbootimg and mkbootfs tools?

    BR,
    Yegnesh

    https://forum.xda-developers.com/showthread.php?t=2670512